02-17-09 06:09 PM
105 ... 2345
tools
  1. RLPoloBoy380's Avatar
    Nice game. I also agree that the screen click would be nice to rotate the pieces.
    01-16-09 05:39 PM
  2. nightfishing's Avatar
    I would like to see screen click used to "drop" blocks. Once you get used to it, swiping to turn is pretty comfortable.
    01-16-09 05:45 PM
  3. liveify's Avatar
    I also agree with click to rotate pieces, click to drop blocks would be nice to but I have more of a problem turning them and that is more crucial to the game than dropping
    01-16-09 08:55 PM
  4. jcharris08's Avatar
    i actually like the swipe, and plus when people are watching they are much more "awed" by the fact that i'm turning the device and swiping across the screen. But in general I'd rather keep the swipe and click to drop a block, would speed the game up a lot. i find myself swiping down constantly to drop blocks.
    01-16-09 08:57 PM
  5. RobUM2011's Avatar
    i find myself swiping down constantly to drop blocks.
    X2

    A quick way to drop would be great, and I think a click would be a good way to do it. I find myself using both thumbs to do quick down swipes..
    01-16-09 09:51 PM
  6. TouringMN's Avatar
    I successfully downloaded the game - thanks for the clear instructions.

    But I can not rotate the pieces. I see that it is working for others; so perhaps it is a user error. I have not downloaded any other games, so is there a missing 'driver', 'utility', or 'component' that GetJar is expecting for Titris to work?

    I was disappointed, needed another way to waste some time with my new Christmas toy.

    All suggestions and input is welcomed.

    Thanks
    01-19-09 06:51 AM
  7. nightfishing's Avatar
    1. make sure you start the game with the phone in landscape.

    2. rotate the pieces by swiping left or right. (it takes some time to get used to "swiping" on the storm in general...
    01-19-09 12:45 PM
  8. bigwill1223's Avatar
    yea i sure like this game more than i thought i was going to. but i DO find myself with the phone crooked and my head tilted also, thinking why the eff is it going to the side, oh yea
    01-19-09 04:41 PM
  9. nightfishing's Avatar
    Updated.

    Click now drops the blocks!

    Big THANK YOU to the dev. I have two looong days of flights this week and between Tiltris and Season 2 of Dexter I am set :-)
    01-19-09 09:02 PM
  10. RobUM2011's Avatar
    Updated.

    Click now drops the blocks!
    Can someone else confirm this? I downloaded it again but clicking isn't dropping?
    01-19-09 09:34 PM
  11. nightfishing's Avatar
    1.3 hasn't shown up on the site, yet, apparently.

    Sorry.
    01-19-09 09:40 PM
  12. RobUM2011's Avatar
    1.3 hasn't shown up on the site, yet, apparently.

    Sorry.
    No worries
    01-19-09 09:42 PM
  13. nightfishing's Avatar
    up now :-)
    01-20-09 06:59 AM
  14. FreD_BeaR's Avatar
    I still cant believe there is no highscore. I find it to be a waste of time to play it without one.
    01-20-09 07:50 AM
  15. SkoogusMaximus's Avatar
    level 10 speed is ridiculous, but much better upgrade than i thought it would be. This really showcases what the storm can do on a very simple level. I want about a thousand more apps like it.
    01-20-09 08:37 AM
  16. RobUM2011's Avatar
    up now :-)
    Cool! thanks!

    EDIT: This makes the game about 100 times better...
    Last edited by RobUM2011; 01-20-09 at 09:05 AM.
    01-20-09 08:57 AM
  17. httrdd's Avatar
    Works great and a big thanks!
    01-22-09 04:00 AM
  18. loooney2ns's Avatar
    Another tip for those having trouble

    When you go to quick download (OTA) and enter the code and hit the enter key on your keyboard, it sometimes adds a space, which the getjar wap site misconstrues and won't let you get what you want. Make sure that space isn't there at the end of the download code!
    Thanks for the tip!
    02-06-09 08:45 PM
  19. rydeordie's Avatar
    I updgraded to 103 and lost this. Tried to dl again and getting 40256 cannot be found... Any idea where I can get it again? And.. there is no space. I tried a hundred times, just to make sure.
    02-11-09 08:42 PM
  20. sccrmastr's Avatar
    When i type in the code and hit enter (i checked for the space and that is not the problem) it says the code is invalid?
    02-11-09 08:55 PM
  21. Robert Calhoun's Avatar
    I'm getting "Quick Download Code 40256 in invalid..." and to check back in one day...

    I searched by name in all apps and looked at the Storm apps... Nada. I still have the app after going to .103 and there is not a space at the end...

    I can figure out why you would want such a cool app tp be so hard to find...

    Well I guess I'll have to check back for the updated version...
    02-11-09 09:01 PM
  22. rabbitgtdguy's Avatar
    I had the same exact problem tonight trying to download it as well. Running on .103 as well. Not for this...but my Browser is randomly dissappearing as well!

    Joe
    02-11-09 09:18 PM
  23. hennesseystealth's Avatar
    same here...
    02-12-09 01:08 AM
  24. Djaries's Avatar
    Ugh,,, Someone please save our gaming souls! bad links all over the place!
    02-12-09 03:06 PM
  25. HarlyFan's Avatar
    Someone needs to have the right code for this?
    02-12-09 08:03 PM
105 ... 2345
LINK TO POST COPIED TO CLIPBOARD