1. mishap2010's Avatar
    Hi all,

    I've looked everywhere for help but it seems like people have one problem or the other, while my phone is going wrong IN EVERY WAY :P

    I have a Storm, got it over a year ago, out of warranty.

    OK, here's what's wrong:

    -Phone began dying unexpectedly a few weeks back, after only one phone call (or sometimes after only being off the charger for 10 min)

    -Phone had died completely now. All it does is flash the red light, then show the hour glass, then repeat over and over.

    -Won't charge when plugged into the wall

    -Won't charge via USB on laptop

    -Not recognized by computer

    -Not recognized by Desktop Manager (when plugged it it will "connect" briefly, then disappear

    -Sometimes, when plugged into either the wall or laptop, a white screen will come up with a charging battery, but never stays for more than 5 min, then goes back to hourglass.

    -Also won't connect on my desktop computer

    -Despite many battery pulls, nothing has managed to get the phone to start charging

    -Took it to Verizon to see if the battery was the problem, worker replaced it with a new battery and still nothing. Continued doing the red light/ hourglass thing. So it's not the battery.

    -Used a friend's bb wall charger and it also didn't charge there.

    My final guess is that it's the usb port in the phone, but I don't see how. The little pins aren't in the phone, so I don't understand how it could be damaged. But the pins in the usb cord and charger are uneven (the two outermost pins on each side are more forward than the middle three, which are set farther back. I don't know if that's the problem?

    I've tried to be as thorough as possible with this explanation; I'm really confused and frustrated because nothing is working, despite trying two different wall chargers, plugging it to two different computers, and trying a new battery. My data is not backed up and if I could get it working for just enough time to get my data off, then that would be fine.

    Thank you in advance for your help!
    10-12-10 03:34 AM
  2. icesteve's Avatar
    Try plugging it to your computer, open dm, go to where you can select os's and downgrade to 4.7 and see if it will recognize it then. I had this same problem it wouldn't connect or charge, but it let me downgrade to 4.7 then booted and charged. After I had done that my screen went out so I had to go to vzw anyway, and I only had a one year warranty but the vzw lady switched it to 2yr coverage and gave me a replacement. Its worth a shot either way

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-10 09:24 AM
  3. dts3204's Avatar
    My Original Storm the USB port crapped out. It also seemed to drain my batteries. Go back to Verizon.
    10-12-10 12:08 PM
  4. mishap2010's Avatar
    Icesteve, I did what you suggested and while the white screen with the battery flashed for about 5 minutes, it went right back to doing nothing.

    Kenneth, if I go back to Verizon, they'll just tell me I need a new phone (which they won't give me because I'm out of warranty).

    Gaaaaahhhhh
    10-12-10 04:42 PM
  5. icesteve's Avatar
    After down grading does it at least get recognized by the computer? If so you could backup everything, do a full wipe with bbsak and try loading a Os. If that still doesn't work I'd just suggest going to different vzw stores and pretend like you don't know about your warranty and you may get lucky with a nice rep like I was.

    Have you tried pulling the battery with it plugged into the wall and puting it back in and unplugging and plugging back in, sounds stupid but its happened to me a couple times as to where I thought my phone was sol but after messing with it that way and letting it sit on the charger after for a while it charged.

    Other than that not sure what else you can try

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-10 07:38 PM
LINK TO POST COPIED TO CLIPBOARD