1. bambuco's Avatar
    Me and my manager both came to VZW for S2's coming from a 8330 Sprint and 8350i Nextel (respectively). We both activated within days and both are on our company's BES in mid February. We each were on BES while at Sprint/Nextel prior to coming to VZW.

    So here's were things get interesting....

    We had the 900 minute plans and unlimited data (that includes SMS & MMS unlimited). I don't send MMS frequently, only when working with others on different carriers that don't have/use Blackberry. Ever since joining VZW i had never received a picture message (MMS). We could send out picture messages but never received any.

    After calling this in to VZW they said to check our IT Policy to see if we have any restrictions regarding MMS. Note that we were previously on BES with Sprint/Nextel and did not have any problems. So i contact our IT and had them check our policy... only to confirm there is no policy setup on our BES regarding any messaging services (Emial, SMS, MMS).

    So after doing Security Wipe, deleted/pushing MMS service books, reactivating the phones... they decided to send us "Like New Re-Certified" (refurb's) devices. We tested the refurbs before activating the enterprise on both. We were able to receive and send MMS type messages!!

    Given that it seems pre-BES activation MMS is working...so it seemed that our IT Policy on our BES was the problem, right? Well, after activating BES and testing MMS again we went to our IT have them check the Policy a final time. Again, there is no restrictions on MMS, SMS nor Email established.

    Now we call into VZW and run through all their tests and they suggest the only resolution is to have our BES admin contact a RIM server admin and trouble-shoot some "hidden" policy that could be causing all these. At this time my boss had gotten a call from one of our IT BES admin's and conferenced in a Tier 2 or 3 VZW tech rep. they began doing all the same tests (check MMS service books, remove/push serv books, security wipe). Our BES admin and T2/3 rep starting to go back and forth clarifying at what point the MMS goes out and our BES admin repeating that there is no policy in place that would cause MMS to shut down after activating the BES. It would seem that either the devices were not properly activating or the transmission to them during the activation is causing the MMS to stop working.

    So then the conf call ended with our BES admin & T2/3 tech rep agreeing to the following: after completely removing the IT policy (not just the BES but a policy that might have been on the refurb's themselves) we would first test the MMS confirming it works then activate BES and verify if MMS goes down. IF MMS went down then our BES admin would have to contact RIM to problem solve.


    We now had to remove the IT policy off the devices, a new Tier 2 tech rep was assigned to us who then proceeded to give us instructions how to remove the IT policy. After trying to use Command Prompt entering what seemed to be in to the "In Motion" folder, we then entered a register "hack" entering a path command in the IN MOTION folder a file named "policy.bin". So we add the path and plug in our devices and nothing happened.... even tried to remove some of the databases related to "policy" but didn't work (seemed we tried to change the Firewall setting on the device to disabled).

    NOTE: i was very close of suggesting JLCommander, to brick the device and install the OS, accomplishing a COMPLETE DEVICE WIPE....but figured its not the best thing to do since VZW didn't suggest, i just kept my mouth shut.

    So we didn't get the Policy removed nor able to change the Firewall setting to "disabled". The T2 tech rep then said lets now go to the store where they would have 2 new devices (not refurb's, but brand new) to ensure a clean slate to begin. He searched and find a store that would have 2 devices waiting for us, gave us the name of the store manager and that he would have the devices waiting for us.

    We left then to the store, asked for the store manager and told him we were the two sent to get new Storm2 devices. He shrugged us off and instructed one of his sales reps to help us. OK... so we get a rep and begins going the same thing we've done 5 times already, there's even a note in our ticket in the VZW account stating we were to pick up new devices!!! My boss flipped, began to explain we had already done the dance, read our ticket and please give us the new devices. The store manager comes in and tries to help, he keeps repeating "All i was told was to look at them, not replace them" over and over again. I tried calling back our T2 tech rep who told us what to do....but the muthaf#cker's phone kept going to vmail and his inbox was full!!!!

    So... we left. F#ck this, we had a 2pm conf call schedule with VZW and our BES admin so we'd let them know we did not get the "new" devices so this new testing would be pointless since we don't have a clean slate to start with.



    The point of this was to share my experience and provide details to those who are familiar with each system. I do not want out of VZW, i do not want another phone other than a Storm2. I want MMS to work while on BES. We use MMS in construction when asking for details regarding a specific part or material and we don't all have BB's nor on the same carrier.

    Let me know if you've had any problems with MMS and BES. I just updated the latest refurb to .607 OS and restored some items. Not going to bring all my apps back on since we might be getting new devices. I'm curios to know anyone had any problems and how they were addressed.
    04-10-10 03:34 PM
  2. jbdale's Avatar
    Well that sucks I am sorry. I am on a company network and don't have problems. However, the problems you are describing do not sound device related to me, more your company's net work despite what you stated in your post.
    04-10-10 03:46 PM
  3. neocaster's Avatar
    Not had any such problems (BIS user), but I have had the "Let's do everything tier 1 did before we look any further" frustration before, and often, with every carrier, every utility, every cable company, h*ll, everybody! Period. At some point I ask them how much time I have to waste so that their device can save me some. T-Mobile was the best about keeping the problem-solving ball rolling.
    04-10-10 04:15 PM
  4. Gav508's Avatar
    Well that just plain sucks. All that time spent and the problem isn't fixed. It will probably end up being a small glitch somewhere in the IT policy on your end. Hope it all works out for you because the Storm2's are actually great phones.
    04-10-10 04:45 PM
  5. bambuco's Avatar
    UPDATE:

    So i left out that i txt mssg'd a Tier 2 rep that tried to help us remove the IT policy on Friday letting him know what went down at the VZW store. He txt'd back saying that he was going to "send us new devices ASAP to our office" so today my Boss and I got our new (refurb) devices. So we get in touch with the Tier 2 rep telling him we got the devices and then began the Phone Activation. Once they both were activated we then tested MMS capabilities, we were successful.

    So... the moment of truth: would MMS go away once we activated the Enterprise EVEN THOUGH our IT policy has no "restrictions" with messaging transmission. We activated and... nothing, MMS stopped working. We're told we can send but we cannot receive MMS messages while on our BES. See the screen shot (thanks to CaptureIt, a must have!!!) and see how i've got a policy enabled and locked. Before BES was activated it was simply set to Disable and no lock.


    Tomorrow we'll conference between our BES admin's & the Tier 2 tech rep and confirm whose got the problem... i think is going to come to our BES admin contacting RIM to review and double check our policies.

    I appreciate the comments, keep them coming. I'll update tomorrow after our call, now i've got to start loading back all my apps, didn't quite make it in the restore... =D
    Last edited by bambuco; 04-13-10 at 11:04 PM.
    04-13-10 10:57 PM
  6. paulwright1's Avatar
    So then I guess its not the devices. Sounds more like a BES issue. Hopefully they can get it figured out. Does the IT guys have BB's as well?
    04-13-10 11:02 PM
  7. bambuco's Avatar
    So then I guess its not the devices. Sounds more like a BES issue. Hopefully they can get it figured out. Does the IT guys have BB's as well?
    Not all of them do... and when it comes down to sharing pic's i think it hasn't been an issue since they BBM it to eachother since a majoirty of our IT's have Blackberrys'.... but out in the field we're only two that have BB's and need to share with others on different networks and devices.
    04-13-10 11:07 PM
  8. bambuco's Avatar
    Well that just plain sucks. All that time spent and the problem isn't fixed. It will probably end up being a small glitch somewhere in the IT policy on your end. Hope it all works out for you because the Storm2's are actually great phones.
    YES THEY ARE. I don't want anything else. Its part of my 3 yr plan: stage1 to get the Storm2, stg2 is to get the BB watch (late 2010), stg3 get a watch phone (like those popular in EURO right now, i'll wait till they come over and subsidized by carriers). =D

    But in the meantime, gotta get these Storm2's working!!
    04-13-10 11:09 PM
  9. paulwright1's Avatar
    Not all of them do... and when it comes down to sharing pic's i think it hasn't been an issue since they BBM it to eachother since a majoirty of our IT's have Blackberrys'.... but out in the field we're only two that have BB's and need to share with others on different networks and devices.
    So for the IT guys that have BB's have them try sending an MMS message and see if they have the same issue.
    04-13-10 11:12 PM
  10. dkingsf's Avatar
    UPDATE:

    So i left out that i txt mssg'd a Tier 2 rep that tried to help us remove the IT policy on Friday letting him know what went down at the VZW store. He txt'd back saying that he was going to "send us new devices ASAP to our office" so today my Boss and I got our new (refurb) devices. So we get in touch with the Tier 2 rep telling him we got the devices and then began the Phone Activation. Once they both were activated we then tested MMS capabilities, we were successful.

    So... the moment of truth: would MMS go away once we activated the Enterprise EVEN THOUGH our IT policy has no "restrictions" with messaging transmission. We activated and... nothing, MMS stopped working. We're told we can send but we cannot receive MMS messages while on our BES. See the screen shot (thanks to CaptureIt, a must have!!!) and see how i've got a policy enabled and locked. Before BES was activated it was simply set to Disable and no lock.


    Tomorrow we'll conference between our BES admin's & the Tier 2 tech rep and confirm whose got the problem... i think is going to come to our BES admin contacting RIM to review and double check our policies.

    I appreciate the comments, keep them coming. I'll update tomorrow after our call, now i've got to start loading back all my apps, didn't quite make it in the restore... =D
    My security firewall looks exactly the same as this screen shot, through my company BES and I can send and receive MMS pic/video etc. with no problems.
    04-14-10 05:18 PM
  11. bambuco's Avatar
    FINAL UPDATE:

    PROBLEM RESOLVED!!!

    Turns out it was a BES problem, not within the messaging policy but with the Internet policies. What i was told was that in the past in order to control data usage and keep bills down they placed a restriction to not allow Internet Browser becuase it used more data than Blackberry Browser. Our IT admin started to play around with some policies and noticed that restriction and found that affected our MMS capabilities. He changed to remove the restriction and we were able to send/receive MMS messages!

    I'm guessing that the way MMS transmit data is similar in certain ways to how the Browser gets its data. I'm sure others more tech-savvy will correct me, but i'm glad i now can send/receive MMS.

    Something to add: there was not a new Storm2 in any of the VZW stores in Jacksonville, FL. Does this strike a little odd? How could it be, are they holding out their new stock in stores and rather ship me a new phone (whihc i never got, all refurbs were sent) and not take one from their shelves??? Each store said they did not have any new Storm2's and i started to wonder if there's something coming soon like maybe they trying to phase it out or something along those lines....
    04-17-10 07:48 PM
LINK TO POST COPIED TO CLIPBOARD