1. ksaabd's Avatar
    Good Afternoon, last week ive just bought my new storm 9500 Vodafone (previous I had a Bold) and know I want to hit it against the wall. I made a software upgrade and install the 4.7.0.106 and I have 2 main, huge and principal problems:

    The first one is that my device hungs when Im using it and without response after a few minutes I have to reboot it by taking out the battery...this is crazy because it happens 5 or 6 times a day!!!

    The second problem is that the phone doesn't shows the name of the sender, having it in the contacts address book..and this is really annoying...

    I'm thinking about returning to my previous Bold...this phone is driving me crazy! Please help me!!
    Now I'm going to downgrade my device to the last official OS to see if this problem is solved.
    02-21-09 04:44 PM
  2. BBSchase373's Avatar
    You should probably try reloading .106
    02-21-09 04:48 PM
  3. ksaabd's Avatar
    Hi...how could it reload the software?? I know how to downgrade or upgrade but reload not...
    02-21-09 05:20 PM
  4. dayzofkonfuzion's Avatar
    why return the phone? It's obviously a OS issue. Try downgrading.
    02-21-09 05:24 PM
  5. VideoEngineerAJS's Avatar
    Right on about the software. I've not touched mine except for adding the themes that I've made and I haven't had nearly (if any) of the problems that a lot of people on here have.

    Now some might think that my phone is "slow" but I had the Dare previously and it's honestly not much slower (if slower at all) than the Dare.
    02-21-09 05:28 PM
LINK TO POST COPIED TO CLIPBOARD