05-24-09 12:58 AM
80 1234
tools
  1. pgumby's Avatar
    And you don't see a sluggishness in performance when it's in the mid 20's?
    I'd imagine based on how many people come up with different minimums before they pull that sluggishness and such is subjective to the user.
    05-21-09 03:39 PM
  2. dropkickoreilly's Avatar
    shoot my free memory is never over 33MB.
    even after a battery pull i start with 32-33MB. I only worry aboutit when it drops below 5MB because then my phone gets sluggish
    Same here!

    Posted from my CrackBerry at wapforums.crackberry.com
    05-21-09 03:43 PM
  3. markdental's Avatar
    Memory leak will exist PERIOD.

    Please do not try to diagnose it or stop it.

    It is a function of an operational 4.7 OS. Maybe this will change with 5.0
    05-21-09 03:46 PM
  4. nightfishing's Avatar
    Phone being "sluggish" with app memroy in the 20's has nothing to do with free app memory. It is either due to something else or placebo.

    In all seriousness, though, scheduling a quick pull once a day will solve so many of these "issues".

    (And I don't want to hear a peep about how it SHOULD be unnecessary to do pulls - sheesh!)

    Here is a work day (on bb's 5.1, lots of apps, 3rd party theme, wb etc). Results were similar with 132.

    05-21-09 03:49 PM
  5. Zelmo88's Avatar

    But I am curious as to what is making it drop. Today I deleted facebook. Im gonna go out on a limb and say this may have been my problem. But Im giving it 24hrs to confirm. Ive been hovering around 35-37mb.

    Now the question is, if it the facebook app, what to do? The app or the leak? lol
    I'm running Facebook and haven't had a memory problem.
    05-21-09 04:17 PM
  6. patches152's Avatar
    It's not the numbers that concern me as much as the sluggish performance. I don't look at the memory until I see the sluggishness, then I know it's dropped below 30mb. It have been running .148 since yesterday morning, and I know there's some settling-in time. However, my Storm definitely slows down after about 6 hours and by 10 hours, needs a battery pull- not by looking at the numbers but by the feel of the device.

    You don't see that degradation in performance over time?
    my phone has improved every hour that i've owned it. i did the traditional reset after i restored my stuff (didn't restore theme settings) and i've only had to reset again for installing/deleting apps (people send me all kinds of crap to try out)

    other than that, it's been the best functioning build i've EVER used. even better than hybrids. and to say that the camera and browser are better than the hybrids is saying something.
    05-21-09 04:19 PM
  7. DenverRalphy's Avatar
    If your phone gets sluggish after dipping below 30mb, it's not because it's low on app memory. You must be running an app that is hogging the cpu, or you're not closing all your apps properly and have a bunch running in the background all at once. With all those running combined, they're eating up all the cpu resources and the ram, at which point it has to utilize app memory as ram. Contrary to what a lot of people say, your available app memory is NOT the system's ram. However your device will utilize it for swapping when ram runs low. At which point 30mb is more than plenty (even 10 would be).

    Many Storm users have a boatload of apps installed and boot up right at 30mb and it's not uncommon to drop below 10mb, yet the devices are running fine.
    05-21-09 04:35 PM
  8. stevealb's Avatar
    If your phone gets sluggish after dipping below 30mb, it's not because it's low on app memory. You must be running an app that is hogging the cpu, or you're not closing all your apps properly and have a bunch running in the background all at once. With all those running combined, they're eating up all the cpu resources and the ram, at which point it has to utilize app memory as ram. Contrary to what a lot of people say, your available app memory is NOT the system's ram. However your device will utilize it for swapping when ram runs low. At which point 30mb is more than plenty (even 10 would be).

    Many Storm users have a boatload of apps installed and boot up right at 30mb and it's not uncommon to drop below 10mb, yet the devices are running fine.

    Except that I do not run many apps in the background and I religiously close out programs. I can't imagine what's eating up cpu cycles.

    I have docs to go, google maps, bbm, password keeper, mobile banking, bbfilescout, and bb appworld, the stock theme, and 3 email accounts on BIS.

    I don't see much here to impact my performance.
    05-21-09 08:12 PM
  9. tucker3434's Avatar
    I have a pretty good number of 3rd party apps and my memory stays very high. With 75 it was always between 15-20. Now it is usually above 25.
    05-21-09 10:37 PM
  10. lect's Avatar
    its not the lack of memory that makes your phone sluggish, its the apps you run that make the phone sluggish.

    i havent rebooted in 5 days, i am down to 20mb of memory but my phone is as fast as it was when i rebooted it (and i reboot at 48mb). i use FML, amazon app, all my chat apps, ap mobile news reader, and watch at least 30 minutes of video every day.

    im not sure why everyone is concerned with app memory, correlation != causation. if your phone is getting bogged down, it is most likely one of your apps that you are running or have previously run. App world always kills my phone whenever i load it... as do most games that i download - i have since uninstalled them and have no problems with phone performance, although memory "leaking" is still present.
    05-21-09 10:49 PM
  11. StingRay's Avatar
    And you don't see a sluggishness in performance when it's in the mid 20's?
    sometimes yes.....just took a look and my memory is at 20.5, which it hasn't been that low in a while....phone is sluggish...menus slow to respond, etc.

    so far on my phone anyway, .148 is showing signs of memory leak issue, worse than .141 or hybrids.....

    will give it a little longer, then may have to go back....
    05-21-09 10:53 PM
  12. Storm_Warning's Avatar
    I'm running .148 and I have no complaints. I boot up with 5+ more memory than usual. (Before 43mb and now 48mb). Although it does leak, it seems to bounce back up quite a bit like it should. I haven't noticed anything sluggish about this build so far. My apps are: Poynt, Google Maps, CB App Store, CB Launcher, Storm Taser, WeatherBug, Meterberry, Shotgun, Wrap it Up, and Tiltris.
    05-21-09 11:44 PM
  13. stevealb's Avatar
    Are there configuration settings that would impact memory recovery or sluggish performance?

    I have set the phone to always use 1EX, not global. I have not set the event log to "hidden", and I'm not sure that it would really do much. Anything else?
    05-22-09 08:36 AM
  14. SilverLight98's Avatar
    I actually tried turning memory cleaning on, usually it slows down the phone, but now with .148 I haven't noticed any difference In speed so far. It keeps my memory up without me having to constantly worry about it falling too low

    Posted from my CrackBerry at wapforums.crackberry.com
    05-22-09 09:15 AM
  15. erupert66's Avatar
    OK, I am wondering what I am doing wrong. I have owned the Storm for about 2 months and have been on .132 for the past month or so. I am having massive memory leak issues. First, at boot I only have about 20MB to start. I am not actively running a theme (although I don't know how to remove them) and the only two apps that I run are UberTwitter and Pandora. I haven't run either one for the past week or so because within about 4 hours, I have only a 2mb left. I am booting the phone about 4x / day. The only other thing I have is Storm Slider.

    I don't use the VZ stuff and I have the AIM client configured but not set to auto-login. So, what is using all my memory?

    I was thinking about bumping to .148 this AM to see if the OS was the source of the leak, but seems like others are reporting the same. I installed that Aerize memory client as a trial, but it doesn't reclaim much so I don't think I'll buy it.

    Any suggestions?
    05-22-09 09:26 AM
  16. patches152's Avatar
    OK, I am wondering what I am doing wrong. I have owned the Storm for about 2 months and have been on .132 for the past month or so. I am having massive memory leak issues. First, at boot I only have about 20MB to start. I am not actively running a theme (although I don't know how to remove them) and the only two apps that I run are UberTwitter and Pandora. I haven't run either one for the past week or so because within about 4 hours, I have only a 2mb left. I am booting the phone about 4x / day. The only other thing I have is Storm Slider.

    I don't use the VZ stuff and I have the AIM client configured but not set to auto-login. So, what is using all my memory?

    I was thinking about bumping to .148 this AM to see if the OS was the source of the leak, but seems like others are reporting the same. I installed that Aerize memory client as a trial, but it doesn't reclaim much so I don't think I'll buy it.

    Any suggestions?
    try deleting all of the apps and themes, and see if it persists...
    05-22-09 10:56 AM
  17. ChXion's Avatar
    I'm Running .148 with shrunk OS but kept Log Viewer, OS Update, Default Font, Ringtones, and Brickbreaker. No themes.

    Apps:
    CaptureIT
    Google Maps
    Opera Mini
    Pandora
    WeatherBug
    AppWorld
    Level
    QuickPull v2 (scheduled for 4am)
    Flight Path

    Uptime is: 167915 secs

    I booted up with 53mb and i'm currently cruising at 48mb.

    I have seen little to no memory leak with this OS so far. Not sure what everyone else is running, but figured I'd share my config to help compare.
    05-22-09 11:09 AM
  18. cenloe's Avatar
    Seriously, is this really an issue?
    05-22-09 11:12 AM
  19. patches152's Avatar
    I'm Running .148 with shrunk OS but kept Log Viewer, OS Update, Default Font, Ringtones, and Brickbreaker. No themes.

    Apps:
    CaptureIT
    Google Maps
    Opera Mini
    Pandora
    WeatherBug
    AppWorld
    Level
    QuickPull v2 (scheduled for 4am)
    Flight Path

    Uptime is: 167915 secs

    I booted up with 53mb and i'm currently cruising at 48mb.

    I have seen little to no memory leak with this OS so far. Not sure what everyone else is running, but figured I'd share my config to help compare.
    the shrink-an-OS doesn't help much in the situation, you could have potentially shrunk something that was causing the issues with someone else's phone. ya know? for the purpose of troubleshooting you wanna compare like devices, and like software.

    but good config, the most i've ever seen on my storm was in the 45mb range on a hybrid/shrink, and i get that easily on .148 so i haven't made any effort to shrink or hybrid it yet...no need for me to
    05-22-09 11:13 AM
  20. stevealb's Avatar
    The number itself is not an issue. App memory is supposed to be used, especially f the Storm is caching some of its data. It's when the device becomes sluggish in its response that this is a concern. For me, that happens about 6 hours after a battery pull, and it seems to coincide with my app memory falling below 28-30 mb. Right after a battery pull I start with about 43 mb. I end up having to do an initial battery pull at 6 am when i start my day and then another battery pull at about 3 pm, when the phone is just too sluggish.
    05-22-09 11:18 AM
  21. Tsip85's Avatar
    I check my ap memory frequently, but I have no idea why. I know it doesn;t really affect anything. I'm running Lyr's 141/5.0 hybrid and I start at about 45 and it will drop to about 35 over the course of the day. my phone never seems sluggish. My wife and I both got Storms on the same day. I have installed .132 on her phone and she plays around on it all day. I'll check her phone in the evening and she will be down to 9mb of ap mem, but her phone is still running fine. Almost as fast as mine. Whenever it seems sluggish, I'll look to see how many programs she has running in the background and it seems that every ap she's downloaded is running.

    I agree that ap mem is not that important. It's all about how many aps you have running in the background that's going to determine if you phone seems sluggish.
    05-22-09 11:18 AM
  22. stevealb's Avatar
    I check my ap memory frequently, but I have no idea why. I know it doesn;t really affect anything. I'm running Lyr's 141/5.0 hybrid and I start at about 45 and it will drop to about 35 over the course of the day. my phone never seems sluggish. My wife and I both got Storms on the same day. I have installed .132 on her phone and she plays around on it all day. I'll check her phone in the evening and she will be down to 9mb of ap mem, but her phone is still running fine. Almost as fast as mine. Whenever it seems sluggish, I'll look to see how many programs she has running in the background and it seems that every ap she's downloaded is running.

    I agree that ap mem is not that important. It's all about how many aps you have running in the background that's going to determine if you phone seems sluggish.
    That's not always true, since I do not run any 3rd party apps in the background, only use the stock theme, and close out programs I'm finished with. However, after about 6 hours following a battery pull, my Storm gets sluggish and app mem is at about 28 mb down from 45.
    05-22-09 11:32 AM
  23. hookbill's Avatar
    I don't usually do this because it's just a waste of time but I just checked my memory and its sitting at 50.7 after a quickpull at 5 am this morning. Thats 6 and a half hours ago. I run 11 apps. I'm not seeing any memory leak.
    05-22-09 11:40 AM
  24. stevealb's Avatar
    I don't usually do this because it's just a waste of time but I just checked my memory and its sitting at 50.7 after a quickpull at 5 am this morning. Thats 6 and a half hours ago. I run 11 apps. I'm not seeing any memory leak.
    Do you think there are device configuration settings that may be producing my problem with "memory leak" or sluggishness?
    05-22-09 11:57 AM
  25. hookbill's Avatar
    Do you think there are device configuration settings that may be producing my problem with "memory leak" or sluggishness?
    Have you cleared your log using "/"/? That could help. Also are you using Weatherbug or any memory sucking apps? I'm a bit careful about what I add just for that reason, if I see it sucks too much memory then I won't keep it. I'll find an alternative.
    05-22-09 12:08 PM
80 1234
LINK TO POST COPIED TO CLIPBOARD