1. Bond J's Avatar
    So after I changed the top cover of my storm the lock button and mute doesn't work anymore.

    The mute button only works fine in the media player but it doesnt put the phone in standy by and the lock button does nothing at all.

    I completely wiped the phone but got no results.

    Any ideas on how to fix this?

    I searched for other threads and accordnig to those I might have a damaged a ribbon or something that connects the buttons...
    11-02-09 12:58 PM
  2. djrams's Avatar
    Yup...you damaged the ribbon.

    I don't think the Mute button is supposed to put the phone in standby. At least it doesn't on .328
    11-02-09 04:30 PM
  3. chuckh0308's Avatar
    Yep, you tore the ribbon cable (I did it on two Storms). The second one I tore while trying NOT to tear it like I did the first one. I still haven't figured out how to remove the top piece without damaging that thing! I searched and searched and was never able to find a supplier for that cable. Your best bet is to just get a third party lock app such as BerrySlider or Pattern Lock and then just use the on-screen controls for mute.
    11-02-09 05:21 PM
  4. himefrankie's Avatar
    Yep, you tore the ribbon cable (I did it on two Storms). The second one I tore while trying NOT to tear it like I did the first one. I still haven't figured out how to remove the top piece without damaging that thing! I searched and searched and was never able to find a supplier for that cable. Your best bet is to just get a third party lock app such as BerrySlider or Pattern Lock and then just use the on-screen controls for mute.
    You can find replacement Lock/Mute ribbon cables on eBay, search for "Blackberry 9530 Ribbon Cable"
    05-03-10 04:56 PM
LINK TO POST COPIED TO CLIPBOARD