11-22-08 12:38 PM
56 123
tools
  1. pittguy18's Avatar
    So this is my first post on this board, even though I have been following religiously for weeks.

    I waiting in line this morning and was the first person out of the store with a brand new Storm in my hands.

    After playing around with it all morning, I have to say I am extremely disappointed with the final product. Specifically:

    -The accelerometer only works about 25% of the time
    -It will occasionally switch me into camera mode for no reason at all
    -It has frozen up on me several times, prompting a reboot. This reboot took almost 10 mins!!
    -The buttons look like cheap plastic that can/will easily fall off


    Now I know this is a brand new device, and there will be bugs .. but I guess I just expected more from RIM (and Verizon sorta)

    Hopefully the new OS will fix these issues, but so far the device says there are no new OS downloads available.

    My advice to anyone wanting one - wait until the new software update gets released, and then buy one.

    Anyone else experiencing same issues??
    11-21-08 10:15 AM
  2. shooptek's Avatar
    For the camera thing, stop pushing the right shortcut key, thats why your camera is booting up un-intentionally. I havent had any issues with mine yet.
    11-21-08 10:17 AM
  3. Nyisles84's Avatar
    same here , no issues whatsoever and i been running it pretty hard for the last 3 hours almost
    11-21-08 10:18 AM
  4. BBStorm31's Avatar
    It seems like the problems are with your specific phone. The camera could be you hitting the shortcut button on the side.
    11-21-08 10:18 AM
  5. mikeymike00's Avatar
    mine either! mine works great! accelerometor is perfect, less than 1 sec delay!
    11-21-08 10:20 AM
  6. mickyb23uk's Avatar
    I've had delays with the accelerometer, esp when www browsing or viewing photos in the gallery.

    As for the buttons feeling like plastic, they feel and look pretty solid to me.
    Id recommend removing the pre installed network carrier software (in my case this was Vodafone UK Live!)
    Camera is as posted above - by clicking the right h/s shortcut key.

    Ive been using mine since Saturday (15th) and only had to do a battery pull once!
    11-21-08 10:23 AM
  7. snowgimp's Avatar
    And about the buttons being cheap...even on the pre release versions I've played with, no they don't. I'm not even 100% you really have the phone.
    11-21-08 10:26 AM
  8. davemathbn's Avatar
    I Love Mine!!!
    11-21-08 10:31 AM
  9. notabun's Avatar
    Yup, no real issues with mine. Could be snappier, but that will come with each new update. DON'T BELIEVE THE DEBBIE DOWNERS! Try it for yourself.
    11-21-08 10:35 AM
  10. notabun's Avatar
    Oh, a tip for everyone. Try and remember to close out applications ("escape" key usually does the trick) instead of hitting the Red "End" button. This will keep resources free and make things run smoother. I've been running fine.
    11-21-08 10:37 AM
  11. vlkers54's Avatar
    HOW DO YOU CHANGE THE ACCELEROMETER SETTINGS?! Mine's slow
    11-21-08 10:45 AM
  12. Darko.com's Avatar
    Mine rocks! Smooth as silk and a sexy looking device.
    11-21-08 11:24 AM
  13. saranya's Avatar
    And about the buttons being cheap...even on the pre release versions I've played with, no they don't. I'm not even 100% you really have the phone.
    you might have lower standards. yes. the buttons are cheap. they almost look like if they catch on the littlest thing, they will rip off. the rest of the phone is pretty high quality...except the buttons.

    maybe you don't really have the phone? I know I do.
    11-21-08 11:42 AM
  14. Semantics's Avatar
    Can anyone give me some info on how the click pad works? The reviews I've read were all pretty much the same that they didnt like how the typing was for texting, etc. I'm counting on you Crackberries for a more honest, and thorough review!

    Thanks in advance.
    11-21-08 11:47 AM
  15. Devlyn16's Avatar
    I had the same problem with the camera, I immidiately assumed that between my finger & the rubber case I activated it.

    I do think the Rubber sleve/cases may be the culprit here
    11-21-08 11:48 AM
  16. mrpostman506's Avatar
    my verizon rep gave me a paper saying i need 2 do an update that will take 30-45min
    11-21-08 11:51 AM
  17. ceeya's Avatar
    i love mine...no issues and recommend it...still learning its capabilities...joe


    btw: where is the escape key?
    11-21-08 11:52 AM
  18. ClassaN0va's Avatar
    And about the buttons being cheap...even on the pre release versions I've played with, no they don't. I'm not even 100% you really have the phone.
    Probably an I-phone jerker offer
    11-21-08 11:56 AM
  19. zr1mom's Avatar
    Have had mine now for 5 hours, no real problems, everything seems to work ok. Sometimes when I try to highlight something it doesn't do it right away. Put a condom on mine as well to help protect from banging.

    The touch screen is something to get use to but overall love it.
    11-21-08 11:57 AM
  20. Zappa not Frank's Avatar
    No problem with mine,works quickly.
    11-21-08 12:05 PM
  21. FUSIBLE's Avatar
    I haven't had any problems.
    11-21-08 12:44 PM
  22. xxxxpradaxxxx's Avatar
    In reference to the Camera Issue-

    Have Any Of You even Considered Changing Your Convenience Keys?

    Thats the First Thing I Do For ALL my Berry's.

    Options > Screen/Keyboard > Convenience Keys

    I Guess I Never Had That Problem Because I Switched It Up ASAP.
    11-21-08 12:52 PM
  23. Bayhay1's Avatar
    I am very happy with mine.
    Like any new device, it takes a little time
    to get use to it.
    11-21-08 01:12 PM
  24. lookitsangel's Avatar
    I went into Best Buy last night to try out the Storm... and I was quite disappointed... I have been waiting for this phone forever! The verizon clip makes the phone the most wonderful phone ever! But... yes, it is buggy, it's slow, the load up time is horribly slow, the click/touch screen I think I would have to get used to... but I suggest people wait until the bugs are fixed.... I was ready to buy this phone for full price without contract.... Overall, the phone is really nice.... just slow... I can't wait until they fix it... if anyone has those updates please let me know!
    11-21-08 01:23 PM
  25. tuteblack's Avatar
    no problem with mines at all... i am loving it!!!!
    11-21-08 01:35 PM
56 123
LINK TO POST COPIED TO CLIPBOARD