1. MHarvey124's Avatar
    The last few days I've started to notice more and more that my screen is not registering touches in the correct place. I'll press the T button in landscape and it will register it as a C on the keyboard. Its also like this too when trying to select certain icons in the main menu or homepage. The only thing that seems to fix it is to do a battery pull. Thats fine but when I need to make a call and button doesn't register thats a problem.

    I've only had .65 (official) and .75 (official) running on this phone and nothing else. Never done a wipe, leaked OS, or anything else with the OS.

    Any idea if this is a glitch with .75 or something else I am unaware of?
    01-20-09 07:23 AM
  2. irocknikes123's Avatar
    Mine did this too. I think my touch screen is going bad. I have a replscement coming today .

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-09 08:39 AM
  3. irocknikes123's Avatar
    And I was on .86

    Posted from my CrackBerry at wapforums.crackberry.com
    01-20-09 08:39 AM
  4. djx18's Avatar
    Are you using a third party charger? Third party chargers are known to cause touch screen issues...
    01-20-09 10:03 AM
  5. crackisntwack's Avatar
    My first Storm did the same thing, except battery pulls wouldn't fix it. Touching the bottom right corner may register in the bottom right corner, or maybe in the center, or maybe in the top left corner. It seemed to get progressively worse too. It was absolutely terrible.
    Since it was my first device, I just assumed that it was the "screen click" issue that everyone on here was talking about. Wrong.
    Took it in to Verizon and they sent me out a new one. Works great now.
    You shouldn't have to deal with a crappy touch screen on a touch screen phone....take it back.
    01-20-09 11:33 AM
LINK TO POST COPIED TO CLIPBOARD