1. rcher1's Avatar
    I was having trouble getting MMS to work with AT&T after trying tons of things. What I did find out was there are some settings in the phone that were not set correctly. This is what they are:
    1-dialed ##000000 and it gets you to the CDMA Service Edit Screen on the phone.
    2-Scroll down to the area that says:SIP User ID. There you will find your phone number with the address of a service provider after it.
    Mine had verizon after it since I have an unlocked BB Storm2 9550 from verizon.
    3-Change it to read something like this: your moblie phone #@att.com
    4-Now go just below that to the MIP User ID and change it to the same.
    5-Select Menu and Save.
    6-Now go to Home Screen/Options/Advanced Options/Browser Push.
    7-Check all Boxes and everything-else should say Auto and Allow All.
    8-Save
    9-NOW it should be working like it did for my phone after doing the install of AT&T Service Books How TO's that are out there.
    10-To check just create a contact in address book with your name and phone # then send yourself an MMS after turning on Data Service.

    Hope this helps someone because I was ready to throw this phone out the door after trying for almost 2 months to get MMS to work. Everything-else is working.

    Unlocked Verizon BB Storm 2 9550 on AT&T
    OS v5.0.0.517 (Platform 4.2.0.250)
    04-22-10 10:45 AM
  2. usernam9102's Avatar
    I tried those steps on a unlock 9550 and they did not work
    04-22-10 02:01 PM
  3. erinzmd's Avatar
    Didnt have the same suces you described also...Bought my 9550 from verizon directly also.
    I dont even have the option of mms showing up under compose new message..
    really need elp get this MMS working.....ahhh
    04-25-10 10:18 PM
  4. usernam9102's Avatar
    I agree on the mms issue. I have searched other forums and google for the answer. I wish there was a fix. I would post it
    04-26-10 01:27 PM
  5. gaint_71's Avatar
    I have been looking all over the internet too and still haven't found a fix for it, i don't even have the option MMS on my phone. i have downloaded the service books also and it still doesn't work.
    05-31-10 02:15 AM
LINK TO POST COPIED TO CLIPBOARD