1. dookieball87's Avatar
    hey guys i need help on my storm!....my touchscreen has a glitch and it works sometimes and then it stops working! i cannot scroll up or click anything! any help please......can someone recommend me a solution?? thanks!!
    02-07-09 10:11 PM
  2. blueskyjunkie's Avatar
    Do a battery pull. If that doesn't fix it then its probably a hardware issue and you'll need to exchange your storm.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-07-09 10:17 PM
  3. dookieball87's Avatar
    i did that already. and when i put the battery back on it really takes long to load back up more than it usually does. and then my screen works for a bit and then it stops working. i have to leave it alone for a while for the screen to work for a while again. it is pretty annoying and it makes the phone crappy. i really need help because i cannot exchange it.
    02-07-09 10:28 PM
  4. SWFL's Avatar
    What os are you running? t mobil wont take that back lol
    Last edited by SWFL; 02-07-09 at 10:52 PM.
    02-07-09 10:49 PM
  5. dookieball87's Avatar
    im running the 4.7 os u think an upgrade might help?
    02-11-09 03:28 AM
  6. neolantis's Avatar
    it can't hurt it
    02-11-09 04:13 AM
  7. CH2iS's Avatar
    hey guys i need help on my storm!....my touchscreen has a glitch and it works sometimes and then it stops working! i cannot scroll up or click anything! any help please......can someone recommend me a solution?? thanks!!

    same problem here. 9500 vodafone version. i just upgraded to the 100 and all is well. pretty annoying and i know how you feel.
    02-11-09 04:15 AM
LINK TO POST COPIED TO CLIPBOARD