1. FurryHusky's Avatar
    Well, yesterday after work, I plugged my storm in to charge, and fell asleep. I woke up, battery was full, so I unplugged it and put it under my pillow. Woke up again a few hours later, and couldn't find my phone. After searching the apartment, I found what was left of it on the ground, in front of a very content looking puppy. He chewed off the lock/mute buttons, the covers, etc, took out the ribbon cables that hook those to the main phone, and put a tooth mark in my back button. He also took the rear cover(the one over the camera and flash) off, and chewed it up. Now, I know the phone is beyond repair, that much goes without saying. What I need to do, is get my data off of it. When I found the phone, it was powered on, and apparently functioning(I had a few text messages, emails, and a missed call), but the touch screen was working sporadically at best, and none of the buttons along the bottom row(send, menu, back, end) worked at all. I decided to do a battery pull to see if I could get those buttons working, and now the phone won't power up at all. As soon as I put the battery in, the red LED comes on, and stays on, like it's starting up, then the LED goes off, the screen and bottom row buttons light up for a second, then everything resets and it does that again. After about 20-30 cycles of that, the bottom row buttons stay lit up, as does the screen, and I get a turning clock logo in the center. I left it like that for eight hours, and it didn't do anything. I tried pressing the touchscreen, and a few other buttons, and that started the whole process over again. While it's plugged in to my computer, I get the "USB Device connect" noise when it starts the process, and the "USB Device disconnect" noise when it starts over. In Desktop Manager, my only options for the connection are "<None>" and "USB". Neither choice gets me anywhere. Now, if I pull the battery, and plug it into USB, it will go to the white "No Battery" screen, and desktop manager can see the PIN number of the device, but it still won't let me connect to it.

    I REALLY need to get my data off of this phone. I just plugged in the portable HDD with all my backups on it, and found that someone had overwritten ALL of my backups, from the phone, my other computers, and everything else. Every communication I've made in the last 9 months is on that phone, along with every contact information I've ever had. If I have to buy another storm, and swap pieces over until I can access the memory, I will. I just need to know what to do.
    04-18-10 11:02 AM
  2. FurryHusky's Avatar
    Anybody? Anything?
    04-22-10 10:54 AM
  3. jeffmeden's Avatar
    Wow, super freaking bummer. Maybe try to disconnect the damaged pieces of the phone (Screen, buttons, etc) until it powers on? You don't need any of those things available to get to the point where you can dump the data. Get desktop manager running to see if you can interrupt the reboot process at all (I think this is possible, since a similar problem happens when a firmware upload goes bad and this is the fix).

    Oh, and this is probably not the time to mention it but you really should check out the Google suite of apps (gmail and sync mostly) since you can back up your contacts and have a perpetual archive of all emails. Its well integrated, and free.
    04-22-10 11:04 AM
LINK TO POST COPIED TO CLIPBOARD