1. rellims's Avatar
    I can't believe this phone....it works perfectly. I have diligently updated to every official and leaked OS and to no avail it just gets better and better. What's wrong with this thing? according to these forums their must be something wrong. If anyone can help me fix this state of functionality please do.

    Its driving me crazy I cant complain about anything.....help please.
    02-03-09 07:50 PM
  2. NickyParsons's Avatar
    Time for a replacement
    02-03-09 07:57 PM
  3. mhind52's Avatar
    Ha!

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    02-03-09 07:59 PM
  4. jdoc77's Avatar
    Help! Something's wrong with my Storm!
    Duh, it's a Storm!

    Actually, contrary to popular belief, I (and dare I say others of my ilk [I have an ilk?]) agree that the majority of Storms function rather well under most conditions.

    It's the assertion that very nearly ALL of them do, or that the issues it does have are overlooked in large degree by some that makes the BS meter go up several clicks.

    BTW... this is clearly a pure Rant/Rave thread, solely for the purpose of raving... just to say. Kinda similar to when CK posts something meant solely to call BS on certain issues.

    It cuts both ways, don't it?

    *le sigh*
    02-03-09 09:15 PM
  5. jenaywins's Avatar
    Time for a replacement
    Bahahahaha!!!!

    Ehem. Sorry. Composure... At any rate. Well, I'm only on my first replacement and all is well, so... Maybe the OP is one of the lucky ones.
    02-03-09 09:17 PM
LINK TO POST COPIED TO CLIPBOARD