1. PavementPilot's Avatar
    How come I am only seeing the phone number from the sender of an SMS instead of the name if they are in my contacts? I have been all over the settings everywhere, unless I missed one. This happened after I did an official re-update from my carriers OS. It even carried over to the Hybrid OS.
    02-25-09 10:57 AM
  2. QyKo's Avatar
    You have the number saved?
    Check under SMS/MMS options?;

    -Click the date of the msgs in the inbox and go to General Options its in there last time i checked.
    02-25-09 11:02 AM
  3. shellie-da-newbie's Avatar
    hey pave-p have you done this already- go into your sms icon-scroll all way to top>bb button(dotted)>options>general options> then display name-change to YES and display order choose name/subj or subj/name. remeber to save also. hope that helped! good luck
    02-25-09 11:04 AM
  4. PavementPilot's Avatar
    I have display name on. It looks like it is not polling the contact list for the name info, and then dispalying it. I wonder what is causing this.
    02-25-09 11:23 AM
LINK TO POST COPIED TO CLIPBOARD