1. rob_berry's Avatar
    Hi. I have a Storm 2 on Vodafone UK. Today I have tried to update the firmware to the .713 available from Vodafone Spain, I have followed instructions from here and other websites (delete the vendor file, so on...) but I cannot get the phone to update. I'm probably been a bit thick and missing something really obvious but could someone please tell me exactly what I need to do to get this working? Step by step would be really helpful. My phone is currently running version 5.0.0.497 and my BlackBerry desktop software is version 6.0.0.43. Thanks for any help offered.
    09-18-10 08:05 AM
  2. Blinkie's Avatar
    not sure what way you have done it but try it this way:

    1. Un-install any older versions of firmware from your PC.
    2. Install the new one on the PC.

    You should see it installed in the following path....

    C:\Program Files\Common Files\Research In Motion\Shared\Loader Files\9520AllLang_v5.0.0.713_P4.2.0.323

    3. Go back 2 folders to the 'Research in Motion ' folder.
    4. Go into the 'Apploader' folder
    5. DELETE the file entitled 'vendor.xml'
    6. Click on the file entitled 'loader.exe'
    09-18-10 08:20 AM
  3. mechanic_joe's Avatar
    Try using apploader to update your OS instead of Desktop Manager, make sure you delete the vendor.xml file and make sure you remove and delete previous versions. Good luck

    http://crackberry.com/blackberry-101...ting-system-os
    09-18-10 08:22 AM
  4. kriptikchicken's Avatar
    Blinkie has this pretty much covered.

    One thing to add would be if you are on a 64bit system it will be the 'program files (x86)' directory as it is a 32bit program.
    09-18-10 08:42 AM
  5. rob_berry's Avatar
    I see... I wasn't deleting the old version of the firmware. How do I do this? Using the add/remove programs feature in Windows or something else?

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-10 09:47 AM
  6. rob_berry's Avatar
    Try using apploader to update your OS instead of Desktop Manager, make sure you delete the vendor.xml file and make sure you remove and delete previous versions. Good luck

    http://crackberry.com/blackberry-101...ting-system-os
    I didn't realise there was another way to do it other than Desktop Manager. The instructions for using DM in CrackBerry 101 are for a much older version of the program and bears almost no resemblance to the version I'm using.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-18-10 09:52 AM
  7. mechanic_joe's Avatar
    I see... I wasn't deleting the old version of the firmware. How do I do this? Using the add/remove programs feature in Windows or something else?

    Posted from my CrackBerry at wapforums.crackberry.com
    Yes, I do that first, then I go to directory manually and delete out whatever remains... sometimes if you mess with the java folder the windows uninstaller won't fully remove it.
    09-18-10 09:53 AM
  8. rob_berry's Avatar
    Seems to be working now. Thanks guys!
    09-18-10 11:14 AM
  9. Blinkie's Avatar
    Blinkie has this pretty much covered.
    would hope so, copied n pasted from the instructions you gave me
    09-18-10 02:50 PM
  10. _SyCo_'s Avatar
    Im having the same problem that he had, ive tried everything in this topic. Ive updated my phone before and as far as i can rememeber everything went smoothly.
    Is there anything more that i can do?
    09-26-10 07:13 PM
  11. Blinkie's Avatar
    Are you doing the install as previously stated?

    It should be as easy as the steps above.
    09-27-10 04:54 PM
LINK TO POST COPIED TO CLIPBOARD