1. Pyrobyte's Avatar
    I have got this every time I try to build, ever since I downloaded the program. I have reinstalled the JDK and JDE, and I still get the error.

    The Error

    Building test
    C:\Program Files\Research In Motion\BlackBerry JDE 4.7.0\bin\rapc.exe -quiet import=..\lib\net_rim_api.jar codename=test test.rapc warnkey=0x52424200;0x52525400;0x52435200 "C:\Program Files\Research In Motion\BlackBerry JDE 4.7.0\bin\test.java"
    java.lang.NoClassDefFoundError: com/sun/tools/javac/Main
    Caused by: java.lang.ClassNotFoundException: com.sun.tools.javac.Main
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    Exception in thread "main" Could not find the main class: com.sun.tools.javac.Main. Program will exit.
    Error!: Error: java compiler failed: javac -source 1.3 -target 1.3 -g -O -d C:\Users\Pyrobyte\AppData\Local\Temp\rapc_543776ad .dir -boot ...
    Error while building project
    02-22-09 08:33 PM
  2. phrehnck's Avatar
    Check your Environment Variables in Windows: [Right Click My Computer->Properties->Advanced->Enviroment Variables->System Variables]

    [CLASSPATH] must contain [C:\Program Files\Java\jdk1.5.0_17\bin] of watever jdk version u have.

    [JAVA_HOME] [C:\Program Files\Java\jdk1.5.0_17]

    [QTJAVA] [C:\Program Files\Java\j2re1.4.2_12\lib\ext\QTJava.zip]

    [PATH] must contain [C:\Program Files\Research In Motion\BlackBerry JDE 4.7.0\bin]





    and they have http://forums.crackberry.com/f9 =)
    Last edited by phrehnck; 02-22-09 at 08:40 PM.
    02-22-09 08:38 PM
  3. Pyrobyte's Avatar
    I don't have that option when I click on My Computer. I run Vista...

    I'll be sure to use that forum next time.
    02-22-09 08:55 PM
  4. Pyrobyte's Avatar
    Anyone?...
    02-23-09 03:27 PM
  5. anon(96573)'s Avatar
    Right click my computer > Advance System Settings (it's a link on the left) > Advanced Tab > Environment Variables

    Then do what phrehnck said

    =)
    02-23-09 03:33 PM
  6. Pyrobyte's Avatar
    Well, I did that, then I didn't have the variables soo I made them. I can't find QTJava.zip anywhere on my system so I left out the variable. I still get the error...
    02-23-09 08:53 PM
  7. Pyrobyte's Avatar
    Yep, the error is exactly the same.
    02-24-09 06:37 AM
  8. Pyrobyte's Avatar
    Is it possibly something else?...
    02-24-09 02:41 PM
  9. Pyrobyte's Avatar
    Bump... Bump... *pushes topic*(Is that allowed here?... The last forum I joined didn't allow bumping.)
    02-24-09 05:56 PM
  10. Pyrobyte's Avatar
    Bump... Bump... *pushes topic*(Is that allowed here?... The last forum I joined didn't allow bumping.)
    *shoves topic up the list*
    02-25-09 02:57 PM
  11. anon(12291)'s Avatar
    I suggest you try the blackberry dev forums.
    02-25-09 03:16 PM
  12. Pyrobyte's Avatar
    I suggest you try the blackberry dev forums.
    Tried, and I got one reply. I'm really anxious to start making my own apps...
    02-26-09 07:26 PM
  13. anon(12291)'s Avatar
    hmm, are you using the right namespace?
    02-26-09 10:09 PM
LINK TO POST COPIED TO CLIPBOARD