1. kfiz's Avatar
    For the past couple days, my blackberry has been erasing all my incoming emails. Not right away, but after a few hours. Last night I checked my email before I went to bed. The ones from yesterday were all there. I woke up this morning and checked my email, and found yet again, all the incoming emails from yesterday were gone, but my sent emails were still there.

    I have my email settings set to keep them "forever", so why is this happening? The other creepy thing is that the emails are also being deleted from my webmail box.

    Some of these emails are important for business, etc., so this is particularly frustrating/ worrysome. Fortunately I have Entourage (like Outlook, but for Macs) at home, which seems to save the messages I have lost. But I need the emails to stay on my Blackberry so I can reference them when I am out of the house.

    The only other time I had an issue with emails being deleted was when I had a memory issue and it was going down to 0MB, but this is currently not the case. I monitor the memory on my device using Meterberry. It never gets below 15MB without resetting, at which point it goes up to a little over 21MB. And only my incoming messages from the previous day are being delete, so it seems to be selective.

    PLEASE, are there any gurus out there who have a clue?

    Thanks very much for hearing me out.
    06-04-10 01:01 PM
  2. Rosebudster's Avatar
    I wonder if your settings have gotten changed without your actually doing it. Have you checked to see if they are the same as you originally intended?
    Last edited by Rosebudster; 07-12-10 at 08:11 PM.
    07-12-10 07:53 PM
  3. Snarfler's Avatar
    One of my email accounts the emails disappear from the bb when I check the account from a particular pc app, must have it set to delete from the server on download and the bb sees then gone from the server and deletes them from the bb. But I want it that way for that account.
    Any chance you've got something similar going on?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-12-10 09:24 PM
  4. JRSCCivic98's Avatar
    As Snarfler indicated... you must be checking this POP3 account from another "non-mobile" device, which by default deletes the emails from the server when it pulls them down to your email client. With the new BIS upgrades RIM made, this deletion now syncs down to your BB as a delete.

    Just log into your BIS account and turn off Deleted Items Sync and it should solve your issue while still allowing your other email clients to get all the emails correctly and also not clog up the email server by leaving emails behind (if you were to set your email client to leave a copy on it).
    07-12-10 10:14 PM
LINK TO POST COPIED TO CLIPBOARD