1. DankJemo's Avatar
    Hey all,

    I am new to this site, and a new BB user all together. I bought the storm a few days after it came out and really like it, although at the beginning of last week or so I started to notice something strange. Every now and then I noticed the edge of my screen shake a little, not the actual screen itself, but the images being displayed.

    I didn't think much about it at first, figured my eyes were tired from staring at computer monitors all day, then last Wednesday or Thursday it was really obvious. I could actually see the refresh rate on the Storm's touch screen. I confirmed this when I was setting up a colleagues BB Storm last Friday. I had my phone sitting next to her's and saw that the screen was basically flickering, although it was doing it so fast that it looked more like there was a haze on the screen, and around all the edges it was "wobbly."

    I called and talked to Verizon, they said that they haven't heard anything about this, and the recommend that I do a hard reset (really don't think it is going to do anything.) I am going to give it a shot anyway, but I want to know if anyone has been experiencing this issue, or any screen issues like it as well?
    02-02-09 05:50 PM
  2. JRSCCivic98's Avatar
    They'll always tell you that they've never heard of anything. They are trained to do so. Take it to a store if it's brand new and show them. Then have them swap it for a new one if you're under 30 days. Take your box and accessories with you to expedite the process of return/swap out.
    02-02-09 05:57 PM
  3. Bundy#AC's Avatar
    Never happened to me and never heard anyone else mention it, but whenever something strange like that happens, try a battery pull first. Same idea as a computer: when it starts acting strange, restart it.
    02-02-09 05:58 PM
  4. xxxxpradaxxxx's Avatar
    My Storm seems to have a bunch of display issues-

    The one I hate most is when the Screen Actually "Shifts Over" to a Corner and Gets Stuck in the Spot.

    It's Pretty Annoying.

    02-02-09 06:23 PM
  5. DankJemo's Avatar
    Yeah,

    I have tried the pulled battery and all of that... It solves the issue for about 10 minutes... The strange thing is it isn't consistent at all. Unfortunately, I am passed my 30-day return policy. Luckily the guy at Verizon was actually pretty helpful as far as saying if I reset the device and the issue returns He will have a new one sent out to me.

    I did get it at best buy, and I have the insurance on the phone, but I'd rather not wait to have it shipped out as they attempt to fix it for a few weeks, only to decide that is it not working properly and then send me a new one.

    I do admit it is a strange issue, i wasn't even sure I was seeing what I was seeing since it happened so slowly. Does BB themselves have a Warranty period on their devices, or is that all handled by the carrier, or the place you purchased it at?

    I love the thing, but I am kind of miffed that I spent so much money on it only to have it be messed up about 6 weeks after purchase for no real reason.
    02-03-09 07:45 AM
  6. DankJemo's Avatar
    Prada,

    I would try setting the device back to defaults with a soft reset, either that or run an update if you haven't done that yet. I know the issue you are talking about, I had it for the first week or so I had the phone but BB released a update which seemed to clear that right up for me.
    02-03-09 07:49 AM
LINK TO POST COPIED TO CLIPBOARD