1. blaisedinsd's Avatar
    Results Do Not appear reliable or repeatable on other Storms...
    5-27-08

    I can only confirm the following only applies to .141 and .148 and am interested if others users have similar experience with this.

    I am no expert about any of this but the difference for me is night and day so I wanted to share this to see if other user have the same experience. I also had a few problems with App World failing on large downloads (these ended up pausing and I was able to resume them).

    First off, I enjoy downloading videos to my Storm and these are the methods I have experience with.

    1. Poynt Movie Trailers
    2. YouTube videos via KeepVid: Download and save any video from Youtube, Dailymotion, Metacafe, iFilm and more! (takes a few steps but it's great to have a few cartoons to distract unruly toddlers).

    So downloading was working great for me on .141 but after going to .148 I continually was getting failures....Then I remembered something I did on .141 that fixed a problem with a third party App I was running so I tried it and it seems to have helped fix the problem with downloads failing.

    Here is the instructions:

    Go to Options>Security Options>Certificates
    (I don't think this exists in all the older leaks)

    You should see a list of certificates with a bunch of green checks. Scroll down to the very bottom of the list where you will see the last one has a yellow question mark instead.

    It is called VeriSign/RSA Secure Server Root certificate and it's expired or something.

    Tap to highlight and press the BB menu button.

    The very top option will be "delete" which you may have to scroll up to find. It then prompts you to type a password and to retype it. I had no password so I made one up and typed it twice and then it was deleted with no problems.


    When I did this on .141 I never had a failure during a large download. When I upgraded to .148 my downloads were failing maybe 70-80% of the time. I then deleted this expired certificate and since then I successfully downloaded about 5 videos with zero problems (well I actually have one failing through keepvid, about an 8 minute video). I thought it was a problem with .148 code but now with this fix it seems to work just as well as what I experienced on .141

    Maybe someone with more knowledge could shed some light on this because I have no idea why this works but it did for me.
    Last edited by blaisedinsd; 05-27-09 at 02:15 PM. Reason: Upadted findings....
    05-22-09 03:41 PM
  2. carlos31820's Avatar
    How are you downloading from Keepvid? Im trying to do it using Opera Mini and when I click on either the .flv or .mp4 download links, it tells me "Invalid Address".
    05-22-09 04:31 PM
  3. carlos31820's Avatar
    Never mind. Had to use the BB browser instead of Opera.
    05-22-09 04:34 PM
  4. blaisedinsd's Avatar
    If it is an extremely large file that might happen I think.

    I don't use Opera though, I use the berry browser set to identify and IE and with Javascript off.

    I usually find the video I want on m.youtube.com

    Use the menu to pull up the page address and copy it

    Go to keepvid.com from my bookmark and paste the URL

    I'll give Opera a try and see if I can do it....
    05-22-09 04:35 PM
  5. blaisedinsd's Avatar
    Well I can' figure out a way to copy a URL with Opera in order to paste it in to keepvid

    I plan on seeing how this fix on my wife's storm to see what I find.
    She is running .122 (actually the version that came out before the full .exe was available)
    05-26-09 10:23 AM
  6. JRSCCivic98's Avatar
    SSL Certificate lists would have no affect on this sort of behavior. I think you might have stumbled across a coincidence, but that's about it.
    05-26-09 10:53 AM
  7. blaisedinsd's Avatar
    Didn't work too well on .122 (oops, I forgot to *228 though when I tried it)

    5 Poynt trailers failed before deleting it, and after I only had one success out of about 6 tries.

    I am going to upgrade the second Storm to .148 and test for repeatability.

    And this RSA is expired, it seems if you need it for someting it will give you problems....I had Instango checking it and prompting me to the point it was unusable on .141

    I deleted this expired certificate and that issue was fixed.
    Last edited by blaisedinsd; 05-26-09 at 02:46 PM.
    05-26-09 01:55 PM
  8. 1magine's Avatar
    I need RSA for token codes. No streaming podcasts for me.
    05-26-09 02:42 PM
LINK TO POST COPIED TO CLIPBOARD