1. bk99nd's Avatar
    I have purchased and have been using Garmin Mobile version 5.4.2 for over a year on my Storm 9530 without issue. I recently upgraded from OS 5.0.0.328 to 5.0.0.591 and it is unable to figure out my current location or acquire satellites.

    I went to see if there is an update available but it downloaded the same version again.

    Is this a known issue, or do I need to downgrade my OS?
    05-06-10 09:51 AM
  2. doctorlove316's Avatar
    Hmmm...

    I'll have to go outside of my work and try it out. I don't remember having any of these problems after upgrading to .591 but I'll try when I can.

    BTW, are you sure your GPS is set to ON? After I upgraded, it was back to 911 ONLY for me and I had to change it.
    05-06-10 11:22 AM
  3. bk99nd's Avatar
    I have double checked and the GPS section has the following options set:

    GPS Data Source: Device GPS
    GPS Services: Location On
    Location Aiding: Enabled
    05-06-10 09:40 PM
  4. viceversa's Avatar
    Permissions set to allow all?
    05-06-10 10:31 PM
  5. vaca232's Avatar
    My GPS likes to randomly not work occasionally even after several battery pulls... Is it just Garmin Mobile, or any mapping program?
    05-06-10 10:33 PM
  6. bk99nd's Avatar
    I have the permissions set to Allow for Connections, Custom for Interactions as the Security Timer Reset sub option is set to Deny and I can't change it. User Data is set to Allow as well.

    I downloaded Google Maps and it also tells me GPS is not available and gives me a location within so many meters.
    05-09-10 09:28 AM
  7. viceversa's Avatar
    and why dont you try setting permissions for all of these apps and see what happens? options->applications->garmin/googlemaps->edit permissions

    allow allow allow for everything
    05-10-10 07:51 AM
  8. bk99nd's Avatar
    I set allow for all 3 permission groups for both Garmin Mobile and Google Maps and uninstalled/reinstalled Garmin Mobile and it still doesn't work. I guess I need to either downgrade the os or install a hybrid. Any advice?
    05-10-10 10:06 PM
  9. doctorlove316's Avatar
    I'm running Lyricidal's latest public .591 hybrid and Garmin works fine for me. I had to set all permissions to ALLOW but after that, all was well.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-10-10 10:29 PM
  10. Riding the Storm Out's Avatar
    bk99nd,

    I also upgraded from OS 5.0.0.328 to OS 5.0.0.591 (no hybrid). I'm running the same Garmin Mobile version you are (5.4.2), and it is working fine on my Storm. I don't know why it isn't working on yours. Here are my settings:

    GPS options:
    GPS Data Source - Device GPS
    GPS Services - Location On
    Location Aiding - Enabled

    Garmin Mobile permissions:
    Connections - Allow
    Interactions - Custom
    User Data - Allow
    Under Interactions, everything is set to Allow except:
    Input Simulation - Deny
    Browser Filtering - Deny
    Recording - Prompt
    Security Timer Reset - Deny
    Display Information While Locked - Deny

    I also checked Google Maps and BlackBerry Maps, and they are both working fine as well. I hope this helps. Good luck!

    Riding the Storm Out
    05-10-10 11:26 PM
  11. bk99nd's Avatar
    Should I just wipe the OS and reload it?
    05-11-10 10:22 AM
  12. Riding the Storm Out's Avatar
    Should I just wipe the OS and reload it?
    bk99nd,

    Since you're also seeing the GPS issue with other apps (i.e., Google Maps), I believe that's what I would try next. Reloading the OS may correct the problem...

    Riding the Storm Out
    05-11-10 11:53 PM
  13. bk99nd's Avatar
    I called verizon and they had me wipe the phone after I downgraded to 5.0.0.328. I can't get any map program to work including blackberry maps. That application times out with the message "Unable to acquire GPS lock." The phone is out of warranty so there is nothing verizon can do for me either it seems. Anyone else have any ideas?
    05-12-10 06:12 PM
  14. Riding the Storm Out's Avatar
    I called verizon and they had me wipe the phone after I downgraded to 5.0.0.328. I can't get any map program to work including blackberry maps. That application times out with the message "Unable to acquire GPS lock." The phone is out of warranty so there is nothing verizon can do for me either it seems. Anyone else have any ideas?
    bk99nd,

    Don't give up just yet. Upgrading (or downgrading) an OS should not be able to physically damage any hardware in a phone. And the chances that the GPS circuitry coincidentally failed at the precise moment you were doing an OS upgrade, while possible, is extremely unlikely. That's why I still believe the problem is firmware or software related (which suggests that it can be fixed by changing one of those two things).

    So, did you recheck the GPS settings and application permissions again after you reinstalled the .328 OS (it's possible for those settings to change during an OS install)? Also, have you done one or more battery pulls following the OS install (to allow the files to reload into memory properly)? Usually, wiping a phone and reinstalling the OS fixes most problems, so I think we're simply missing something. We just haven't figured out what it is yet! If I come up with anything else to try, I'll let you know. Good luck!

    Riding the Storm Out
    05-13-10 12:10 PM
  15. bk99nd's Avatar
    How do I wipe this thing and load it up from scratch? The security wipe verizon had me do only wiped my applications and settings, but kept the OS as is. I am as skeptical as you are. Is there a fool proof way to wipe this thing so I don't brick it and then be able to load the OS back on it. If so, please point me in the right direction.

    I have since tried putting .419 and .591 back on top of it and still not able to use it. I don't need VZ navigator or some other software on this thing to enable the GPS do I?
    05-13-10 02:47 PM
  16. Riding the Storm Out's Avatar
    How do I wipe this thing and load it up from scratch? The security wipe verizon had me do only wiped my applications and settings, but kept the OS as is. I am as skeptical as you are. Is there a fool proof way to wipe this thing so I don't brick it and then be able to load the OS back on it. If so, please point me in the right direction.

    I have since tried putting .419 and .591 back on top of it and still not able to use it. I don't need VZ navigator or some other software on this thing to enable the GPS do I?
    bk99nd,

    Unfortunately, I'm not an expert on JL_Cmder, so I can't really say what pitfalls there might be. There are a number of threads in the OS Discussion forum that have step by step instructions for wiping before an OS install. I'd check out a few of those before proceeding. I do know that backing up both your phone data and 3rd party apps is absolutely critical before doing a wipe.

    As far as needing any specific software to enable GPS to work, I believe some apps require BlackBerry Maps to be installed to work properly, but I'm fairly certain that Garmin Mobile is not one of them. I have BB Maps, Google Maps, and Garmin Mobile on my phone, although I really only use the Garmin Mobile. Good luck!

    Riding the Storm Out
    05-14-10 01:35 AM
  17. bk99nd's Avatar
    I used JL Commander last night and wiped the operating system and reinstalled it, without restoring my applications. Oddly, it remembered my device password, so not 100% sure it was all cleared out.

    I downloaded garmin again and the phone is still stuck acquiring satellites. I am at a loss as to what could be wrong. Is there a chance it somehow has a loose connection inside the phone? Not sure I would even know how to look for that anyway.

    Any ideas or is it time for me to give up?
    06-09-10 09:38 AM
LINK TO POST COPIED TO CLIPBOARD