07-03-10 10:12 AM
45 12
tools
  1. NYGiants2008's Avatar
    pull your battery out and put it back in
    08-12-09 08:12 PM
  2. macsti's Avatar
    I realize these posts are kind of old, but I just got a Storm and having the same problem with one odd exception; my battery will charge just fine when plugged into USB, but will not charge when plugged into wall charger or car charger. I have tried 3 other AC wall chargers that successfully charged other Storms. I did several battery pulls and still cannot get the charger to work.
    I guess, at the end of the day, I should just be happy that it charges via USB, but I am afraid this may be part of a larger issue with the battery and/or phone. I also tried another battery from a Storm that was able to charge from the wall charger and still no luck.
    I will second your issue and throw this kink into the armour....I will not charge from the AC cord itself or the car charger, but when I plug the AC cord into the desktop charging pod, it works find...hmmmmmmmm.......
    08-21-09 08:50 AM
  3. kinggeoff's Avatar
    Anyone having charging problems should take their device and charger into their carrier's store and have them take a look at it.
    08-21-09 09:12 AM
  4. bizymare's Avatar
    This thread is interesting. I have had the Storm since Dec. Beginning in June, I can plug in my charger and get the charging bolt and my phone goes to the clock. Everything appears to be fine. Get up in the morning, no additional charge. I've had the same problem when I try to charge in the car. It's completely random as to when it happens and now it's starting to happen to my husband's Storm, too.

    If I do a quick pull it seems to fix it, but I'm really not interested in doing a battery pull every time I need to charge my phone. It's not that I can't, it's more that it should work correctly. I mean, I need a charge on my phone, you know? Guess I'm going to head into Verizon and see what they say.
    08-23-09 06:28 PM
  5. paulwright1's Avatar
    This thread is interesting. I have had the Storm since Dec. Beginning in June, I can plug in my charger and get the charging bolt and my phone goes to the clock. Everything appears to be fine. Get up in the morning, no additional charge. I've had the same problem when I try to charge in the car. It's completely random as to when it happens and now it's starting to happen to my husband's Storm, too.

    If I do a quick pull it seems to fix it, but I'm really not interested in doing a battery pull every time I need to charge my phone. It's not that I can't, it's more that it should work correctly. I mean, I need a charge on my phone, you know? Guess I'm going to head into Verizon and see what they say.
    are you using generic chargers or are they the ones that came with the BB?
    08-23-09 06:49 PM
  6. bizymare's Avatar
    are you using generic chargers or are they the ones that came with the BB?
    The original AC that came with the phone. The car is a third party charger.
    Last edited by bizymare; 08-23-09 at 07:41 PM. Reason: added the car charger part
    08-23-09 07:38 PM
  7. paulwright1's Avatar
    The original AC that came with the phone. The car is a third party charger.
    if I were you I would stay away from the generic chargers. I would plug your home charger into the wall and let the storm charge for an hour and see if that fixes it.
    08-23-09 07:44 PM
  8. bizymare's Avatar
    if I were you I would stay away from the generic chargers. I would plug your home charger into the wall and let the storm charge for an hour and see if that fixes it.
    Thanks for the input. It doesn't help. And the car charger didn't work only after a night of not charging in the house (on a morning I needed a full charge all day.) It happens randomly - once a week or so.

    Like I said, it appears to be charging with the bolt and going to the clock default, but it's not. Only a battery pull shakes it out of the dead zone.
    Last edited by bizymare; 08-23-09 at 07:53 PM. Reason: added how often it happens
    08-23-09 07:52 PM
  9. paulwright1's Avatar
    Thanks for the input. It doesn't help. And the car charger didn't work only after a night of not charging in the house (on a morning I needed a full charge all day.)

    Like I said, it appears to be charging with the bolt and going to the clock default, but it's not. Only a battery pull shakes it out of the dead zone.
    well Im sorry to hear it didnt work. Do you have insurance? Or can you exchange it at the store?
    08-23-09 07:54 PM
  10. bizymare's Avatar
    well Im sorry to hear it didnt work. Do you have insurance? Or can you exchange it at the store?
    I will take it into Verizon this week. It's going to be one of those things, though. Can't make it happen in front of them. Maybe I'll wait until it doesn't charge again and then bring it in.
    08-24-09 12:34 AM
  11. paulwright1's Avatar
    I will take it into Verizon this week. It's going to be one of those things, though. Can't make it happen in front of them. Maybe I'll wait until it doesn't charge again and then bring it in.
    bring the chargers in as well. Make sure your nice and tell them your story. Im sure they will give you a replacement
    08-24-09 12:42 AM
  12. bizymare's Avatar
    bring the chargers in as well. Make sure your nice and tell them your story. Im sure they will give you a replacement
    I'll let you know how it goes. I am the queen of "attracting more flies with honey than vinegar."
    08-24-09 12:53 AM
  13. bizymare's Avatar
    bring the chargers in as well. Make sure your nice and tell them your story. Im sure they will give you a replacement
    Just a follow up. Brought in the phone and wall charger to Verizon. Gave me a new phone on the spot. Have to say, the new Storm is working a lot better than the old one from December. The light leak is dramatically less and seems more responsive (accelerator) than the old one.
    08-28-09 01:18 PM
  14. butchybutch's Avatar
    I read about a special battery for the storms only. Thats why you will see the lock icon on the original battery. The D-X1 has some type of crpytic logic circuitry
    10-24-09 03:53 PM
  15. vybuiii's Avatar
    im having the same issue too, everytime i charge my blackberry, it has the lightening bold on it but really, its not really charging, i let it charge overnight, and when i check it, its coompletely dead! help pls :/
    12-31-09 10:55 AM
  16. elgordon's Avatar
    I just went through a charging issue.
    I found my phone at the same charge level after a full night of charging.
    I used my car charger and did get a small charge. Noticed the lighting bolt would disappear and still be under charged.
    Verizon at first gave me a new battery. Second visit I got a new charger. Third visit a got a new phone. Seems that the charging port was bad.
    It took three different people at Verizon to resolve this. My first two visits they thought I was nuts.
    01-02-10 03:09 PM
  17. mkarps's Avatar
    I would use the BB chargers. I've always used generics but have heard many problems with the Storm being "picky". Plus you can get oem chargers for about $5 a piece on ebay.
    01-04-10 08:34 AM
  18. lukehyun's Avatar
    To all who have problems charging with the message "unauthorized charger". I had issues charging my blackberry in the car and I found this solution on another forum.
    1. Take the battery out while the phone is still plugged in.
    2. Hold the off (red) button for about thirty seconds until the screen changes to a battery with a red line through it.
    3. Reinsert the battery.

    I did this and haven't had a problem since, it's been about three days or so.
    04-27-10 01:10 PM
  19. jeffmeden's Avatar
    I would bet that the issue is in the contacts and not the battery or the software. Doing a battery pull re-seats the connection and will let it charge normally (for some time). This is the same kind of problem that happens to a lot of phones, people beat their heads against the wall thinking it's the charger, or the USB plug, or the phone, or the battery, and if you replace any one of those things at a time (except maybe the phone) you won't fix the problem. Clean the terminals on the battery and the phone!
    04-27-10 01:54 PM
  20. Mstark223's Avatar
    I have the same problem as well but I have it as a result of charging in my car as I am rarely home. The inner part of the micro USB port on the phone has been pushed out of alignment and doesn't make a good connection. it would be plugged in at night and be dead in the morning and only through constant moving of the phone and cord would the charge light indicator light up. I used a thin bladed knife to push the center lug of the phones micro USB port towards the back of the phone and it seems to be working like normal. Maybe that will help.

    Matt
    07-03-10 10:12 AM
45 12
LINK TO POST COPIED TO CLIPBOARD