07-03-10 10:12 AM
45 12
tools
  1. JustAThought's Avatar
    First, I did a search and haven't seen this. I apologize if it's been brought up and I didn't find it.

    I got the Storm on Friday. I charged it all the way with no problem and it worked great over the weekend.

    Charged it Sunday night with no problem. I plugged it in Monday night and Tuesday morning it was at the same charge level as when I went to bed. Hmmm.

    By yesterday (Tuesday) afternoon, I was down to one bar and put it on the charger again. The lighting bolt came on...but no charging.

    I put it on the charger again last night (by the way, it was fully drained at that point). The red light came on, but again, no charge this morning when I got up. So now, a completely dead Storm.

    Any ideas, solutions or suggestions? Has this happened to anyone else? By the way, I was using the wall charger.

    Thank you for your help!
    Kim
    11-26-08 09:50 AM
  2. JustAThought's Avatar
    btt...can anyone help?
    11-26-08 10:12 AM
  3. EdwardK's Avatar
    Did you try both the USB to PC and the AC Charger? I don't have the issue, but I do notice that connecting it to the Laptop (laptop plugged in) takes forever to charge the phone.
    11-26-08 10:22 AM
  4. JustAThought's Avatar
    I was using the AC charger.
    11-26-08 11:58 AM
  5. spawn026's Avatar
    just for kicks, did you try turning your phone off and charging? maybe even checking the status to see if the battery level moves eventhough the bars look the same? just trying to throw out ideas
    11-26-08 12:01 PM
  6. Gaget's Avatar
    make sure you are closing all your apps on the phone. If you have so many open it could be sucking the life of your phone. Do you see the symbol showing you it is charging (lightning bolt) when you plug in the charger?
    11-26-08 12:01 PM
  7. cbagz's Avatar
    First, I did a search and haven't seen this. I apologize if it's been brought up and I didn't find it.

    I got the Storm on Friday. I charged it all the way with no problem and it worked great over the weekend.

    Charged it Sunday night with no problem. I plugged it in Monday night and Tuesday morning it was at the same charge level as when I went to bed. Hmmm.

    By yesterday (Tuesday) afternoon, I was down to one bar and put it on the charger again. The lighting bolt came on...but no charging.

    I put it on the charger again last night (by the way, it was fully drained at that point). The red light came on, but again, no charge this morning when I got up. So now, a completely dead Storm.

    Any ideas, solutions or suggestions? Has this happened to anyone else? By the way, I was using the wall charger.

    Thank you for your help!
    Kim
    This also happened to mine. Did a battery pull and seems to be alright.
    11-26-08 12:10 PM
  8. raorth's Avatar
    Is the outlet connected to a switch that you may be turning off before going to bed?

    Just a thought
    11-26-08 12:11 PM
  9. JustAThought's Avatar
    spawn026

    just for kicks, did you try turning your phone off and charging? maybe even checking the status to see if the battery level moves eventhough the bars look the same? just trying to throw out ideas
    Originally, I didn't turn the phone off when charging. The battery level didn't increase (and it was red, so I knew it was almost dead). I got the message that popped up saying that the battery needed charging and the phone was shutting down. Well, DUH...I've been trying to charge it! The phone turned off. I persisted with plugging it in (that was last night). This morning, the phone was still completely dead.

    Gaget
    make sure you are closing all your apps on the phone. If you have so many open it could be sucking the life of your phone. Do you see the symbol showing you it is charging (lightning bolt) when you plug in the charger?
    There were no open apps at the time when I was trying to charge. Obviously, once the phone shut down, there were no open apps. While there was still a bit a juice remaining, it did show the little lightning bolt. Once the phone shut down, I couldn't tell if the lightning bolt was there or not.

    This also happened to mine. Did a battery pull and seems to be alright.
    I pulled the battery and reinstalled it. It still didn't charge. Thank you though.

    Is the outlet connected to a switch that you may be turning off before going to bed?

    Just a thought
    I'm a female. I actually do read directions. Not to mention the fact that there's a pretty little green light thingy on the charger do-hickey that is lit up. (power from the outlet to charger...check). When there was still a bit of juice, the light in the upper right was flashing and there was a lighting bolt where the battery life shows. (Power to Storm...check). Unfortunately, there doesn't appear to be a connection between the power coming in and the battery, even though the phone seems to think it's charging.

    OK, just checked it. The red light is not blinking now. Could someone with a working unit tell me if that is the charge indicator (in addition to the lightning bolt that's not showing)?
    11-26-08 12:33 PM
  10. cbagz's Avatar
    So when you plug in the charger with the device turned off, does the the green light flash? Maybe reseat the prongs on the adapter (push and take off, than push back on).
    11-26-08 01:41 PM
  11. JPremo's Avatar
    I'm having the same problem, can someone please help. I have no idea what to do, I've done 2 battery pulls and nothing, now my phone is completely dead.
    11-26-08 07:36 PM
  12. JPremo's Avatar
    ::BUMP::

    Seriously, has anyone else had this problem? I called tech support and they had me wipe my phone (BEFORE I EVEN BACKED IT UP), and still, it isn't charging. What should I do? They ordered me a new one, but it won't be here until the 15th!
    11-27-08 12:22 AM
  13. bhirsch's Avatar
    I had the same problem. I pulled the battery and did a soft reset and now it seems to be ok.
    11-27-08 07:08 AM
  14. teal's Avatar
    There was another thread about problem batteries and the Storm. Some folks were given new batteries by VZW. Wish I could help more than this folks.
    11-27-08 07:11 AM
  15. mbr's Avatar
    I got a new battery last night from vzw seems to work better now. couldnt hold a charge for more than 7 hours with no use
    11-27-08 07:14 AM
  16. JPremo's Avatar
    I had the same problem. I pulled the battery and did a soft reset and now it seems to be ok.
    i really wished that would have helped. i'm so unhappy about this, and i cant find anything else about this happening.
    11-27-08 07:32 AM
  17. JPremo's Avatar
    update: i went to the verizon store and it happened to be a defective charger.


    just letting anyone else know who might have this problem
    11-30-08 05:36 PM
  18. Jfredrix's Avatar
    Just searched and found this thread - having similar problem. Plugged my 75% charged Storm into USB charger to top it off & when I went to get it, phone has powered off. I thought it just needed a battery pull but when I did that, it got about 1/2 way through the power-up process and died. So, I left it plugged in all night in my wall charger, where it repeatedly (I think) powered up and shut down all night (battery charging icon with bolt was on). When I woke up, it was powering up. I unplugged it from the charger and it lasted about 2 minutes before powering down due to dead battery. Interesting that it first happened while charging. In fact it quickly DISCHARGED from a 75% charge in about an hour, while charging.

    In my case, having used two different chargers, I doubt if it's the charger. I had no problems with battery charging before this and have had my Storm since the release date.
    12-13-08 08:38 AM
  19. Jfredrix's Avatar
    Finally got my battery to hold a charge - on the third try, this time back with the usb charger. I wonder if there could be a problem attempting to charge a totally drained battery at the same time the device is trying to boot up? In other words, if it is taking all the available juice to power up, it drains the battery totally and the Storm shuts itself down again, whereupon it recognizes that it is attached to a power source and it attempts to reboot - only to have the process start all over again. Rinse, wash, repeat. At least that's what it seemed like mine was doing.
    12-13-08 02:13 PM
  20. frankied101's Avatar
    Same problem but i did battery pull and pluged it in agian. I am not sure what it looks like when it charges after dying (first time i ever let it die) but there is a green blinking light but it is still dead when i unplug so does the green blinking light while the phone is off mean it is charging?
    05-20-09 04:20 AM
  21. Dyzrv's Avatar
    welcome to crackberry ... JustAThought
    05-20-09 05:41 AM
  22. LAN-WAN-IT's Avatar
    I realize these posts are kind of old, but I just got a Storm and having the same problem with one odd exception; my battery will charge just fine when plugged into USB, but will not charge when plugged into wall charger or car charger. I have tried 3 other AC wall chargers that successfully charged other Storms. I did several battery pulls and still cannot get the charger to work.
    I guess, at the end of the day, I should just be happy that it charges via USB, but I am afraid this may be part of a larger issue with the battery and/or phone. I also tried another battery from a Storm that was able to charge from the wall charger and still no luck.
    05-21-09 03:35 PM
  23. tghockey07's Avatar
    November 26th? That must be right after the release and everyone runnin .65. Lan-wan-it just bring it in to Verizon/ Vodafone or whoever dealer and they will just give you a different phone.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-21-09 04:41 PM
  24. Demilitch's Avatar
    I know this is an old post, but I run into this issue from time to time. Phone charges fine on the USB or Car charger. Wall charger only works sometimes.... which makes no sense. Sometimes a batt pull resolves the issue. If all chargers dont work for you, then its the batt or the phone itself. I am most likely going to try a different wall charger. I usually charge mine via USB at work, so I never run low. Only on weekends when I forget and have to use the wall charger does this happen. Just wanted to let you know that you are not alone in these issues.
    06-04-09 09:16 AM
  25. Stormpwnsiphone's Avatar
    i have the same problem, HELP...
    08-12-09 02:31 PM
45 12
LINK TO POST COPIED TO CLIPBOARD