1. hughdrbf's Avatar
    The Escape key (immediately left of the red End button) does absolutely nothing, even when following the sequesces in the User's Guide. The only way I can get out of any screens is Menu button | Close.

    Has anyone seen the Escape key work?
    11-23-08 06:43 PM
  2. eric256's Avatar
    I constantly use the escape key...no idea why yours wouldn't be working.
    11-23-08 06:55 PM
  3. vzwty's Avatar
    Mine was doing this earlier. Actually my BB and ESC key weren't working. Now they are working fine. I deleted a few of the pre-installed apps I dont use and it seems to do the trick. Try that.
    11-23-08 06:58 PM
  4. hughdrbf's Avatar
    Thanks - mine is competely inop. I uninstalled VZNavigator and Visual Voicemail and did see the speed improvement. But still no Escape key functionality.
    11-23-08 07:03 PM
  5. MD-Dave's Avatar
    Mine is messed up too. I called TS and they said they would replace it ; once they get more in stock.
    Since then I found that if I push really hard it will work sometimes.
    My wife's BB button is the same way.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-23-08 07:19 PM
  6. hughdrbf's Avatar
    Thx - looking more and more like a hardware problem.

    Edit: I just tried pressing harder and - yep - it worked. Hardware issue it is.

    Much appreciated.
    Last edited by hughdrbf; 11-23-08 at 07:39 PM.
    11-23-08 07:35 PM
LINK TO POST COPIED TO CLIPBOARD