1. meikle's Avatar
    Hi all,
    Had my storm 2 for 3 weeks now all going well until the weekend when the sound through the earpiece is muffled, I've tried all the sound settings that I can find but no difference.
    Any help would be appreciated.

    Thanks
    Col
    04-27-10 08:01 AM
  2. KenBMD's Avatar
    Hi all,
    Had my storm 2 for 3 weeks now all going well until the weekend when the sound through the earpiece is muffled, I've tried all the sound settings that I can find but no difference.
    Any help would be appreciated.

    Thanks
    Col
    Does it sound like static too? I'm on my 3rd storm 2 because after awhile the ear piece sounded like it was blown out.
    04-27-10 08:06 AM
  3. StaticFX's Avatar
    i returned my first because in certain positions, the right earpiece would cut out.

    Spin the plug in the jack, does it change? return it before your 30days and get a new one.
    04-27-10 08:26 AM
  4. meikle's Avatar
    i returned my first because in certain positions, the right earpiece would cut out.

    Spin the plug in the jack, does it change? return it before your 30days and get a new one.
    It's only when talking on the phone that the problem occurs, it' s as if there's something covering the speaker.
    04-27-10 09:56 AM
  5. heateris's Avatar
    Get it replaced. I had the same problem on my first two storms.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-28-10 08:35 AM
  6. duece2478's Avatar
    my last four have done that, I have used my blue tooth the last two weeks because mine barely works at all. This is the reason I am switching over tomorow.
    04-28-10 08:46 AM
  7. meikle's Avatar
    New phone delivered this afternoon, someone start the stopwatch as I don't hold out much hope for this phone lasting long...unfortunately.

    I'll keep you posted so to speak

    Col
    04-29-10 08:41 AM
  8. meikle's Avatar
    Well just as expected 2nd phone now started to play up, it's a different problem to my last phone, this one keeps freezing & the screen seems to tense up if that makes sense.
    Can't beleive how **** thisphone is, I love the functions, looks, everything except it does'nt work.

    Col
    05-06-10 09:25 AM
  9. HMBgal's Avatar
    I've had a S1 and a S2 and have never had a problem...until a few days ago when my stereo pin broke and now I'm waiting on a refurb. I don't use BlueTooth (one more thing to lose, keep charged) so I don't know if using a wired headset creates more wear than the phone can take, but I would think that if you're going to have the option to use it, the jack should last longer than a few months, yessss???
    05-06-10 09:38 AM
  10. mattp13's Avatar
    Do you have it through any case because sometimes causes it to not be plugged in all the way
    05-06-10 10:40 AM
  11. meikle's Avatar
    Well gave up with battety pulls all day....new handset (3rd) ariving on Monday
    I'll keep you all posted...does anyone else have problems with S2?

    Posted from my CrackBerry at wapforums.crackberry.com
    05-07-10 11:25 AM
  12. tbonenga's Avatar
    hey are we talking about the phone itself or the headset? my phone sounds like crap and i can't get it fixed. since i'm a tmobie customer verizon want help me and RIM want fix it or sell me the part. i can't find the part on ebay or any where else. i'm screwed for now. to be able to hear people clearly i have to use the speaker phone option.
    05-08-10 12:24 AM
  13. art50's Avatar
    My earpiece speaker started sounding very tinny and echoed. I got it replaced yesterday in the store. The first 3 were replaced in the store, #4 was a refurb sent to me, and #5 in the store again. BTW, this is my 5th one in 39 days.........all with the SAME problem........

    All the tech's in this corporate store know me by name now, its kinda funny. When they see me walk in, and check in on the screen, they call my name and already have a new Storm2 sitting there waiting for me........15 minutes and i'm outta there.......

    I had the Storm1 ever since it came out and only had 1 issue. The LED burned out like 6 months after I got it. In comparison, my opinion only, the Storm2 is junk......
    05-09-10 08:21 AM
  14. jiggyb's Avatar
    I never had a problem with my ear piece since release day. I just upgraded to a .607 hybrid from straight .517 and almost instantly got the same "broken" sounding speaker everyone describes. I haven't had a chance to downgrade yet, but what OS is everyone with this problem on. Wishful thinking I know.

    EDIT:
    I just searched some other threads about distortion and there were several people reporting a change after installing a new OS and others said they fixed it by reinstalling their OS.

    This was my hunch becasue mine doesn't sound so much "tinny" and busted as it does severely interfered with.
    Last edited by jiggyb; 05-09-10 at 11:27 AM.
    05-09-10 11:21 AM
  15. meikle's Avatar
    OK...received 3rd phone so again start the stop watches....aparantly after 3No phones I can bin this pile of S---- & pick another brand.

    When does BB6 come in to play & will it make theStorm2 worth keeping?
    05-11-10 08:57 AM
  16. meikle's Avatar
    Well just as I thought Storm 2 is now being replaced AGAIN, what an absolute piece of S**t this phone is.
    I've been forced to get an HTC Mini from o2 which i'm not too happy about but I need a phone that works & the S2 doesn't.
    Good luck with BBs OS6 comes out, I wish I could wait but I use my phone for work.......THE STORM IS OVER
    06-07-10 06:57 AM
  17. dkingsf's Avatar
    I don't believe it's the hardware after all that. I also believe it's the .607 OS which should NEVER have been released as "official"

    If you would have used the Sakatel .517 OS (and perhaps a hybrid based on that) you would have not had this problem.

    I've had nothing but problems with my S2 in many areas that people have complained about when on the .607 or any hybrid based on that, and I've tried a half dozen. Screen clicks, headset issues, bbm, videos, bluetooth etc. etc. I always go back to .517 SaskaTel official or use OOAK's 517/604 hybrid (on it now) and all my troubles melt away. Will never load another 607 based OS on my S2. Waiting patiently for OS6 before even attempting another upgrade. And I'll dump OS6 and go back again if I have to. We'll see.
    06-07-10 09:19 AM
LINK TO POST COPIED TO CLIPBOARD