1. TheMechanix's Avatar
    So all of a sudden my phone isn't working right, or hardly at all.

    With my phone powered on I can highlight my apps but when i click on the nothing happens. The four buttons on the bottom of the storm are also non responsive.

    I have gone through every wipe/restore possible and now after pulling the battery the phone boots up then comes the User Agreement page for the restored/updated software. I can highlight the "ok" button but when pressing there is no response and it just stays there.

    Any Ideas??
    02-12-09 06:16 PM
  2. MyKuL#CB's Avatar
    Sounds like hardware to me. Though it seems strange for all the buttons to fail...

    Posted from my CrackBerry at wapforums.crackberry.com
    02-12-09 07:46 PM
  3. roastdawgg's Avatar
    ha maybe the air pressure where you are is preventing the buttons from clicking...hopefully someone remembers that thread and laughs like i did when i thought it in my head.
    02-12-09 08:19 PM
  4. SleepyTheDon's Avatar
    So all of a sudden my phone isn't working right, or hardly at all.

    With my phone powered on I can highlight my apps but when i click on the nothing happens. The four buttons on the bottom of the storm are also non responsive.

    I have gone through every wipe/restore possible and now after pulling the battery the phone boots up then comes the User Agreement page for the restored/updated software. I can highlight the "ok" button but when pressing there is no response and it just stays there.

    Any Ideas??
    Sounds like you need to had over to VZW store for a replacement
    02-12-09 11:31 PM
  5. BBartist's Avatar
    Ya straight up hardware, bring it back. make sure the phone is still not working before you walk into the store...it just seems like that every time i walk into the VZW store the phone decides it wants to work just fine then I look like an ***** when I bring it up to the counter oh well

    let us kno how it goes
    02-12-09 11:54 PM
LINK TO POST COPIED TO CLIPBOARD