1. chrisnome's Avatar
    So, I've water damaged a couple blackberries before, so I knew what to do..

    Immediately pulled the battery out before it short circuited!
    Went 3 days without it and did a combo treatment from everything I've learned on the internet..
    stuck it in the fridge which dehydrates it.
    stuck it in a rice bag which dehydrates it.
    heated it against the fireplace to evaporate the water.
    then on day three the fateful moment came... I put the battery back in.. and it worked, completely
    It paused for a little bit on startup (OS 5.0.0.386) but then booted completely up
    It just had a little residual water on the underside of the screen and I'd known from a previous experience, it evaporates off.

    First, I felt completely releived and then satiated.. they really are crack, no doubt.
    Then I used it like nothing ever happened, and it worked.. perfectly.
    I even listened to music at the gym while running
    toooooo smooth I had pulled it off!
    BUT then.. today, three days later, I took it outside to finally get back to my job hunt, cause for the first time here it's been sunny, not raining or snowing, and the screen was blank with that residual 503 ERROR screen
    I thought it was just that it ran out of memory and needed a reboot, but it never got past the red dot, never brought up the hourglass or load screen
    I figured, ok, well, I probably just have to reload the software
    For the last three hours I've been trying to do the whole 'nuked BB thing' here

    I'd post the link but it won't let me until I have at least 10 posts, what a joke. Well look it up, it's the crackberry guide to recovering a nuked BB and they have a youtube clip too

    Only, it's different. I can't get past the initial connection screen unless the battery is IN, not out. I have to literally put the battery in for it to read the config; that is the opposite of what it says in the link above. Initially I only had the old 4.7 OS on my computer (did a wireless update for the new OS) and so I loaded that on. Once again, it did not detect the BB at all unless the battery was IN the BB. It got past the initial checkmark which was loading the JVM and system software, then when it tried to initialize the BB went into an infinite reboot cycle (However, this time it brought up an hourglass, a tiny glimmer of hope, after putting the battery in, but that's as far as it got). So I downloaded the latest OS from Verizon and tried to load that. That brought no hourglass at all, the screen starts to load, then cycles off in another infinite reboot cycle. Let me stress again, that the computer will only detect the BB when the battery is in. If it's not it gives me error messages. I don't get error messages when it's in, except at the initialization checkmark after it reboots a couple times, it tells me to reconnect it and try again (with the same result about 30 times now).

    Anybody have any ideas as to how I can fix this software error? Obviously, I don't have 500 dollars for a new Storm, as I'm using it to find a job, and need it to get a job.

    The storm is in the fridge right now haha
    Puke
    05-14-10 06:51 PM
LINK TO POST COPIED TO CLIPBOARD