1. mvoloch's Avatar
    dropped my Storm2 today on the floor and now the screen stopped clicking and vibrate is gone. there is something wrong with the piezos but i have no clue on how to fix it. anyone?
    bad is that i am in brazil and Storm2 has not been released here, so there is no support for the device.
    appreaciate if someone could help.

    thanks
    06-11-10 12:11 PM
  2. nathan5a's Avatar
    Have you tried pulling the battery and seeing if that makes a difference? If not, you may want to see if you can get it exchanged.
    06-11-10 01:07 PM
  3. Thud Hardsmack's Avatar
    Have you tried pulling the battery and seeing if that makes a difference? If not, you may want to see if you can get it exchanged.
    Agree with the battery pull; aside from that all I have to add, since you're not in the US, is that the vibrate is produced from the piezo's along with the screen click so if the piezo's are in any way damaged they won't work and neither will the vibrate function. Is that all that's wrong with your device? Functions fine otherwise?
    06-11-10 01:28 PM
  4. mvoloch's Avatar
    all functions are fine, except whatever is needed from the piezos - click and vibrate.
    i am in brazil and my phone is from Vodafone Germany. Storm2 has not been released here in Brazil so i have no where to run to... except counting with the help of CB's good people.
    thank you!

    and yes... i've done at least a dozen battery pulls.
    06-11-10 05:15 PM
  5. Thud Hardsmack's Avatar
    all functions are fine, except whatever is needed from the piezos - click and vibrate.
    i am in brazil and my phone is from Vodafone Germany. Storm2 has not been released here in Brazil so i have no where to run to... except counting with the help of CB's good people.
    thank you!

    and yes... i've done at least a dozen battery pulls.
    Unfortunately, I have no skill in hacking/modding device hardware, nor do I know much about getting things fixed outside the US Hopefully someone reads this and has something more to offer where I don't.
    06-11-10 05:23 PM
  6. SA13's Avatar
    I know this sounds crazy but on your battery pulls have you tried to leave your battery out for 5 min or so before you put it back in

    Posted from my CrackBerry at wapforums.crackberry.com
    06-11-10 08:42 PM
  7. Thud Hardsmack's Avatar
    I know this sounds crazy but on your battery pulls have you tried to leave your battery out for 5 min or so before you put it back in

    Posted from my CrackBerry at wapforums.crackberry.com
    Add to that: hold the device face down as you pull the battery, keep it face down as it reboots all the way.
    06-11-10 08:52 PM
LINK TO POST COPIED TO CLIPBOARD