1. christopherj's Avatar
    My Storm appears to be permanently stuck in Headset mode for calls. Sending and receiving. Pressing the "Handset" button does absolutely nothing. Here's some other things I've tried;

    -Plugging in and unplugging the headset
    -Reset
    -Reset + battery pull
    -Switching to handset mode from the music menu (this works) and then trying to place a call.
    -Same as above except placing the call while music is still playing from the earpiece. The phone simply switches back to headset mode for the duration of the call.

    Also, why does there not seem to be any speakerphone button during calls? I'm assuming it has something to do with my non-functional handset button or it's just not available during headset mode.

    Anyways, I'm heading to my wireless store now to see if they can fix it. Hopefully someone has some insight to post by the time I get back...

    Thanks in advance for any help!
    06-02-09 05:56 PM
  2. Transfigured's Avatar
    U r on rite track already.

    Hope u get fix/new phone @ carrier.
    06-02-09 06:09 PM
  3. bigrob49er's Avatar
    It took me 15 min of calling Voicemail....and inserting and pulling a Qtip stick in an out...IT took some time.
    06-02-09 06:12 PM
  4. naderam77's Avatar
    I had the same problem and I inserted the headset jack halfway in and wiggled it around while placing a call to my voicemail. It took a couple of tries but it works just fine ever since.
    06-02-09 06:58 PM
  5. Detective M Downs's Avatar
    The simplest fix is *228 option 1.
    06-02-09 07:25 PM
  6. christopherj's Avatar
    The simplest fix is *228 option 1.
    Could you please explain what this is/what it does/why it works? It doesn't work at all for me but it seems to be carrier specific...

    Would be very nice to have a fix for this that doesn't involve carrying around my headset or a Qtip everywhere I go.
    06-02-09 07:39 PM
  7. choc's Avatar
    this did not work for me because i have that automatic screen lock on when you receive or dial out anyone know how to get that off?
    06-02-09 08:56 PM
  8. shell4's Avatar
    I also discovered this problem today after downloading the upgrade last night. Plugging my headphones in and out a bunch of times fixed it, but until I was able to get to my headphones I was able to hit the menu key during a call and choose activate handset to hear the call. It defaulted back to the headset mode when I hung up though so I had to do that for every call I received today.
    06-02-09 09:31 PM
  9. Transfigured's Avatar
    this did not work for me because i have that automatic screen lock on when you receive or dial out anyone know how to get that off?
    If u r referring 2 a 3rd party app:

    Options > advanced options > applications > highlight application > menu > delete + battery pull (w/device ON).
    06-02-09 10:01 PM
  10. Mountain's Avatar
    I had this problem with my podcasts.... wouldn't go to headphones.... plug in/out few times, now ok..... wtf?
    06-03-09 05:55 AM
LINK TO POST COPIED TO CLIPBOARD