09-04-09 11:20 AM
30 12
tools
  1. Taskbar's Avatar
    Hi guys,

    I have a problem with my Blackberry Storm and the call log. Incoming calls are being logged, but outgoing calls are not being logged.

    Now here is the troubleshooting steps I have taken:

    1. From the Storm main screen, I press the "SMS and MMS" icon
    2. I press the blackberry button
    3. I select "View Folder" link
    4. I select "Phone Call Logs" link

    Now after about 1.5-2.0 seconds, I get a popup that states:

    "Uncaught exception: java.lang.NullPointerException"

    w/the OK button

    5. I press the OK button, and the message goes away.


    Ok, with me so far?

    When I open the call logs the normal method, by:

    1. Press the green phone button on the Storm
    2. Press the call log icon
    3. It displays the calls but if I dialout on a number, it does not show the call.


    By the way, one other thing, I get the error message every time I boot up my telephone. This started on Thursday of last week. I have not installed any other software during this same time period and the "Call Log" was working fine ever since I received my Storm back in December.

    Any ideas???

    Thanks so much in advance.




    ====================
    UPDATE: I have resolved my issue.... for me it turns out that my call log database on the Storm was corrupted. I determined this by:

    1. Open main blackberry screen
    2. Select "SMS and MMS"
    3. Press the blackberry button
    4. Select "View Folder"
    5. Select "Phone Call Logs"
    6. Then it would give me the java exception error message

    I then did the following to resolve it for me:

    I connected Storm to desktop PC. I ran a backup of my Storm to the desktop computer using the Blackberry Desktop Manager sofware. Once the backup completed, I clicked on "Backup and Restore", then clicked on "Advanced" and over on the right-hand side of the screen, I scrolled down to locate "Call Log".... I selected that, and then pressed the "Clear" button at the bottom. I then went to the steps I listed above in this post, and no more Null error message. And now my call logs are back working, woohoo!!!

    Taskbar
    ====================
    Last edited by Taskbar; 02-17-09 at 09:42 PM. Reason: I finally resloved this issue!!!
    02-16-09 10:18 PM
  2. pkcable's Avatar
    Not sure if this will fix it but try some memory cleaning. Open browser press bb button select options then cache operations then clear them all. Then from the homescreen options then security options then memory cleaning enable it then press bb then clean now. Press bb from the homescreen and show keyboard, then hold !?123 to lock it type "/"/ to open the java log then press bb and select clear log. Finally do a battery pull.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-16-09 10:43 PM
  3. errtex's Avatar
    Exact same problem (there's actually another thread on the same subject I'm following)...
    Anyway.. tried the suggest listed above to no avail... still have the Uncaught Exception. I'm open and watching for all advice, but it's looking like a wipe and reload of the OS may be in order. Originally I thought this was because I altered the phone to work for T-mobile, but I see Taskbar isn't the only Verizon user having the same problem.... hmmm...

    I get another error message occasionally that looks something like "8 <= 8"..... kinda weird. I'll have to write it down next time it pops up.
    02-16-09 11:03 PM
  4. kokuryuha's Avatar
    Yea I would suggest an OS reload via apploader. Remember to backup and such beforehand. what kind of 3rd party apps do you have installed?
    02-16-09 11:34 PM
  5. errtex's Avatar
    Nothing now, I've deleted them all.... There's another thread called "uncaught exception" on the same thing and seems quite a few ppl are having this trouble now.

    The only 3rd party apps I really had were the basics.... facebook, myspace, weatherbug, viigo, CRACKBERRY launch, and youtube.... I also had a launch for fox news and espn. I've deleted them all, cleared the event log, cpl of battery pulls and still get the uncaught exception....
    02-16-09 11:57 PM
  6. kokuryuha's Avatar
    Hmm yea, that's odd. I'll take a look over at that thread too, but I'd probably start off with a back up and an OS reload. Which OS are you running?
    02-16-09 11:59 PM
  7. errtex's Avatar
    .75....................
    02-17-09 12:13 AM
  8. errtex's Avatar
    I'm on the road now and gotta get to bed... tomorrow's start is only 4 1/2 hours away, but I'll keep a watch on the thread, log in and respond when I have a chance and, if need be, try reloading the OS when I get home... thank God I saved the service books and OS to a flash card.... lol
    02-17-09 12:17 AM
  9. kokuryuha's Avatar
    I found another post where someone restored an older backup to their phone and this problem went away. do you have a backup you could try this with?
    02-17-09 12:20 AM
  10. Taskbar's Avatar
    Not sure if this will fix it but try some memory cleaning. Open browser press bb button select options then cache operations then clear them all. Then from the homescreen options then security options then memory cleaning enable it then press bb then clean now. Press bb from the homescreen and show keyboard, then hold !?123 to lock it type "/"/ to open the java log then press bb and select clear log. Finally do a battery pull.

    Posted from my CrackBerry at wapforums.crackberry.com
    Hi pkcable,

    I just tried the things you posted, but that didn't clear the problem. I appreciate your post here though and I added "keep fingers crossed" at the step right after the battery pull. But alas, no go.... heh...

    Thanks again though ;-)
    02-17-09 05:42 AM
  11. Taskbar's Avatar
    Yea I would suggest an OS reload via apploader. Remember to backup and such beforehand. what kind of 3rd party apps do you have installed?
    I have the following installed:

    Weatherbug 0.1.0.274
    YouTube
    AP Mobile
    vlingo
    BerryTunes
    VyMail
    Aerize Alerts
    Google Sync
    FlyCast
    File Manager Pro
    Blip from Blackline GPS
    SoftReset
    BOLT
    RepliGo Reader
    02-17-09 05:46 AM
  12. Taskbar's Avatar
    .75....................
    Like errtex I am running .75 OS as well.
    02-17-09 05:47 AM
  13. Taskbar's Avatar
    I have resolved my issue.... for me it turns out that my call log database on the Storm was corrupted. I determined this by:

    1. Open main blackberry screen
    2. Select "SMS and MMS"
    3. Press the blackberry button
    4. Select "View Folder"
    5. Select "Phone Call Logs"
    6. Then it would give me the java exception error message

    I then did the following to resolve it for me:

    I connected Storm to desktop PC. I ran a backup of my Storm to the desktop computer using the Blackberry Desktop Manager sofware. Once the backup completed, I clicked on "Backup and Restore", then clicked on "Advanced" and over on the right-hand side of the screen, I scrolled down to locate "Call Log".... I selected that, and then pressed the "Clear" button at the bottom. I then went to the steps I listed above in this post, and no more Null error message. And now my call logs are back working, woohoo!!!

    Taskbar
    02-17-09 09:40 PM
  14. kokuryuha's Avatar
    That would make sense then if someone was able to restore an older back up to their Storm and that fixing it. Probably before the call log got corrupted.
    02-17-09 10:08 PM
  15. errtex's Avatar
    I have resolved my issue.... for me it turns out that my call log database on the Storm was corrupted. I determined this by:

    1. Open main blackberry screen
    2. Select "SMS and MMS"
    3. Press the blackberry button
    4. Select "View Folder"
    5. Select "Phone Call Logs"
    6. Then it would give me the java exception error message

    I then did the following to resolve it for me:

    I connected Storm to desktop PC. I ran a backup of my Storm to the desktop computer using the Blackberry Desktop Manager sofware. Once the backup completed, I clicked on "Backup and Restore", then clicked on "Advanced" and over on the right-hand side of the screen, I scrolled down to locate "Call Log".... I selected that, and then pressed the "Clear" button at the bottom. I then went to the steps I listed above in this post, and no more Null error message. And now my call logs are back working, woohoo!!!

    Taskbar
    DUDE! I'm so glad you posted this! I did the exact same thing and have been meaning to post it before anyone tried to wipe and reset their OS, but I've just been to dang busy to log in and do it! Yeah, I had a count of 678 in the call log... maybe the corruption was due to an overload [of sorts].... from now on I'll be sure to clear my call log more frequently!
    02-20-09 02:00 PM
  16. Taskbar's Avatar
    DUDE! I'm so glad you posted this! I did the exact same thing and have been meaning to post it before anyone tried to wipe and reset their OS, but I've just been to dang busy to log in and do it! Yeah, I had a count of 678 in the call log... maybe the corruption was due to an overload [of sorts].... from now on I'll be sure to clear my call log more frequently!
    Yup mine was pretty big too- but not nearly your size though. I had about 600 in my call log. And like you say, perhaps that lead to an overload. Now I will be sure to keep mine around 500 (if needed), but I'm so glad I didn't have to do a wipe though... hehehe....
    02-21-09 09:14 AM
  17. PavementPilot's Avatar
    I then did the following to resolve it for me:

    I connected Storm to desktop PC. I ran a backup of my Storm to the desktop computer using the Blackberry Desktop Manager sofware. Once the backup completed, I clicked on "Backup and Restore", then clicked on "Advanced" and over on the right-hand side of the screen, I scrolled down to locate "Call Log".... I selected that, and then pressed the "Clear" button at the bottom. I then went to the steps I listed above in this post, and no more Null error message.
    Worked for me too to clear the nullpointer trying to access my messages. Thanks.
    02-21-09 11:12 AM
  18. Taskbar's Avatar
    Worked for me too to clear the nullpointer trying to access my messages. Thanks.
    Thanks, glad to be able to give back ;-)
    02-21-09 12:43 PM
  19. storm1973's Avatar
    I've got this message everytime I turn on my Storm or if I do a battery pull. Does anyone knows what is about? or how to get rid of this message? Please I need your help guys, thanks.
    02-22-09 12:04 PM
  20. AirborneBerry's Avatar
    I've been getting this error ever since i installed .103, i just it was just a bug in that version. I'm glad someone found a way to fix it, now i just have to find time to fix it.
    02-22-09 12:20 PM
  21. Taskbar's Avatar
    I've got this message everytime I turn on my Storm or if I do a battery pull. Does anyone knows what is about? or how to get rid of this message? Please I need your help guys, thanks.
    If I were you, I would have a look at the very first post that I made, and check each and everyone of your folders that are in the folder list view. If any of them error out like mine did (but mine was with the call log), i would attach blackberry to computer and delete that particular log database in question.

    Let us know how it turns out.
    02-25-09 07:13 PM
  22. Taskbar's Avatar
    I've been getting this error ever since i installed .103, i just it was just a bug in that version. I'm glad someone found a way to fix it, now i just have to find time to fix it.
    So did you get a chance to fix it yet mikeavngence??
    02-25-09 07:17 PM
  23. a_spud's Avatar
    I've recently purchased the Curve 8320 and seem to be getting an uncaught exception: java.lang.classCastException error. I've tried taking out the battery but that doesn't fix it and it doesn't matter what I'm doing with the device to make that error pop up...I take it out of the case and bam, there it is!

    Any ideas on how to get rid of the error?
    03-05-09 01:45 PM
  24. Taskbar's Avatar
    I've recently purchased the Curve 8320 and seem to be getting an uncaught exception: java.lang.classCastException error. I've tried taking out the battery but that doesn't fix it and it doesn't matter what I'm doing with the device to make that error pop up...I take it out of the case and bam, there it is!

    Any ideas on how to get rid of the error?
    Hey there a_spud,

    Go back to my post #1 of this thread, and go through each of your folders to see which one pops up errors. Which ever one pops up the error message, I would then clear it using the software with the blackberry connected to the computer like I indicated I had did.

    I'm not an expert on it, but it worked for me ;-)
    03-08-09 11:36 AM
  25. jencwlo's Avatar
    any suggestions for this error not related to the call log? i have not had this problem in the past - but am roaming now and suddenly the phone has gone crazy. my phone basically doesnt work, constantly freezes...and when i can get the blank screen off, i get the error (and missing icons).
    03-22-09 04:51 AM
30 12
LINK TO POST COPIED TO CLIPBOARD