1. ehutt14's Avatar
    my blackberry storm is on (the buttons are lit up at the bottom, it vibrates, and the red light is flashing), but my screen isn't showing anything. does anyone know what happened or how i could fix it?
    03-03-09 06:37 PM
  2. ArmaK's Avatar
    Do a battery pull, the device might have just froze.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-03-09 07:05 PM
  3. ehutt14's Avatar
    i tried that, and i plugged it into the charger.
    any other ideas?
    03-03-09 07:07 PM
  4. Squeegee's Avatar
    Try a backup, maybe? See if the Desktop Manager discovers the phone then do a restore. Don't know if that'll work but it can't hurt

    Posted from my CrackBerry at wapforums.crackberry.com
    03-03-09 07:54 PM
  5. falesq's Avatar
    my blackberry storm is on (the buttons are lit up at the bottom, it vibrates, and the red light is flashing), but my screen isn't showing anything. does anyone know what happened or how i could fix it?
    Did you load any apps, themes, etc. recently? If a battery pull doesn't help you might want to re-load the OS. If none of the above solves the problem then visit your friendly neighborhood verizon store and let the techs have a look... likely a hardware issue.
    03-03-09 08:27 PM
  6. DoctorNeutron's Avatar
    Or, possibly even easier, give VZN a call - they will help you.

    Doctor Neutron
    03-03-09 08:39 PM
  7. davisdog2012's Avatar
    I have the exact same problem. I've tried a million battery pulls it only works the first time it comes back on and then as soon as it blacks out it won't work. Did you end up fixing yours?
    03-03-09 09:10 PM
  8. Grovesfan's Avatar
    Do you have WeatherBug or TwitterBerry installed? If so, you'll get the flashing red LED whenever there's a severe weather alert in any area you're watching or if there's a new Twitter from anyone you follow.
    03-03-09 09:24 PM
  9. ehutt14's Avatar
    i'm trying to restore it now, and it doesn't seem to be working.
    i think i've given up fixing it.
    i'll probably just take it in.
    03-03-09 09:36 PM
  10. ehutt14's Avatar
    how would you re-load the OS?
    03-03-09 09:37 PM
  11. davisdog2012's Avatar
    Me too. I hard rebooted too, still the same problems. Let me know if you figure anything out and i'll do the same for you.
    03-03-09 10:10 PM
LINK TO POST COPIED TO CLIPBOARD