1. dfx987's Avatar
    Ok, I really need help. I bought a brand new digitizer and replacement screen and my phone still doesn't work. The phone came back on after we replaced the screen, but the screen doesn't sit correctly and won't make contact with either the touch screen or the push part of the screen, there is a bulge on the bottom of the screen and it looks like there is a gap on the top of the screen.

    Before you comment, please read the following. There is NO YouTube video or seemingly video anywhere period of a screen removal for the Storm 2, just the Storm 1. Furthermore, even with the instructions for the 1, they are not the same....and nobody shows you how to do the actual replacement, just to take it out, so every video seems to lie.

    Finally, I found a video on the dismantling of a Storm 2, but when they get to the screen they stop and don't touch that area. I need help badly, how does the screen sit correctly, what is the proper way to put the screen back on after removal?

    And my dad, who is the one who worked on the phone...said there is some black rim glue on the original screen that does not seem to come with the replacement....that's all I know, PLEASE...I NEED HELP!
    04-02-10 02:50 PM
  2. wraenking's Avatar
    i just did this last night. Right now my phone is not is the case. When i got the case back on i had the same problem. Need to redo tonight.

    Get some goo off from home depot or somewhere to remove all the glue/sticky tape. I used double sided tape that was too thick. So my digitizer does not sit right. When i romove the case/frame, it works fine. I got some thinner double sided tape, but now i am thinking of even using a thin bead of silicone to attach the digitizer. Let me know how you make out
    04-02-10 04:19 PM
  3. dfx987's Avatar
    I found a site, and cut a deal with them to send the phone there, 30 bucks. I paid 30 USD for the screen, repair is 30 USD. 60 USD total, I am making out pretty well, imo...
    04-04-10 12:15 AM
  4. HWBruce's Avatar
    what was the site for the repair?
    04-16-10 08:09 PM
LINK TO POST COPIED TO CLIPBOARD