1. sriyegna's Avatar
    Well, ive had my storm 2 for some time now with no troubles until now ... I recently cut off my Data package (from fido) and now my phone browser doesnt even seem to open :S. When i press it... it just clicks, but it wont open or do anything. Every other app works, including Opera (which is what i have to use now for browsing)

    Is there any way to fix this? Im using a storm 2 9550 (unlocked) from Verizon running on the Fido network...

    Im considering upgrading to an unofficial OS hoping it would fix the prob... LMK please

    btw... before i added the data pack, the storm2 would load the browser and work with wifi :S , now even though it finds wifi, it wont load the BB browser
    05-01-10 11:52 PM
  2. Jake Storm's Avatar
    Go to
    Manage Connections > Mobile Network Options
    and make sure Data Services is on.
    Even if you are just using wifi and no data plan, Data Services still needs to be on.
    05-02-10 01:33 AM
  3. Jake Storm's Avatar
    You can also try
    Options > Advanced Options > Browser
    Make sure your Default browser configuration is set to Hotspot Browser
    05-02-10 01:36 AM
  4. 312's Avatar
    It's because you no longer have BIS. No BIS, no service books. No service books, no browser.
    05-02-10 04:08 AM
  5. sriyegna's Avatar
    Oh kay, so mobile network is on, and it is set to hotspot browser. Ive already tried those and still it wont work. Idk what you mean by BIS, could you please elaborate?

    And it was working before when i didnt have a data plan :S
    05-02-10 08:58 AM
  6. NurseBerryAddict's Avatar
    BIS = Blackberry Internet Service. I would say you're stuck using Opera. It should work with mobile network on and set to hotspot browser as far as I know.
    05-02-10 09:10 AM
  7. D2TSHR1439's Avatar
    Right, when you have a plan for a BB, its either BIS or BES. BB Internet Service or BB Enterprise Service. If you dint have that, you no longer have a service book supporting your internet. The reason your apps work is because they only need a connection (like WiFi) not a service book to operate.
    05-02-10 09:13 AM
  8. sriyegna's Avatar
    But shouldnt the browser be able to operate via hotspot? (wifi). Ive used it before :S Would a total firmware reset (or upgrade, w.e) fix the problem?

    bcz b4 i had the data plan, it would work with wifi :S
    05-02-10 11:36 AM
  9. z06mike's Avatar
    But shouldnt the browser be able to operate via hotspot? (wifi). Ive used it before :S Would a total firmware reset (or upgrade, w.e) fix the problem?

    bcz b4 i had the data plan, it would work with wifi :S
    Yes, it would work with wifi because you had the service books for the browser!

    No data plan = no service book = no BB browser period!
    05-02-10 11:46 AM
  10. Jake Storm's Avatar
    But shouldnt the browser be able to operate via hotspot? (wifi). Ive used it before :S Would a total firmware reset (or upgrade, w.e) fix the problem?

    bcz b4 i had the data plan, it would work with wifi :S
    Yes you can surf the net with the BB hotspot browser using wifi without a data plan. I am doing it right now!!!!

    I'm not sure what these other guys are talking about

    You will not be able to use BB messenger or other BES/BIS services without the data plan.
    05-02-10 03:37 PM
  11. Jake Storm's Avatar
    Oh, and you won't be able to use Appworld either.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-02-10 06:31 PM
  12. Fnord's Avatar
    Yes you can surf the net with the BB hotspot browser using wifi without a data plan. I am doing it right now!!!!

    I'm not sure what these other guys are talking about

    You will not be able to use BB messenger or other BES/BIS services without the data plan.
    What they're saying is that while you can access the web on the BB browser over WIFI, without a BIS or BES data plan the device won't receive the necessary service books needed to run the browser itself. Without those service books you will not be able to launch the browser.

    It works for you because you have a BB plan, so service books are not an issue.
    05-02-10 07:14 PM
  13. Jake Storm's Avatar
    What they're saying is that while you can access the web on the BB browser over WIFI, without a BIS or BES data plan the device won't receive the necessary service books needed to run the browser itself. Without those service books you will not be able to launch the browser.

    It works for you because you have a BB plan, so service books are not an issue.
    On the contrary. That's what I'm saying: I DON'T HAVE A BB PLAN
    But I can launch the Hotspot browser and surf the web over wifi. in fact I am typing this reply on my Storm2. Go figure.
    05-02-10 07:19 PM
  14. Jake Storm's Avatar
    I think there are different service books for Hotspot browser and BIS browser.
    05-02-10 07:22 PM
  15. Fnord's Avatar
    On the contrary. That's what I'm saying: I DON'T HAVE A BB PLAN
    But I can launch the Hotspot browser and surf the web over wifi. in fact I am typing this reply on my Storm2. Go figure.
    Sorry, hadn't gotten that...

    Maybe Rogers and FIDO don't have the same books...?

    I only say because I've had the exact same issue the OP is asking about, but re-sending book always took care of it.
    05-02-10 07:25 PM
  16. Jake Storm's Avatar
    My phone was originally a Verizon branded phone.
    Desktop Manager automatically updated me to .607 so maybe it still recognizes it as a Verizon phone?
    If I got to Advanced Options > Browser
    it only gives me the Hotspot Browser option, so it does recognize that I'm not subscribed to BIS/BES.

    Funny thing. When I purchased the phone, it was supposedly a "new" open box return, because the seller said the customer was having trouble with the browser. Updating the OS seemed to take care of that problem. But again, maybe it was because it was an official Verizon update. (when I turn my phone on after a battery pull it still shows the Verizon logo on the screen)

    FYI if anyone is curious... the reason I don't have a data plan is because I just pulled the SIM card from my crappy (won't go into what brand) work phone and put it in a Storm2 I got off ebay for a great price. My employer doesn't want to pay for a data plan, but there are lots of free wifi spots near where I work/live. I have (well, the wife uses it now) an iphone with an unlimited data plan. The iphone grabs wifi when available, so it sees very little data usage anyway.
    05-02-10 08:16 PM
  17. Mr. Orange 645's Avatar
    Jake if I'm not mistaken AT&T's system will automatically detect that you are running a BB and they will eventually just add the data package to your plan.

    I'm assuming you have AT&T because you said your wife has an iPhone.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-03-10 08:12 AM
  18. sriyegna's Avatar
    Thanks for all your replies! although i still havent found the answer to my problem.... Il give you all the info i can about my problem and my phone...

    I got it off ebay, (unlocked) and originally branded by Verizon.
    Im running it on a gsm network with FIDO (owned by rogers)
    When i first got it, i did not have a data plan, and could not use apps such as facebook, or app world but i could use the browser through wifi.

    I got the dataplan for 2 months, and everything worked perfectly, i could use wifi, and data and all the apps ran perfectly.

    Now my mother decided to take it off befcause it was too costly, so im back to square one. An unlocked phone with wifi and no data plan.

    But now the problem is, i cant open the blackberry browser :S, i can however use app world :S (but no facebook apps or stuff like tht) through wifi.

    SO, since it seemed to work fine before it got the service books through fido, should i like clear all the files and install the firmware again? (if possible)

    a little more info, my first plan contained

    250 minutes, free eve and weekends, 250 txts

    once i had the data plan, i had 250 minutes, free eve and weekends, 250 txts, 500 mb of BLACKBERRY browsing

    now that i took off the data plan, i have 250 minutes, free eve and weekends, 2500 txt (yea, the extra 0 is meant to be there).

    SOOOO, does this have any factor in whats going on? :P
    05-03-10 12:42 PM
  19. the2ndstorm's Avatar
    Hi I'm on an unlocked verizon storm2 and I'm from the Philippines. I just activated BIS on a Philippine carrier. Everythings running fine its just that the option for browswr configuration to set default browser to hotspot browser is gone missing. I'm just afraid I may not be able to browse via wifo could anyone help me please? Hotspot browser missing. Thanks in advance!
    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    05-03-10 09:36 PM
  20. Jake Storm's Avatar
    Jake if I'm not mistaken AT&T's system will automatically detect that you are running a BB and they will eventually just add the data package to your plan.

    I'm assuming you have AT&T because you said your wife has an iPhone.

    Posted from my CrackBerry at wapforums.crackberry.com
    Nope, the iphone and my Storm are both on Rogers.
    05-03-10 11:35 PM
LINK TO POST COPIED TO CLIPBOARD