1. mnmrmc's Avatar
    I'm running .103 on my storm and have been since it was leaked. Earlier today I downloaded a few games from StormOTA and it ran fine for a couple hours then froze. I did a battery pull and it worked for around another hour. After a pull, everything would be fine until the screen faded out. Once it did fade out, the screen and buttons will light up if you hit a button, but will display nothing. At this point, after a pull it wont even completely start up, just the blank screen. Is my storm bricked? Or what is going on?
    03-25-09 05:25 PM
  2. BostonDan's Avatar
    You might have to do a wipe / reinstall.....

    I hope you backed up your data/apps....

    Good luck.
    03-25-09 05:39 PM
  3. TheTruth8's Avatar
    what games did you d/l ?
    03-25-09 05:50 PM
  4. Olazy1's Avatar
    That just happened to me after I downloaded GoodFoodNearYou. It was working fine for a couple of hours and then all of a sudden the screen started to delay and then completely blanked out. I can see the light behind the screen and behind the buttons on the bottom but the display itself is black. I just did a complete wipe and installed .113. Still no luck. Im gonna do another wipe without any 3rd party apps. Hopefully it works.
    03-25-09 11:02 PM
  5. Olazy1's Avatar
    Suckie.. I went back to .75 and still no luck.

    Theres another thread on this topic but no fix except to replace the equipment.
    03-26-09 12:19 AM
  6. IrishBrit's Avatar
    I experienced this too while beta testing some software for someone, but it only happened if my screen faded (went to sleep) and then i got a message of any kind (SMS, MMS, Email, BBM, etc.). Had to resort to a batt pull each time, finally i removed the software and reinstalled and it has been fine ever since. I just chocked it up to a botched install, but not sure.
    03-26-09 01:21 AM
  7. magungo's Avatar
    Yeah, this happened to my friend's storm as well. I mean the thing just still has problems. The last time I used it, the screen was locked but I could never select the lock icon. It was the most annoying thing ever. Hopefully new firmwares do come out soon to iron out all these little quirks. I doubt it has anything to do with 3rd party apps you get. Is that phone still under warranty for verizon? Can they tell that you loaded a leaked firmware onto it?
    03-26-09 02:30 PM
LINK TO POST COPIED TO CLIPBOARD