1. ratfinkstooley's Avatar
    Just curious as to some advice on what to do when your Storm 9550's screen starts having click issues with the bottom buttons and you bought this phone off Ebay.

    Take it to a Verizon store and let them see the problem?

    Call into a Verizon tech support and tell them the problem?

    Try and deal with the seller from Ebay and see if I can get a replacement? (long shot in my book)

    Any advice would be appreciated! Thanks in advance!
    05-26-10 12:04 PM
  2. hydroz_23's Avatar
    Just curious as to some advice on what to do when your Storm 9550's screen starts having click issues with the bottom buttons and you bought this phone off Ebay.

    Take it to a Verizon store and let them see the problem?

    Call into a Verizon tech support and tell them the problem?

    Try and deal with the seller from Ebay and see if I can get a replacement? (long shot in my book)

    Any advice would be appreciated! Thanks in advance!
    Try and deal with the seller from Ebay and see if I can get a replacement? (long shot in my book)
    05-26-10 12:14 PM
  3. pcgizmo#IM's Avatar
    I think hydroz is right. I don't think you have any warranty rights on a used device.
    05-26-10 12:17 PM
  4. young519's Avatar
    Your most likely going to have to buy an other one

    Posted from my CrackBerry at wapforums.crackberry.com
    05-26-10 01:47 PM
  5. greydarrah's Avatar
    Why don't you try adjusting the 2 torx screws under the battery door? That fixed my bottom button issues perfectly and permanently.
    05-26-10 02:57 PM
  6. ratfinkstooley's Avatar
    Why don't you try adjusting the 2 torx screws under the battery door? That fixed my bottom button issues perfectly and permanently.
    really? I wasn't aware of this as a solution. How much do I turn them?
    05-26-10 04:42 PM
  7. Masahiro's Avatar
    Did you update the OS?

    Posted from my CrackBerry at wapforums.crackberry.com
    05-26-10 06:02 PM
  8. ratfinkstooley's Avatar
    yeah actually i took grey's advice and just turned the one screw underneath the battery a little bit and it seems to have solved the problem. I hope there's no danger in doing this. Thanks Grey!
    05-26-10 06:07 PM
LINK TO POST COPIED TO CLIPBOARD