1. theboyk's Avatar
    Hello.

    I just received a BB Storm via Telus in Canada. I'm trying to set up my gmail account (x2 one regular and one google apps) via IMAP. I tried following instructions here...

    hxxp://mail.google.com/support/bin/answer.py?answer=78882&topic=12920

    ...I get past the part where I enter my username@gmail.com (or username@domain.com for google apps version) but then can't get past the part where I'm to NOT enter a password. I just go into a loop where the BB continues to say "you must enter a password" I continued through this loop about 10 times hoping eventually it would crap out and let me do what I need to do to continue with the instructions, but no go.

    So, I can't select "I will provide the settings to add this email account"?

    So, wondering if anyone could lend some advice on what I need to do to get gmail IMAP working?

    Thanks!
    Kristin.
    01-14-09 11:40 AM
  2. slick0ne's Avatar
    Just go to telus.blackberry.com web site from a PC and set up your BIS account , you'll be able to create a Telus blackberry email or add any other email account such as Gmail, Hotmail ...
    01-14-09 12:05 PM
  3. theboyk's Avatar
    Just go to telus.blackberry.com web site from a PC and set up your BIS account , you'll be able to create a Telus blackberry email or add any other email account such as Gmail, Hotmail ...
    And this works fine/sets everything up for IMAP (so I can access all the folders, etc. on my BB as I can via the web or desktop client)?

    I thought there was something special that needed to be done to setup for IMAP?

    k.
    01-14-09 12:23 PM
  4. bribears's Avatar
    When setting up the email on the BB do NOT choose "Gmail" choose "other". Then put in a fake email address but the correct Gmail password (how I did it but it shouldn't matter if it wrong). After a couple failures it gives you the option for "entering in the info yourself" and you can follow the directions you found. the key for me was having a bad email address in the first place and choosing other.
    01-14-09 03:01 PM
  5. theboyk's Avatar
    When setting up the email on the BB do NOT choose "Gmail" choose "other". Then put in a fake email address but the correct Gmail password (how I did it but it shouldn't matter if it wrong). After a couple failures it gives you the option for "entering in the info yourself" and you can follow the directions you found. the key for me was having a bad email address in the first place and choosing other.
    Nope, I still get stuck in a loop of "Processing..." and then "Unable to set up xxx@gmail.com. Please try again." over and over. I've tried about 15 times in a row now. Geez, I'm testing the Storm again iPhone and I can't believe it's this difficult/impossible to get IMAP working. All I need it to do is let me access my gmail account via IMAP. How hard is that?
    01-14-09 03:11 PM
  6. bribears's Avatar
    Be SURE you chose OTHER. Also, try an email address that is not @gmail....like @gail. I recall the same behavior when I used other and @gmail but it worked after a couple tried when I did not use @gmail.
    01-14-09 03:16 PM
  7. theboyk's Avatar
    Be SURE you chose OTHER. Also, try an email address that is not @gmail....like @gail. I recall the same behavior when I used other and @gmail but it worked after a couple tried when I did not use @gmail.
    FINALLY!
    That worked.
    THANKS!!!

    Ok, so now that I have it set up should I now be able to see my gmail folders? When I "view folders" on the Storm, I don't see any of the folders I see when logged in via the gmail web interface?
    01-14-09 03:38 PM
  8. bribears's Avatar
    No. It is not TRUE IMAP. I could never find an app that supports TRUE IMAP for the Storm (Logicmail sounds nice but it does not work on the storm).

    None of my email accounts appear to be true IMAP but Gmail is definitely the worst one. If I read or delete an email on Gmail.com it does not replicate down to the Storm. People will tell you it will, that it works with varying success and sometimes you have to wait hours for it to update. Well yesterday morning I sent a test email and opened it on Gmail.com. I left it unread on my BB. This morning it was still there!

    I have configured the BB account for Gmail multiple times and deleted them, and tried again, and spent two weeks playing around. If I read\delete on Gmail.com it does not replicate down to the BB. It works great the other way around!

    Ultimately I have the Gmail mobile application on my phone. The app is great except it does not get the Blackberry "push" of new mail. Rather it checks on Gmail for new mail every once in a while (rumored every 20 minutes). Also HTML links in the emails do not work.

    So, I now have the BB email configured for Gmail and get an automatic push. I go to Gmail.com less, MUCH less. If I get an email that I wish to archive or label I open the Gmail mobile app and do so. then I go back to my BB gmail email and delete the email....FROM THE HANDHELD ONLY.

    It's a little more work but it's as close to "TRUE IMAP" and "using the great features of Gmail" that I could get.

    I welcome any and all ideas.

    MY other email accounts work fine BUT on 6 of them I never check them on the web and do not have any email client on any computer to check them. So technically they are not TRUE IMAP either but I notice it less than Gmail (my primary account).

    The last one is configured with OUTLOOK WEB ACCESS and it is really close to IMAP, though it also does not read\delete emails on the Storm if I get them elsewhere.
    01-14-09 03:58 PM
  9. theboyk's Avatar
    Perfect — exactly what I was looking for!
    I like your solution of BB account for Gmail + Google Mobile app.
    Thanks again!
    Kristin.
    01-14-09 04:23 PM
LINK TO POST COPIED TO CLIPBOARD