1. CrackBerry_uk1's Avatar
    Hello all,

    Got my 9500 unlocked from vodafone today and it now accepts my o2 sim card. Great.

    I can see that the data Network access is still currently registered to the previous owner.. sweet - but wait, I want my own data provider on it for my emails.

    so I called Vodafone, explained that I need that data service removing for the IMEI I gave them. - they said they can't remove it as the BB9500 is locked to vodafone only??

    Surely the data services aren't locked to a specific provider?

    Answers on a small postcard please.

    D
    05-13-09 05:40 AM
  2. sanki's Avatar
    You probably need the new Service Books from your new provider. I don't think Vodafone can lock data services.
    05-13-09 06:22 AM
  3. Hazysky's Avatar
    Did this phone come direct from vodafone or was it purchased elsewhere? Is it new or used?

    Also do you have an o2 Blackberry Bolt package added to your sim?

    Posted from my CrackBerry at wapforums.crackberry.com
    05-13-09 06:22 AM
  4. CrackBerry_uk1's Avatar
    Phone was my brothers - they sent him it as an upgrade. Its never been used, he only received it 3 days ago.

    Thats when I got it, (still sealed).

    Right away I got an unlock code of the t'interweb and stuck my card in. tried to register my providers service book (o2) but it says "this IMEI is already registered with another provider."

    thats when I called vodafone to release it. They say they can't.

    yep. already have data services with o2 - using it on my Pearl, just trying to upgrade my handset.
    Last edited by CrackBerry_uk1; 05-13-09 at 06:32 AM.
    05-13-09 06:27 AM
  5. Hazysky's Avatar
    You should be able to go into your current o2 Bis login page and select change device (BlackBerry Internet Service). It should recognise the PIN and imei automatically but if it doesn't manually input them.

    Failing that if the device is not actovated go to options > advanced options > host routing table > menu > register now. You should get a registration message and a browser. Look for your set up folder and in there you will find an email settings icon, set up from there.

    Let us know if that worrks.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-13-09 06:46 AM
  6. CrackBerry_uk1's Avatar
    Thank you very much Hazysky
    It worked perfectly.

    All registered and working as I'd exect it to
    05-13-09 07:03 AM
  7. Hazysky's Avatar
    Excellent!

    Enjoy your storm

    Posted from my CrackBerry at wapforums.crackberry.com
    05-13-09 07:05 AM
LINK TO POST COPIED TO CLIPBOARD