1. blueskyjunkie's Avatar
    I'll start off by saying how much I hate the 2 piece wall charger that comes with the Storm. I understand that it's probably convenient for people who leave the country often; however, I tend to stick around the States for the most part. I live in an older house with some tight sockets, and I've accidentally separated the cord from the piece with the prongs multiple times. This past weekend, I was at a skydiving boogie several hours from my house, and I left the piece with the prongs in the wall at the drop zone. Not thinking much of it, I just used my Xbox to charge my phone via the micro USB cord. The only electrical engineering knowledge I have is from AP Physics in high school, and I didn't even think to check the voltage or anything like that. When I woke up, my screen was black, and I get no response out of it. I just plugged it into my computer and the screen is still black, but the red LED came on. Still not responsive. Any ideas?
    05-20-09 05:09 PM
  2. blueskyjunkie's Avatar
    Come on I know there are some electrical engineers out there.
    05-20-09 05:52 PM
  3. Morf32's Avatar
    I am going to suggest two things... first, pull the battery. Second, let it charge on the wall charger for an hour or so, and see if that makes a difference.
    05-20-09 05:57 PM
  4. blueskyjunkie's Avatar
    I am going to suggest two things... first, pull the battery. Second, let it charge on the wall charger for an hour or so, and see if that makes a difference.
    Hey Morf . I've been absent from the forums for a while, but it's good to see ya again. I've already tried pulling the batter like a gazillion and a half times, and I can't charge it with the wall charger until I go to Verizon and pick up a new piece with prongs (that's the part that's stuck in the wall 3 hours away) .
    05-20-09 05:59 PM
  5. blueskyjunkie's Avatar
    Oh I also wanted to let you know that the video playback issue is present on .141. I recorded an AWESOME swoop video this weekend that it won't play. I just remember we were discussing it a while back so I wanted to let ya know.
    05-20-09 06:01 PM
  6. Morf32's Avatar
    As far as the wall charger goes, there was a girl having the same "blank screen" issue just recently, and it corrected itself after charging it for a bit with an OEM wall charger.

    Sorry to hear that you can't play back that video. That stinks.

    Nice to see you, too!
    05-20-09 06:03 PM
  7. blueskyjunkie's Avatar
    As far as the wall charger goes, there was a girl having the same "blank screen" issue just recently, and it corrected itself after charging it for a bit with an OEM wall charger.

    Sorry to hear that you can't play back that video. That stinks.

    Nice to see you, too!
    Alrighty well I guess I'll just have to wait another day to go pick up a new charger. After all, how hard could it possibly be to go a day without a phone.. text messaging.. Google maps.. a lightsaber.. a fart machine.. and music?

    Do you by any chance remember the title of the thread where they were discussing it? Maybe I can find some more useful information regarding what I did wrong or what not to do in the future. I've searched several related phrases and didn't find anything relevant.

    EDIT: Nvm I think I just found it (or at least something that sounds similar to my problem) .
    05-20-09 06:14 PM
  8. blueskyjunkie's Avatar
    Got it working finally. Plugged it into a different computer and let it sit for 10 minutes or so. A white screen with a charging symbol in the middle finally showed up. I let that sit for another 10 minutes or so, did a battery pull, put the battery back in, and it booted up just fine.
    05-20-09 07:19 PM
  9. Morf32's Avatar
    Got it working finally. Plugged it into a different computer and let it sit for 10 minutes or so. A white screen with a charging symbol in the middle finally showed up. I let that sit for another 10 minutes or so, did a battery pull, put the battery back in, and it booted up just fine.
    Good to know! Glad you got it working again!
    05-20-09 07:26 PM
  10. blueskyjunkie's Avatar
    Good to know! Glad you got it working again!
    Thanks . Oh and as far as the video playback issues I read a thread and someone brought up a solution involving turning a "media encryption" option off but neglected to inform anyone as to where the option is. Any ideas?
    05-20-09 07:29 PM
  11. Morf32's Avatar
    Thanks . Oh and as far as the video playback issues I read a thread and someone brought up a solution involving turning a "media encryption" option off but neglected to inform anyone as to where the option is. Any ideas?
    I think. I want to say it's the one under Options > Memory > Encryption Mode. Try setting it to None if it isn't already. I think that's the one.
    05-20-09 07:38 PM
  12. chuckh0308's Avatar
    In the Crackberry store you can get an OEM wall charger that has the fold up prongs, but not detachable for about $10. I switched to that one for my bedside charger so that I can save the multi-adapter for travel. Might check it out and see if it would be better suited to your needs!

    Glad everything is back in order for you too!
    05-20-09 07:40 PM
  13. blueskyjunkie's Avatar
    In the Crackberry store you can get an OEM wall charger that has the fold up prongs, but not detachable for about $10. I switched to that one for my bedside charger so that I can save the multi-adapter for travel. Might check it out and see if it would be better suited to your needs!

    Glad everything is back in order for you too!
    Thanks man I didn't know that! I'll probably end up buying that, but you don't happen to know if they sell the prong adaptors by themselves do you?
    05-20-09 07:42 PM
  14. chuckh0308's Avatar
    Correction, it's $15. I think I got mine for $10 because I got some combo deal or something. This is the one I got!

    http://shop.crackberry.com/blackberry-micro-usb-travel-charger/5A17A4202.htm

    I should just send you one since you made those two awesome Backgrounds for me!

    I don't know about the RIM specific prongs being available alone, but you might look for the Kensington branded travel chargers and see if you can get one from them. I got one of the Kensington chargers for our iPhone and they are exactly the same as the one RIM sends with the Storm and the plug attachments are interchangeable.
    Last edited by ChuckH0308; 05-20-09 at 07:48 PM. Reason: edit
    05-20-09 07:45 PM
  15. blueskyjunkie's Avatar
    Thanks for the link! I might look into picking one of those up since my charger is pretty much worthless in the United States now .

    Are you sure it was me? I think you might have me mistaken with someone else. I'm terrible at graphic design and that kind of stuff, and I don't recall ever making any wallpapers. It would be an awesome skill to have though.

    I think I'll just get the one from CB. I don't really need a travel one, and I'd probably just end up losing the prongs again lol.


    Correction, it's $15. I think I got mine for $10 because I got some combo deal or something. This is the one I got!

    http://shop.crackberry.com/blackberry-micro-usb-travel-charger/5A17A4202.htm

    I should just send you one since you made those two awesome Backgrounds for me!

    I don't know about the RIM specific prongs being available alone, but you might look for the Kensington branded travel chargers and see if you can get one from them. I got one of the Kensington chargers for our iPhone and they are exactly the same as the one RIM sends with the Storm and the plug attachments are interchangeable.
    05-21-09 12:31 AM
  16. blueskyjunkie's Avatar
    I think. I want to say it's the one under Options > Memory > Encryption Mode. Try setting it to None if it isn't already. I think that's the one.
    No luck. None of the settings under that option allow it to play. Hopefully .148 won't be plagued with this unfortunate bug.
    05-21-09 12:32 AM
  17. chuckh0308's Avatar
    Thanks for the link! I might look into picking one of those up since my charger is pretty much worthless in the United States now .

    Are you sure it was me? I think you might have me mistaken with someone else. I'm terrible at graphic design and that kind of stuff, and I don't recall ever making any wallpapers. It would be an awesome skill to have though.

    I think I'll just get the one from CB. I don't really need a travel one, and I'd probably just end up losing the prongs again lol.
    Well, I'm a dork, it was "SkydvrZero" that made the wallpapers for me...duh! Sorry! You should have just played along...lol! You'll probably understand how I made the mistake though.

    I did do a few searches for you to try and find replacement prongs, but didn't have any luck. Was hoping there would be an online source for parts.

    Hope the folding version works better for you! One thing about it, if you do go out of the Country you can still take the other adapter, unless you are like me and risk losing it sometime between now and then...lol!
    05-21-09 04:12 PM
LINK TO POST COPIED TO CLIPBOARD