02-10-09 02:32 PM
28 12
tools
  1. bbman1605's Avatar
    I unplugged my storm at 8am and left for work, it's now 3:44pm and my phone has lost all of its battery life. I've had 1 text, 1 phone call and less than 5 mins of using the browser. Also a side note, .99 doesn't seem any faster than .75. That said it seems pretty stable.
    02-03-09 06:55 PM
  2. MPSmith1's Avatar
    Try this existing thread on the subject. It might help.

    http://forums.crackberry.com/f132/ba...s-99-a-149651/
    02-03-09 07:02 PM
  3. mrfols's Avatar
    I'm very pleased with Battery Life on .99. Since 7am til 7:30pm I still have 65% life left. I've been on the phone for over an hour today and some light internet usage. I don't know that I've done anything special to get it though. I seems much better than .90.
    02-03-09 07:40 PM
  4. tommy m's Avatar
    what other apps are you running?
    02-03-09 08:17 PM
  5. mike240se's Avatar
    maybe a bad batt?

    i am on day 2, even leaving it on while isleep. and it gets tons of mesages all day/night.

    so its good here.
    02-03-09 08:29 PM
  6. GpCaptMandrake's Avatar
    Yeah... since I've installed .99 I've hammered mine all day and never gone beyond 50% by the end of the day.
    Last edited by GpCaptMandrake; 02-04-09 at 08:08 AM. Reason: Fixed typo
    02-03-09 08:31 PM
  7. tommy m's Avatar
    They should make it so when it boots the screen doesnt go to 100% brightness.
    02-03-09 08:36 PM
  8. NewAge's Avatar
    I took about a 5-10% hit on battery. Ended up the day at 60% which is still awesome. Tons of texts calls emails and CB.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-03-09 08:39 PM
  9. MPSmith1's Avatar
    They should make it so when it boots the screen doesnt go to 100% brightness.
    Mine doesn't do that on .99. Mine always stays where I put it; at 10%. In fact, I've had about every official and leaked OS so far and mine has never done that.
    02-03-09 08:39 PM
  10. BBCrackman's Avatar
    I unplugged my storm at 8am and left for work, it's now 3:44pm and my phone has lost all of its battery life. I've had 1 text, 1 phone call and less than 5 mins of using the browser. Also a side note, .99 doesn't seem any faster than .75. That said it seems pretty stable.
    Is your GPS enabled? This tends to draw the battery down quickly. Are you running any apps that update and if so at what interval. All this plays havoc on battery life. Last but not least, it could just be a bad battery. You can have that checked.
    02-03-09 08:50 PM
  11. MPSmith1's Avatar
    Is your GPS enabled? This tends to draw the battery down quickly. Are you running any apps that update and if so at what interval.
    I understand what bbcrackman is saying about apps that update using GPS, and he's right: it DOES draw down the battery. But just to be clear, simply having GPS enabled doesn't affect battery life.
    02-03-09 08:54 PM
  12. bigredrandy's Avatar
    I firmly believe those who are having battery issues either:
    A. Have a defective battery from the get-go
    B. Never brought their battery up to its full potential when it was new by giving it a full charge/discharge cycle.

    I've posted this before, but maybe it'll help people.
    I get easily 18 hours of SOLID use from my battery day in and day out and over the weekend get 2 full days, no problem. Here's how I do it:

    1. EVERY weeknight, my Storm is on charge (and running the clock in "bedside mode) from the time I go to bed (generally around 12-1AM until I get up ~6AM. When I get up the "lightning bolt" had gone away, indicating a full charge.

    2. When I'm at my desk, if possible, my Storm is connected to the PC - and charging during the "morning sync" but once the "bolt" goes away, I disconnect it.

    3. Every weekend, I let my Storm discharge down to where it is only showing 1 bar on the battery. (This normally takes all day Saturday if I don't charge it overnight Friday night.)


    There shouldn't be this much variability in these batteries. The LiIon battery technology is a mature and proven one. Iv we're getting this much variability, it's either user related, or there's a SERIOUS Quality Control issue where they're made.
    02-03-09 09:05 PM
  13. GeneralMills's Avatar
    I'm very pleased with Battery Life on .99. Since 7am til 7:30pm I still have 65% life left. I've been on the phone for over an hour today and some light internet usage. I don't know that I've done anything special to get it though. I seems much better than .90.
    Almost exactly the same, 7am to 8 and I have 68% left with 45 minutes of call time and some internet usage.
    02-03-09 09:06 PM
  14. bosephus61's Avatar
    I'm running .99 (upgraded from .90) -- I've had mine off the charger since 7:30am (and it's not 6:11pm) and I've only used 20% of my battery
    02-03-09 09:12 PM
  15. bbman1605's Avatar
    I firmly believe those who are having battery issues either:
    A. Have a defective battery from the get-go
    B. Never brought their battery up to its full potential when it was new by giving it a full charge/discharge cycle.

    I've posted this before, but maybe it'll help people.
    I get easily 18 hours of SOLID use from my battery day in and day out and over the weekend get 2 full days, no problem. Here's how I do it:

    1. EVERY weeknight, my Storm is on charge (and running the clock in "bedside mode) from the time I go to bed (generally around 12-1AM until I get up ~6AM. When I get up the "lightning bolt" had gone away, indicating a full charge.

    2. When I'm at my desk, if possible, my Storm is connected to the PC - and charging during the "morning sync" but once the "bolt" goes away, I disconnect it.

    3. Every weekend, I let my Storm discharge down to where it is only showing 1 bar on the battery. (This normally takes all day Saturday if I don't charge it overnight Friday night.)


    There shouldn't be this much variability in these batteries. The LiIon battery technology is a mature and proven one. Iv we're getting this much variability, it's either user related, or there's a SERIOUS Quality Control issue where they're made.

    First off I when I was on .75 my battery life was great. I was running the same apps and had GPS and it would always last the enitre day. So, that tells me I do not have a defective battery.

    Secondly their is no need to charge your phone right out of the box, all phones are fatory chargerd before they even hit the stores. Im sure it wouldn't hurt to do it but it really doesn't make a difference. .99 is just not good on my phone might work for others but not mine.
    02-04-09 01:44 AM
  16. russap5's Avatar
    Mine lasted well over a day on .90 and now with .99 it barely makes is 8 hours with little use.. .99 blows
    02-04-09 01:54 AM
  17. Skilover's Avatar
    Battery life on 99 is fantastic, better than 86, which was much better than 75
    02-04-09 01:54 AM
  18. mkivsuprapower's Avatar
    Mine started off pretty crappy and died within 9 hours, but after 2 batt. pulls it got.... well... awesome! today was great. unplugged mine at 11am this morning and used mine pretty heavily with about 30 minutes worth of calls, heavy texting and some browsing and sill have 60% power. its now 11:25pm. 12 hours. the best performance so far since launch date.
    02-04-09 02:25 AM
  19. bad-s's Avatar
    I'm surprised there is such different experiences. I hated how terrible the battery life was with 75. 99 has been night and day. Its much better

    Posted from my CrackBerry at wapforums.crackberry.com
    02-04-09 04:43 AM
  20. mister_tu's Avatar
    I figured it out...its weatherbug. Uninstall and do a reboot and your battery life will be exponentially better.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-04-09 08:18 AM
  21. Torino216's Avatar
    mine was bad with .90 but since going to .99 mine has greatly improved.
    02-04-09 09:42 AM
  22. tranceformer's Avatar
    I figured it out...its weatherbug. Uninstall and do a reboot and your battery life will be exponentially better.

    Posted from my CrackBerry at wapforums.crackberry.com
    +1

    The first day I had .99 installed, weatherbug was hanging up trying to update using the GPS. That killed over 50% of my battery in less than a day while barely using the phone. Since that day (sunday) I've only had to charge my phone once.
    02-04-09 11:11 AM
  23. ThePerfectStorm's Avatar
    Me and my wife got our storms monday night. I had to work that night so didn't get to hardly charge mine, but her's charged all night and she lost around 50% her battery during the day and she's a teacher and doesn't get to use it at all during the day! I got up yesterday afternoon and updated to .99. Went to work last night with full charge and came home with about 80-85%. I didn't make any calls but spent a good hour or 2 online dowloadin a few apps and playing with them.
    02-04-09 11:31 AM
  24. josh.perry's Avatar
    Yeah I was able to go from 10:30 am until 2pm and was still at 100%...i've found that the battery life has drastically improved from .75.
    02-04-09 11:54 AM
  25. Hophead's Avatar
    My phone comes out of the cradle every morning at 6:0AM. I hammer it all day (Kids and wife) by the end of the day when it goes back in the cradle (About 9:00PM) I am down to 70%. I love .99 except for the media player.
    02-04-09 01:49 PM
28 12
LINK TO POST COPIED TO CLIPBOARD