1. therston's Avatar
    Ok,
    I cannot get a reliable charge on my Storm. I have tried to follow every step by upgrading OS .99 and CrackMem, Getting rid of Apps, Buying the extended Battery, not charging overnight Etc. I looked to see if there was a thread somewhere else on this but can someone help me figure out how to correct this problem? Is my Sorm defective?
    02-07-09 10:33 AM
  2. the tony banza show's Avatar
    Ok,
    I cannot get a reliable charge on my Storm. I have tried to follow every step by upgrading OS .99 and CrackMem, Getting rid of Apps, Buying the extended Battery, not charging overnight Etc. I looked to see if there was a thread somewhere else on this but can someone help me figure out how to correct this problem? Is my Sorm defective?
    hmmm may be a silly question but have tried doing a battery pull? take the battery out of the phone for like 30-45 sec and put it back in. try that a couple of times if that doesnt work you may have a defective battery and not a phone.
    02-07-09 11:34 AM
  3. ArmaK's Avatar
    Ok,
    I cannot get a reliable charge on my Storm. I have tried to follow every step by upgrading OS .99 and CrackMem, Getting rid of Apps, Buying the extended Battery, not charging overnight Etc. I looked to see if there was a thread somewhere else on this but can someone help me figure out how to correct this problem? Is my Sorm defective?
    Did you also try disabling the GPS if you don't need it and setting your network settings to 1xEV instead of Global. I would also suggest letting your battery drain all the way and then fully charge it.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-07-09 01:07 PM
  4. the tony banza show's Avatar
    Did you also try disabling the GPS if you don't need it and setting your network settings to 1xEV instead of Global. I would also suggest letting your battery drain all the way and then fully charge it.

    Posted from my CrackBerry at wapforums.crackberry.com
    agreed i forgot about that too
    02-07-09 02:18 PM
  5. Thomas271973's Avatar
    Umm, do you ever find yourself with near zero service? (one bar or none?)

    If so, turn the radio off when you encounter this area if you intend on staying there for an extended period of time.

    When the Storm is searching for service continuously, you have about 3-5 hours and it'll be dead.
    02-07-09 02:32 PM
  6. therston's Avatar
    Yes I do battery pulls a few times a day but I will try a few other of your tips here, thanks btw.
    I had this problem with the basic battery it came with and bought the extended battery to try and resolve it...so I do not think it is the battery.
    02-07-09 07:15 PM
  7. the tony banza show's Avatar
    Yes I do battery pulls a few times a day but I will try a few other of your tips here, thanks btw.
    I had this problem with the basic battery it came with and bought the extended battery to try and resolve it...so I do not think it is the battery.
    sorry dont know what else to tell you bro.
    02-07-09 07:25 PM
  8. therston's Avatar
    so explain this...I do all of the things above...my phone has shut off with automatic shut off the last 2 nights and while the phone is off from 12 to 7....at 7 am...the battery has leaked down to completely empty or near empty...it was full when I shut it off.
    02-08-09 08:46 AM
  9. Thomas271973's Avatar
    so explain this...I do all of the things above...my phone has shut off with automatic shut off the last 2 nights and while the phone is off from 12 to 7....at 7 am...the battery has leaked down to completely empty or near empty...it was full when I shut it off.
    There's only three things left dude.

    1. You dropped it. And doing so effed something the eff up inside your Storm. One wire shorted.......draining power......yadda yadda.

    2. You got it wet and it's doing the same thing as above.

    3. It's defective.

    Anyways, just take it to Verizon and have them mail you a replacement. Seriously, not worth the effort. Getting a replacement Storm is stupid easy right now.

    Good luck dude.
    02-08-09 11:18 AM
  10. anon(1385035)'s Avatar
    Are you running Weatherbug? If so, delete it and see how you go. I deleted it last night and have 55% battery after 17 hours of reasonable use. Previously I would be at 25-30% by now.
    02-08-09 11:52 PM
  11. therston's Avatar
    Are you running Weatherbug? If so, delete it and see how you go. I deleted it last night and have 55% battery after 17 hours of reasonable use. Previously I would be at 25-30% by now.
    hmmm. I will do that.
    02-09-09 12:31 AM
  12. ArmaK's Avatar
    Are you running Weatherbug? If so, delete it and see how you go. I deleted it last night and have 55% battery after 17 hours of reasonable use. Previously I would be at 25-30% by now.
    I have the Weatherbug app installed on my storm and I can usually get 3-4 days with very heavy usage. I forgot to suggest this earlier but also try turning down the brightness of your screen. I have mine set to 10 and it plenty bright enough.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-09-09 01:04 AM
  13. Shawn.'s Avatar
    something on your phone is seriously messed up if none of the said advice helped...new storm?
    02-09-09 10:12 AM
  14. southnam's Avatar
    Ok,
    I cannot get a reliable charge on my Storm. I have tried to follow every step by upgrading OS .99 and CrackMem, Getting rid of Apps, Buying the extended Battery, not charging overnight Etc. I looked to see if there was a thread somewhere else on this but can someone help me figure out how to correct this problem? Is my Sorm defective?
    Question. I bought mine last week. Do you hav condition the battery? I read yes and no on here. Was I supposed to charge 12hrs out ofbox.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-11-09 09:42 AM
  15. Andrewstorm9530's Avatar
    Im Having The Same Battery Problems. Im Noticing That The Problem Reoccurs After Plugging In My Stock Head Phones. Not Only Does The Battery Drain Super Fast (within 5 Hours Or So) But When I Receive Or Send Calls They Cant Hear Me On The Other End. I Have To Pull My Battery Everytime To Fix This Problem. So Freaking Annoying! And I Stress This Only Occurs After Using The Head Phones.
    02-11-09 11:29 AM
  16. southnam's Avatar
    this is my first blackberry. If I get about 30 emails a day, use it for about 1 hour surfing, how long should the batter last than. I charge it overnight and by about 9 pm at night it's pretty well drained so only about 12-15 hours of battery life. Is there something wrong. I have weatherbug and gps on all the time as well but should that cause this problem. I also have viigo installed, would that cause the drain. Or did I just not condition my battery properly
    02-11-09 09:18 PM
  17. therston's Avatar
    ok...I figured I would update you all on this and maybe it helps someone.
    None of the things I did worked.
    BUT...I noticed that when my phone shut off for 7 hours and the phone was not plugged in...it was draining my battery anyway so i wonder...could it be a bad battery?
    So I charge the battery to full and shut off the phone and remove the battery for the night.
    1- The battery is fine AND
    2- It stays charged well now all day long.
    Every night I pull the battery for the night but I wonder why if the phone is off does it drain my battery.
    02-11-09 10:38 PM
  18. southnam's Avatar
    it shouldn't. Yesterday I didn't use my phone for like 5 hours. Went to check it an it was out of battery. Frustratiing a bit. The guy who said he gets a few days with heavy usage... I'm dreaming of that.
    02-12-09 12:37 PM
LINK TO POST COPIED TO CLIPBOARD