02-09-09 11:04 PM
33 12
tools
  1. zigzackattck's Avatar
    I'm very confused, because I've been reading over .99 threads, and it seems like everyone is getting fantastic performance out of their batteries -- well, everyone except me. My battery was doing fine up until this update. I could go two days without charging my phone (even if I left it on during the night). Now that I have .99 installed, I am lucky if it lasts 6 hours. I text very little, and haven't made any phone calls yet. I keep the phone on lock for most of the day. I have GPS and Bluetooth turned off as well. Why is my battery getting killed by .99 while other people's batteries are having the opposite effect?
    02-05-09 11:05 AM
  2. adubya4585's Avatar
    The exact same thing happened to me. Do you happen to have Weatherbug installed? If so, try uninstalling it. Since I could never get it to work with .99 anyway, I deleted it and it totally solved the problem. Now my battery life is better than it has been with any of the OS's so far.
    02-05-09 11:11 AM
  3. Shadizar's Avatar
    I have found by doing updates to the OS that if you do not first perform a WIPE, then updating the OS that battery performance is in the tank.

    After updating from .86 to .90, my battery would last only 3 hours if I was lucky. After updating from 90 to 99, it lasted 6 hours like you were seeing. I wiped the phone and started fresh straight to .99 and I am back to about 10-15 hours of battery life.
    02-05-09 11:38 AM
  4. zigzackattck's Avatar
    Alright, well I do have Weatherbug installed, so I will try uninstalling that first. If that doesn't work, then I guess I'll have to wipe my phone . Thanks for the help.
    02-05-09 11:47 AM
  5. DPDCrackBerry's Avatar
    I have found by doing updates to the OS that if you do not first perform a WIPE, then updating the OS that battery performance is in the tank.

    After updating from .86 to .90, my battery would last only 3 hours if I was lucky. After updating from 90 to 99, it lasted 6 hours like you were seeing. I wiped the phone and started fresh straight to .99 and I am back to about 10-15 hours of battery life.
    This is not neccesarily true, I have not wiped from .90-.99 and the battery life is fine, lasts easily 16 hours with extensive use.

    Possibly with a OS update it effects the battery memory?
    02-05-09 11:47 AM
  6. buckifvr's Avatar
    I'm very confused, because I've been reading over .99 threads, and it seems like everyone is getting fantastic performance out of their batteries -- well, everyone except me. My battery was doing fine up until this update. I could go two days without charging my phone (even if I left it on during the night). Now that I have .99 installed, I am lucky if it lasts 6 hours. I text very little, and haven't made any phone calls yet. I keep the phone on lock for most of the day. I have GPS and Bluetooth turned off as well. Why is my battery getting killed by .99 while other people's batteries are having the opposite effect?
    I had a similar problem with my Storm and .99. It did not show up right away, it took a couple of days and occured after I downloaded Typerspeed. Anyways, I noticed that my screen backlight was continuously cycling off and on at 1-2 minute intervals and I think that this drained the battery. Oddly once I recharged the battery, and because the battery was so dead that he device essentially rebooted. Battery life has been fine ever since. What caused my screen to cycle on and off, I don't know. But it seems ok now.

    As for WeatherBug, I have it set to update every 2 hours (as opposed to what appears to be the default of every 15 minutes) and it seems to work just fine. I don't think you need to delete WB from your device, just change the update settings from the preferences menu.
    02-05-09 12:24 PM
  7. buckifvr's Avatar
    I have found by doing updates to the OS that if you do not first perform a WIPE, then updating the OS that battery performance is in the tank.

    After updating from .86 to .90, my battery would last only 3 hours if I was lucky. After updating from 90 to 99, it lasted 6 hours like you were seeing. I wiped the phone and started fresh straight to .99 and I am back to about 10-15 hours of battery life.

    I would caution about "wiping" your device with JL Cmdr. Even the Crackberry Gods (CX, Pete6, Don, Reed) do not recommend wiping your device when you upgrade OS's. They say when you upgrade the OS it removes the old OS automatically prior to installing the new OS. They also are concerned that using JL Cmdr can cause other problems when in the hands of an inexperienced user. They suggest JL Cmdr be used only when severe problems are occuring with your device. Just a word of caution.

    I have updated from .65, .75, .85, .86, .90, to .99 with very little problems all without doing a "wipe" with JL Cmdr or CrackMem.
    Last edited by buckifvr; 02-05-09 at 12:30 PM. Reason: addition
    02-05-09 12:29 PM
  8. bigman2's Avatar
    I would caution about "wiping" your device with JL Cmdr. Even the Crackberry Gods (CX, Pete6, Don, Reed) do not recommend wiping your device when you upgrade OS's. They say when you upgrade the OS it removes the old OS automatically prior to installing the new OS.
    I distinctly remember Crucial saying you don't need to wipe every single time... Going on to say maybe every 3-4 upgrades a wipe might be in order. But I also took that to mean that individual experiences may vary. Sometimes you get a bad update applied and it causes problems, so wiping and starting fresh is helpful. Other times it'll work fine for several updates in a row.

    They also are concerned that using JL Cmdr can cause other problems when in the hands of an inexperienced user. They suggest JL Cmdr be used only when severe problems are occuring with your device. Just a word of caution.
    I don't know about severe problems. You really have to set your mind to it to truly brick a Blackberry, but yes, some inexperienced people may panic at the first sign of trouble, but that's why there are guides and forums like this.
    02-05-09 12:43 PM
  9. mister_tu's Avatar
    Its weatherbug for sure. Had the same problems and removed and reboot and the gods are smiling again.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-05-09 12:44 PM
  10. miata492's Avatar
    i am on .99 now with weatherbug and no probs with battery life. i have had weatherbug installed since i got the phone with .75 on it. i did the .99 update to 2 other storms yesterday - one with weatherbug already installed before the upgrade and no problems, the other wanted weatherbug installed after i did the upgrade to .99 and his phone is lasting about 3 hours before dying. needless to say, i am going to uninstall WB now and see what happens. very strange...

    also, i only wiped mine once just because i tried so many different programs, etc out and things were a little funky. i did it after i installed .90. the other 2 have never been wiped.
    02-05-09 01:22 PM
  11. sda3's Avatar
    5.5 hours today with light to moderate use on my .99 and the battery is still at 95%. Do you have a weak signal? (2 bars or less) That drains mine really fast. Oh, and weatherbug is working fine.
    02-05-09 01:30 PM
  12. GodModeOn's Avatar
    I get about 4-6 hours in "super" extensive use, like browsing the net, an hour or 2 of phone calls, and also using it as an mp3 player. Otherwise I'm getting around 8-10 hours with my normal use, which is still a bit low for my liking. I'm not sure what I have running that causing the low battery life, but it's a fresh .99 install (updated the first day I got the phone). The battery drains rather quick, and by the end of the day I'm getting a low battery notice, which in my opinion, isn't a good thing cause it's not like I know whether or not I can charge it right away or if I still need it for a little extensive use.
    02-05-09 01:40 PM
  13. budreaux's Avatar
    I'm having battery issues as well and have been pooring throught most of these threads and came across one that was interesting (wish I could find it again), but it was about battery drainage due to the OEM holster. It would be interesting to see if those users that are having battery problems store they BB in the holster. After my daily charge tonight I'm going to not holster my BB and see what happens.

    Budreaux
    02-05-09 05:55 PM
  14. zigzackattck's Avatar
    Yay. It was Weatherbug that was causing the problem. Thanks everyone. I am at 85 percent, and my blackberry has been on for 5 hours -- a phone call and lots of texting... also I used the web browser.
    02-05-09 06:14 PM
  15. blopez24's Avatar
    I don't know how u guys get so much batter life I can't go a day with out having to recharging my phone.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-05-09 06:19 PM
  16. Sith_Apprentice's Avatar
    Keep an eye on your signal, if it drops from EDGE to edge or 1XEV or 1xev then your battery life will suffer.
    02-05-09 06:21 PM
  17. ejackson's Avatar
    I unplugged my phone at 7am and now its 6:50pm and my battery is @ 25%. I have made approx. 30 minutes of phone calls, 20 or more text messages plus all my emails. Also have done 3 battery pulls, two for software removals and one for memory leakage. So far my battery has lasted much longer with .99 over .90.

    Also with .99 I don't have random reboots or media card\vsod errors or any app 523 error.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-05-09 06:59 PM
  18. Dj_murph's Avatar
    What i did to fix the batt drain was let it completey drain keep trying to turn it on until its completely dead then charge overnight .. do a batt pull when its dead and then when its fully charged ... dont know the theory behind this but what can i say it worked for me the batt now lasts 2 days
    02-05-09 08:27 PM
  19. mbspark's Avatar
    +1 on removing weatherbug after .99.

    I was getting the little "busy" icon pop up about every 20-30 seconds throughout the whole day, draining my battery down to about 1/2 power in 3 hours. Read this thread, removed weatherbug, restarted. Haven't gotten that busy icon since.

    Much better! I can make it through the day again with 90% life.
    02-06-09 12:26 PM
  20. jamesandyori's Avatar
    No weatherbug.

    I turned on @ 5:15 A.M. this morning and as of 11:00 A.M. battery: 61%

    I'm running .99.

    Is this good?
    02-06-09 02:05 PM
  21. ejackson's Avatar
    +1 on removing weatherbug after .99.

    I was getting the little "busy" icon pop up about every 20-30 seconds throughout the whole day, draining my battery down to about 1/2 power in 3 hours. Read this thread, removed weatherbug, restarted. Haven't gotten that busy icon since.

    Much better! I can make it through the day again with 90% life.
    I have weatherbug installed, doesn't drain mine anymore than normal. I do think letting the battery dicharge then re-charge (with unit OFF) does help, FWIW.
    02-06-09 04:59 PM
  22. nzero's Avatar
    if you must keep weatherbug just take out all the alerts, and set it to update ever 2-4hours. Reduce from adding more than 2-3 cities. and not show high/lo. I have had weatherbug running for a while like that and been having 42-48mb memory on average even after days without battery pull and the battery life hasnt really been effected much ethier, even after .99 OS update.
    02-06-09 05:15 PM
  23. BB_Chaser's Avatar
    After an OS upgrade, I alwasy do a battery pull within 10 minutes of being back up and restored.

    Then comes battery care and charging...
    I always do another battery pull the power off with the red end button. Plug into the AC wall charger and leave it overnight.
    That is it. I have have had 2+ days of solid battery life with each OS (.65-.75-.99). Tried others and VSOD was too much!
    02-07-09 07:04 AM
  24. buckifvr's Avatar
    Here's a little different battery issue. I had essentially a full battery. Powered down my Storm before bed (not connected to power cord). Woke up the next morning and my Storm was dead. No battery at all. Has anyone else experienced this? How could I have such a severe battery drain, when the device has been powered off? Any clues? Thanks for your input.
    02-08-09 04:17 PM
  25. farundrpar's Avatar
    Just want to report that I too was having the severe battery drain with .99. I uninstalled WB (even though I haven't even ran it since the upgrade to .99) and battery life seems to better... about 5% loss the past few hours, which is a significant improvement over what I was getting before I uninstalled WB.
    02-08-09 04:55 PM
33 12
LINK TO POST COPIED TO CLIPBOARD