1. SquirrelNuts's Avatar
    I read so many posts about poor battery life that I have to post this info.

    Previous to my storm I owned a couple of Palm Treos and both had very poor battery life (a few hours) before conditioning. After following this procedure battery life increased to 3-4 days moderate use on the treos and yes, on the Storm too!

    1) Discharge the battery fully.
    2) Recharge the battery.
    3) Disconnect the charger, wait 30 seconds and reconnect it. Leave the charger connected 6 hours or more (overnight is good).
    4) Keep charging overnight every night for 2 weeks whether your Storm needs it or not.
    5) You'll see a vast improvement in battery life.


    I've just put my Storm on charge after nearly a week of 15 emails and 4 voice calls per day. Not to mention 2 1.5 hour videos and loads and loads of music.
    05-22-09 09:41 PM
  2. patches152's Avatar
    i bought a new battery with a few other accessories. new charger with the flip blades, the int'l adapter one bugs me...idk why. got the OEM charging dock, and this mini battery charger. the new battery charges faster AND dies 3 times slower...

    and i believe that the newer charger(s) are a big improvement also.
    05-22-09 10:29 PM
  3. Wizard101's Avatar
    The Lithium-ion batteries do not need to be fully discharged and then fully charged, in doing so it will actually make the battery perform worse over time.

    Lithium-ion battery - Wikipedia, the free encyclopedia
    05-23-09 12:08 AM
  4. patches152's Avatar
    thanks whizz

    (thats what i call you, the wizard aka "the whizz")
    05-23-09 12:14 AM
  5. SquirrelNuts's Avatar
    Wizard, you are correct that Li-ion batteries do not need to be fully discharged. However, it helps a lot if they *are* discharged fully on the first cycle.
    Sometimes the science and reality clash. I think this is one of those cases. I have had 3 storms now, and battery life has never been an issue on any of them.
    05-23-09 02:58 AM
  6. SquirrelNuts's Avatar
    Patches, I'm still using the charger that I got with my first Storm back in November. For some reason the dock won't charge my third one but works in every other way, odd.
    05-23-09 03:03 AM
  7. patches152's Avatar
    maybe there is something missing out of the USB port on one of your devices? like a pin used for power or something?

    if the dock works with two, but not the 3rd then i speculate that it's the device.
    05-23-09 03:09 AM
LINK TO POST COPIED TO CLIPBOARD