1. zacko's Avatar
    I thought the Bold was a battery hog compared to my previous Curve and Pearl, but I was at least able to take it along and use it heavily on a 6 hour trip that included a lot of texts and browsing during down time in an airport and heavy music/game use during the flight.

    I switched to the Storm and have always been a little disappointed in battery life, but expected it to improve with OS upgrades. Last week, I was using the leaked .83 while waiting around a hospital ER. The phone had only been off its charger for two hours when I arrived, so it was still nearly full. While waiting, I used BB messenger heavily. I checked and replied to emails. I made a few phone calls and spent a great deal of time browsing the web (no bluetooth, video or music use). 3 and 1/2 hours later, the phone was dead. Inside the hospital, the signal would often drop off or down to 1x, so I imagine there was possibly some extra drain while the phone kept trying to reestablish a 3g connection, but I was shocked by how fast the charge dropped under consistent heavy use.

    Is my experience consistent with others? Is it possibly a battery issue? I upgraded to .85 but haven't been able to really test it under similar conditions.
    12-29-08 08:44 AM
  2. mystics7's Avatar
    before the hospital how bad was the battery life and yes you are 100% correct that when the phone has no signal it will drain battery life trying to obtain a signal. I have not had a problem with my battery at all i usually get 2 1/2 days out of the phone. I was in AC (atlantic City) and using the BBM, phone and music and i would have no problem with the battery got a full day (19 hours) with out a problem.
    12-29-08 08:52 AM
  3. anon(91837)'s Avatar
    Based on your description that seems about normal. It is like a laptop, if you are using its functions heavily as your describe this is going to happen. Especially w/ a weak signal that drops the EvDO connection regularly.
    12-29-08 08:53 AM
  4. jh4for5's Avatar
    More than likely it was your signal strength that drained it. The batter powers this thing and its high powered screen. Everything you were using (phone calls, emails, BBM, etc...) required a signal to use so combine signal searching with yoru screen being on for a long period of time - that's probably what did it. Same thing happens to me when I'm low on signal strength.
    12-29-08 08:53 AM
  5. holdfast's Avatar
    I got the storm on Saturday. I noticed with heavy use yesterday I only got 5 hours out of a full charge. My pearl can last almost all day with the same usage.
    12-29-08 09:14 AM
  6. mdude85's Avatar
    I'm going to have to agree with the others that heavy usage of the phone (especially for web browsing) in addition to low signal strength probably is a huge contributing factor. Combine that with the fact that hospitals are designed to reduce signal strength (the use of cell phones and other wireless devices could interfere with hospital equipment) and you have a dead phone in 4 hours. I'm actually surprised it lasted that long.

    I think if the battery lasts 2 days with light use on a strong signal then it's fine. Although I've heard some horror stories about bad batteries being shipped with the Storm. Who knows?

    You can't really compare the Storm to other BB devices, especially the Pearl. The Pearl is a fliphone, it has a tiny screen. The Storm has a huge, high resolution screen with a very bright backlight. It would be interesting to see how the Storm would have compared to the iPhone, since the iPhone is known to have atrocious battery life.
    12-29-08 09:17 AM
  7. BlackCuse8830's Avatar
    Battery performance might be linked to the OS you're running. Some of my friends were expiriencing bad drain, but os upgrades corrected it. On the other hand, my Storm was getting great battery life. I upgraded to .85 on Saturday and now it dies every six or seven hours (before it waould last two days).

    Don't know if this is your problem, but it is for me.
    12-29-08 09:32 AM
  8. zacko's Avatar
    Thanks for the replies. I suspect it's probably the signal issue. The only other time I experienced a really rapid drain like that was when I accidentally left the Garmin free trial running in the background while in a basement for a few hours. I've upgraded to .85 and tried to use the phone quite a bit today but I'm not seeing the drain like I was. I'll probably never love the battery life on this phone like I have my other berries, but I do love the phone enough that I would rather buy an extra battery than go back to the Bold or Curve.
    12-29-08 02:26 PM
LINK TO POST COPIED TO CLIPBOARD