1. susiegirl07's Avatar
    I have been having major screen clicking problems. The screen will click a lot with just a little pressing. I am running 517 with lyrical hybrid. 608 in about screen. I had 713 but the screen problems were worse so I downgraded back to 517.

    Anyone else having these issues?
    06-22-10 03:48 PM
  2. TheOne01's Avatar
    Impossible! Surepress is the answer!
    06-22-10 03:49 PM
  3. ynotbme's Avatar
    Yes, since I loaded .713. I did not have it with the .517 hybrid. I randomly get multiple clicks. Also sometimes my screen doesn't click at all. I have to hit the back button several times to get it to work. Not very often, but annoying. I'm on the fence as to downgrading to .517 again or reloading .713 to see if it goes away.
    06-22-10 03:57 PM
  4. Thud Hardsmack's Avatar
    That was somewhat less than helpful.

    Impossible! Surepress is the answer!
    06-22-10 06:12 PM
  5. Thud Hardsmack's Avatar
    Which .713 do either of you have? I'm running TBayTel's .713 and I've had very little issues. And most are Opera Mini.
    06-22-10 06:14 PM
  6. joe_fresh's Avatar
    none here and i am on vzw .713
    06-22-10 07:29 PM
  7. 1812dave's Avatar
    I have been having major screen clicking problems. The screen will click a lot with just a little pressing. I am running 517 with lyrical hybrid. 608 in about screen. I had 713 but the screen problems were worse so I downgraded back to 517.

    Anyone else having these issues?
    713 works identically to 607 which worked identically to 320, when it comes to screen press (at least for my phone and my wife's)
    06-22-10 09:41 PM
  8. aboutDbuzz's Avatar
    No problem with my screen on .713. It is actually snappier.
    06-22-10 10:14 PM
  9. nickp001's Avatar
    TBayTel's .713 with multiple click problem here.
    06-23-10 12:55 AM
  10. titusilvering's Avatar
    Just curious... did those multiple clicks happen at corners of the screen?
    06-23-10 01:29 AM
  11. smarty33's Avatar
    I had this problem. Mine was not OS specific. Tried everything to fix - settings, torx, OS. No good. Only fix for me was replacement device.

    It's a very frustrating problem. I put up with it for weeks before getting a replacement. Wish I had done it sooner.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-23-10 05:06 AM
  12. mazinkaiser's Avatar
    I had surepress issues with the new build s2 and got smart and returned it within 30 days for a droid. I type faster than I ever did on any bb that I've ever had with swype and no more truncated emails!
    06-23-10 05:49 AM
  13. trucksmoveamverica's Avatar
    Which .713 do either of you have? I'm running TBayTel's .713 and I've had very little issues. And most are Opera Mini.


    I have ran both versions of 713, which both are the same anyway. Both have done it, and I dont use opera mini. You push the screen once and it clicks multiple times. It dont happen a lot, but it does. Verizon would have been better to release 517 IMO.

    I am also on the fence of going back to 517. Giving 713 a little more time.
    06-23-10 07:28 AM
  14. Lumasmom's Avatar
    I am having clicking problems including clicking while I am on a phone call. This started before the .713 install. I am also getting lots of static since the install.
    06-23-10 08:11 AM
  15. susiegirl07's Avatar
    Mine seem to click in the middle of the screen and it's like a machine gun sometimes!! So does this mean I have to get a replacement???? I have insurance but I know they will give me a refurbished phone and I don't want that.
    06-23-10 05:03 PM
  16. kazmi's Avatar
    I am having the same and possibly worse issues...my sincere advice would be to first try a newer OS....if you are already on the latest and the problem persists, definitely look at a replacement device.
    06-23-10 05:20 PM
  17. titusilvering's Avatar
    Mine seem to click in the middle of the screen and it's like a machine gun sometimes!! So does this mean I have to get a replacement???? I have insurance but I know they will give me a refurbished phone and I don't want that.
    I can understand that click click click thingy! hahhaa i also ever encounter but mine is at the edge when i uses full keyboard potrait mode e.g. "A".

    I figured out that... i am too gentle!!! or too fast clicking with my thumb or finger!!! cuz my sim/phone password start with "a" oopss....

    hahaha so i am not sure how hard or soft you press the screen. cuz when i press too gently that will happen but not always...

    you know what? these days... when i type super fast i just press it like nobody business.. im not saying i pressing hard but you know? this is surepress.. not touch screen only... so press it down like a keyboard thats what i did.

    maybe you can take note and press a little harder or longer always on that spot that clickers more and see if that helps.

    oh yes...to be honest.. its real amazing how the surepress work.. i mean the hardware..i have open it up to see those 4 special electronic points... amazing....it could be a hardware problem... but pray its not...
    Last edited by titusilvering; 06-23-10 at 05:33 PM.
    06-23-10 05:26 PM
LINK TO POST COPIED TO CLIPBOARD