1. tranebwc's Avatar
    hello!
    i have a storm but just out of nowere the battery life is of 6 hours top, i downloaded the battery booster from the crackberry storm, and it does help, but it only gives me like 30-40 minutes extra, does anybody have an advice to give so i can save a little more energy for the battery?

    thank you, greetings

    Sorry for my bad english
    02-20-09 11:06 PM
  2. jradaj's Avatar
    Make sure your network is switched from Global to 1xEV.

    (assuming you're on a CDMA network, which it looks like you are with a 9530)
    02-20-09 11:10 PM
  3. JReek's Avatar
    Tons of forum posts on this: My top six things to do:
    -Upgrade OS to at least .99
    -Close unnec background apps
    -Adjust settings for apps that have auto updates --WB, Viigo..
    -Change phone to 1xev, turn off GPS.. and buy a 1600 Seidio battery (but not good with OS .75)
    02-21-09 08:07 AM
  4. Eric16l's Avatar
    Another suggestion is to go into your screen/keyboard settingz and change your screen brightness down and your backlight timeout to a smaller number.
    Dygwa will reduce the drain on the battery as well as jreek's suggestion.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-21-09 09:13 AM
  5. IowaGuyBB's Avatar
    When finsihed using an app you need to actualy shut the app off don't just exit it with the red phone button. That app is still running.




    02-21-09 10:00 AM
  6. xxfire's Avatar
    Turn off blewteef if not using it...
    Get a holster that will "sleep" the BB when holstered.
    02-21-09 10:05 AM
  7. reisb's Avatar
    When finsihed using an app you need to actualy shut the app off don't just exit it with the red phone button. That app is still running.
    Help me out. I close my apps, but when I goto "Switch Application", I still have Application Center, Browser, Home, BB Messenger, Talklock (runs in back to work when call made), Phone, and Messages.

    So these are all running. And if I click and close, it just moves them to the end of the line on "Switch Application". Wife has all the same running except Application Center.

    But I will change global to 1xEV as a starter.
    02-21-09 10:15 AM
  8. reisb's Avatar
    I'm assuming you change to 1XEV under mobile network in options menu?

    Thoughts on other issue? Do other apps need to run even if you close such as browser, messenger, phone, mess?

    Still application center should not be there. How can I close it?

    thanks
    02-21-09 10:31 AM
  9. rellims's Avatar
    Any programs that use GPS that try to update automatically? Turned mine of or to manual update and it was a game changer for the battery life.
    02-21-09 10:37 AM
  10. tranebwc's Avatar
    thank you to all of you, i did everything you sayd and it help me out, the only thing i couldn't do was changing the network to 1XEV, since my gsm carrier is GSM. but anyway, thanks again.
    02-21-09 04:29 PM
  11. Stang68's Avatar
    Yeah definitely try to update to .99.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-21-09 04:51 PM
  12. Bigdaddy2009's Avatar
    Help me out. I close my apps, but when I goto "Switch Application", I still have Application Center, Browser, Home, BB Messenger, Talklock (runs in back to work when call made), Phone, and Messages.

    So these are all running. And if I click and close, it just moves them to the end of the line on "Switch Application". Wife has all the same running except Application Center.

    But I will change global to 1xEV as a starter.



    Browser, Home, BB Messenger, Talklock (runs in back to work when call made), Phone, and Messages will always be running. it is normally just the 5 without TalkLock but it runs if you have it installed, of course. lol the application center shouldnt be.
    03-03-09 01:10 PM
  13. JoeyMoose's Avatar
    BigDaddy's got it! Just make sure all your 3rd party apps are fully closed, and dont worry about backlight i have mine all the way up and it does no damage.
    03-03-09 01:20 PM
LINK TO POST COPIED TO CLIPBOARD