02-08-09 08:44 AM
71 123
tools
  1. DavidDBlackwell's Avatar
    I know this is long but please read it may just help, not just with this os but any bugs you may be experiencing.

    First off I know I am likely to get flamed for posting this but let me begin by saying that yes I know it says newbie next to my name but though I have only used a blackberry for a little over a year I am no stranger to beta testing. I have been beta for both hardware and software for as long as I can remember. It is my nature to take things that should work and try to make them behave the way they are supposed to.

    I tried all of the leaked os for the storm and really had few if any problems until I got to .90 (I know I was one of the lucky ones). I was beginning to believe my Storm was charmed but was wanting more speed and better functionality. It just didn’t feel like the Storm was living up to its potential. I dl’d .90 with great anticipation and was rewarded with much more speed and enhanced functionality. I was so excited…. For about 20 minutes. Then I started experiencing every bug posted ie. Random reboots, reboots while playing music, sim error, vsod, poor battery life… you name it I had it. I was disgusted. Still I was intrigued by the fact that so many seemed to have it running flawlessly on their machines… what was the difference… it didn’t seem to be related to any one thing and that just doesn’t sit well with me. I knew it had to be user related in some way. What was I doing wrong? I tried everything I could think of. I did a complete wipe reinstall… I tried removing all 3rd party apps (with the idea that I would re-install one at a time to find the culprit/culprits but I still had many of the errors regardless) finally I decided it was a hopeless os for my machine gave up and reinstalled .86. I continued to read the posts of folks having such varied experience with this and other os’s and my mind just couldn’t let it go. I began to see patterns in most of the complaints and decided to give it one more try. What happened was eyeopening.

    I dl’d a fresh copy of .90 made sure it was the only os installed on the computer. Formatted my media card
    Set my mobile network to 1xev
    Deleted all bbthumb files on both the device and the media card
    And because I was exhausted just installed .90 on top of .86

    When the install was completed I converted all the music I wanted to add to plain ole mp3 (I converted all music whether or not it was tagged as mp3 or not) and then just did drag and drop into the music folder instead of using a sync program.

    I then tested and found everything working perfectly… did a battery recondition (ran it to failure and did a total recharge).

    Then added every 3rd party app one by one checking for fatal errors…. Nothing…

    It has been running like a champ… only one freeze while browsing and I can live with that on any machine.
    01-27-09 04:39 PM
  2. Lylej2k's Avatar
    Ya know, other than deleting all the bbthumb files, I installed the same way. I take the media card out before I do it (old WinMo habit of mine), my network is already set to 1XEV and I installed .90 right over .86 (which I wiped before).

    I've had 4 random reboots, and I just posted them elsewhere so I'm not typing them all out again, other than that, with the camera workaround, its been running solid for me. I think I've had 1 VSoD
    01-27-09 04:45 PM
  3. DavidDBlackwell's Avatar
    The two patterns that emerged as i beat my head against all of the apparent bugs in this OS seemed to be associated with the sim card (vsod random reboots etc), and strange effects from any programs that pulled from music, photos, etc. especially from the media card... even the polling/scanning of the media card at boot.

    First... the sim subroutine appears to be unstable sooo... since we don't need it in the US... disable it.

    Second and more importantly.. we all use different methods of ripping, downloading, and syncing music,pictures and files. Some of the os's have been more tolerant of the variances than others... but different os's seem also to have stored and handled them differently. Had .90 been a first release then procedures for loading and using files would have been old hat by now and would not seem like much of a hassle at all. It would be nice, regardless of what direction the developers go with the OS, if they would add a convert option to Media Sync.
    01-27-09 04:52 PM
  4. albertdc's Avatar
    What program did you use to convert your music to "plain ole mp3s"? Does it batch convert or did you have to do each one seperately? How long did it take?
    I'm hoping that whatever you used is free so I can give it a try. Others have reported success with what you are saying, but some people have also said that it didn't work. Nonetheless, I'm ready to give it a try.
    Thanks.
    01-27-09 05:05 PM
  5. DavidDBlackwell's Avatar
    What program did you use to convert your music to "plain ole mp3s"? Does it batch convert or did you have to do each one seperately? How long did it take?
    I'm hoping that whatever you used is free so I can give it a try. Others have reported success with what you are saying, but some people have also said that it didn't work. Nonetheless, I'm ready to give it a try.
    Thanks.
    I used magix music manager but there are much better ones out there... it WAS a pain in the ****. I had to do one album at a time as a batch and it didn't find all of my itunes files but still.... Oh and Slacker is running just as slick as can be... i may not use much dl'd music anymore anyway... i just want it to work properly. also... remember i converted ALL music even those that had the mp3 tag already... and don't forget to delete the bbthumbs files. You have to do a search there should be one in every folder...
    01-27-09 05:11 PM
  6. Timspo14's Avatar
    does anyone else get the prompt to search for GSM or CDMA every reboot in .90 or .86? I can't avoid it. My phone's had some bugs but overall it's decent. Oh, and my GPS won't work despite complete wipes
    01-27-09 05:36 PM
  7. DavidDBlackwell's Avatar
    does anyone else get the prompt to search for GSM or CDMA every reboot in .90 or .86? I can't avoid it. My phone's had some bugs but overall it's decent. Oh, and my GPS won't work despite complete wipes
    First of all... go to options/mobile network/and set the network technology to 1xev or failing that pull the sim card...

    Second... is your gps services set for location on and location aiding.. on?
    01-27-09 05:43 PM
  8. ejackson's Avatar
    Thanks for the insight Dave, what you have stated make sense. It's still too early for me to speculate, but I had done nearly the same as you:
    * ran .90 for a few days, got frustrated with random reboots, APP Error 523, etc.
    * downgraded to .75, everything went back to normal (and slow)

    Then I saw this post http://forums.crackberry.com/f132/some-fix-90-a-145900/ and thought hmmm maybe I should give .90 another try.

    So [today] I did all those things, wiped the machine with JL_Cmder and re-installed .90. I have been running a stable version of .90 thus far. But as I said earlier, too early to say, its only been running for about 4 hours now. But in those four hours with 3rd party apps installed no random reboots yet. *keep fingers crossed*
    01-27-09 05:44 PM
  9. DavidDBlackwell's Avatar
    When you have this many updates this fast... it is really like playing a game when someone keeps changing the rules... you have to stay flexible and remember that some of the basic rules may change from version to version.
    01-27-09 05:47 PM
  10. albertdc's Avatar
    Do you remember what settings you used for the conversion. I just tried it on a couple of songs and it almost doubled the size of the sone (from 4,321kb to 7,036kb). The default settings are 192kbit bit rate and 44100 sample rate, and of course stereo. Do you (or anyone) know what we can lower the kbit rate to and not notice a hit in the quality?
    Thanks.
    01-27-09 06:52 PM
  11. DavidDBlackwell's Avatar
    Do you remember what settings you used for the conversion. I just tried it on a couple of songs and it almost doubled the size of the sone (from 4,321kb to 7,036kb). The default settings are 192kbit bit rate and 44100 sample rate, and of course stereo. Do you (or anyone) know what we can lower the kbit rate to and not notice a hit in the quality?
    Thanks.
    yes! it was 192kbit 44100 sample rate same as yours.
    01-27-09 06:59 PM
  12. rellims's Avatar
    I think the OP might have a really valid point with one that is listed and its not the music. I too have had a Storm that has always worked great and get frustrated with the posts that say it's not what it should be. One thing I always do, and thought you were suppose to, is remove the other OS's from my computer prior to installing the new beta or the one official release.

    Is it possible that the installer brings bugs from the prior versions to the newly installed version? I'm no programmer but everyone who installs every beta OS released likely has others on their computer....could it really be that easy?!?!
    01-27-09 07:02 PM
  13. sigtwenty's Avatar
    i never had random reboots, just lockup issues. and it was all due to phone app after a few calls. i removed sim card and im waiting to see if i need it. of all days, of course today i used phone twice but no issues today other that SMS MMS emails not beeping at me w/ screen black. it has not slowed down, internet browser has its random stalls but same as before on .90
    01-27-09 07:05 PM
  14. stryker1800's Avatar
    Do you remember what settings you used for the conversion. I just tried it on a couple of songs and it almost doubled the size of the sone (from 4,321kb to 7,036kb). The default settings are 192kbit bit rate and 44100 sample rate, and of course stereo. Do you (or anyone) know what we can lower the kbit rate to and not notice a hit in the quality?
    Thanks.
    unless you have a very well trained ear or something goes wrong with the conversion you probably wont notice any difference in sound quality, winamp has plugins that can convert entire playlists.
    01-27-09 07:06 PM
  15. DavidDBlackwell's Avatar
    I think the OP might have a really valid point with one that is listed and its not the music. I too have had a Storm that has always worked great and get frustrated with the posts that say it's not what it should be. One thing I always do, and thought you were suppose to, is remove the other OS's from my computer prior to installing the new beta or the one official release.

    Is it possible that the installer brings bugs from the prior versions to the newly installed version? I'm no programmer but everyone who installs every beta OS released likely has others on their computer....could it really be that easy?!?!
    CX actually mentioned it a long time ago in Don's very helpful thread on how to update to a leaked os. Most of the things I did were first tried by others and are scattered in threads throughout... I think the only truly original thing I did was convert ALL my music that I wanted to d/l to the phone... I had tried using only songs tagged [I]mp3[I] and that didnt work.

    The most important thing for me was realizing that the OS wasn't crap but the rules had just changed... my practice of having 3,4, or 5 different digital file protocols is the culprit. This build is less unstable than it is intolerant.

    on a totally unrelated note... i just noticed i upgraded from "nubie" to "user". sniff sniff.... I'm so proud!
    Last edited by DavidDBlackwell; 01-27-09 at 07:28 PM.
    01-27-09 07:16 PM
  16. rellims's Avatar
    CX actually mentioned it a long time ago in Don's very helpful thread on how to update to a leaked os.
    Gotcha, must have missed that post. Its always worked for me doing that way. Never had a single issue. Each OS upgrade just makes it faster for me.
    01-27-09 07:19 PM
  17. soxfan143's Avatar
    sorry for the newb question but what are bbthumb files and where do I delete them? I to was running .90 for a few days with out any issues until yesterday and I had like 5 random reboots and a few freezes and I finally went back to .75. And it is so slow after running .90 for a few days. I'm going to try this but I have no idea how to delete the bbthumb files. Thanks guys.
    01-27-09 07:33 PM
  18. b121's Avatar
    Just another experience...

    I've had limited issues and no automatic reboots (since exchanging my 8703e). I just download the file each time one is posted, execute it and let it do its thing. I've never bothered with a wipe (but once had to remove a vendor.xml file and once had to disable my internet connection). When I do have a strange bug with the .90 gui (e.g., symbols in the phone, not recognizing the phone pause, web not allowing "Select" mode, attachments not opening, alarm clock accepting changes, etc), I just did a battery pull (maybe once every other day) and things cleared up.

    fyi, I do have the phone set to 1XEV.
    01-27-09 07:35 PM
  19. DavidDBlackwell's Avatar
    sorry for the newb question but what are bbthumb files and where do I delete them?
    The thumb file is a hidden file used by the storms gui and is not dangerous to delete... when it doesn't find one it needs it generates a new one. it seems that old thumb files disagree with the new OS.

    to find them... do a file search from your computer (with your bb connected) on both the device and the media card click the option allowing it to search for hidden files. Search for any file starting with bbthumb, and delete all the ones you find. You should be able to delete them right from the search screen.
    01-27-09 07:51 PM
  20. b121's Avatar
    Figures... just had my first reboot... that will teach me to post . I was listening to an mp3... not sure what process kicked off in the background to trigger it.
    01-27-09 07:51 PM
  21. DavidDBlackwell's Avatar
    Figures... just had my first reboot... that will teach me to post . I was listening to an mp3... not sure what process kicked off in the background to trigger it.
    lol....

    That doesn't surprise me... this build is pretty touchy around media files. It doesn't even seem to like to change media formats within the same family. Total uniformity seemed to do it for mine.
    01-27-09 07:57 PM
  22. RetBchBoy's Avatar
    David, it seems to me that an OS needs some time to settle in. Like it gets stronger as the days go by.
    Is it just me?
    01-27-09 08:04 PM
  23. DavidDBlackwell's Avatar
    David, it seems to me that an OS needs some time to settle in. Like it gets stronger as the days go by.
    Is it just me?
    MMM I have seen that on several threads and i must admit have noticed it myself. The only thing I can think is that it may be becoming more stable because it is writing new thumb files, caches and temps and is slowly weeding out incompatible data..... only a guess though...
    01-27-09 08:08 PM
  24. andydmd's Avatar
    I have seen this posted several times regarding conversion of aac files to mp3. Please remember that converting one type of compressed file (aac) to a different type of compressed file (mp3) by definition will degrade the music. Typically the sound will be somewhat more "mushy" with loss of crispness. This may or may not be bothersome, but I prefer not to have to degrade my music in order to have the media play correctly. I'm still waiting for the media player bug to be fixed in .90. My other small beef is the volume control is too sensitive. I keep switching to the next song when I press volume up, even if I'm not holding the button for more than 1/2 second.
    01-28-09 06:23 AM
  25. aghart's Avatar
    The thumb file is a hidden file used by the storms gui and is not dangerous to delete... when it doesn't find one it needs it generates a new one. it seems that old thumb files disagree with the new OS.

    to find them... do a file search from your computer (with your bb connected) on both the device and the media card click the option allowing it to search for hidden files. Search for any file starting with bbthumb, and delete all the ones you find. You should be able to delete them right from the search screen.
    Do you delete the bbthumb files before or after you update the OS?
    01-28-09 08:29 AM
71 123
LINK TO POST COPIED TO CLIPBOARD