Built for Business - Learn more about BlackBerry KEY2
  1. mikeyrocks's Avatar
    My phone was set to auto shut off at night. I tried to turn it on and it would not respond. I tried two battery pulls, and also a full power off. Still, it won't turn on. I disabled the auto shut down. The device is on, but not the phone. I must be doing something incorrectly...
    01-27-09 03:40 AM
  2. NFLBlitze1's Avatar
    i would have to agree with jrohland sounds like a dead battery
    01-27-09 07:21 AM
  3. FINGER360's Avatar
    If all else fails take it to the store and let them take a look. Although in my experience they don't do much they will try, and if they cant fix it they will get it taken care of.
    01-27-09 07:34 AM
  4. dubge's Avatar
    I just had this happen and even though I had the phone on the charger all night it didnt charge and the battery was dead. I charged the phone for a while and every thing was back to normal, not sure why it wouldnt have charged though and ran the battery down from a 1/2 charge in less then 6 hours
    01-27-09 07:38 AM
  5. petaf's Avatar
    This option doesn't work: I tried it twice and both times phone didn't turn back on in the morning...
    01-27-09 08:41 AM
  6. pmariecof's Avatar
    Did you ever figure out how to turn the phone back on? I'm having the same problem and the battery is fully charged. Thanks!

    Just got off the phone with Blackberry support - they told me even if the phone is off and it says "off" in the top right corner, dial a phone number anyway. After hitting the green send key it will ask if you want to "restore connections", highlight and select this. It goes through a short restore process and viola! the phone is back on. They also said it is a good idea NOT to turn the device off. Just charge it while it's still on.
    Last edited by pmariecof; 02-02-09 at 10:00 AM.
    02-02-09 09:35 AM
  7. djb53's Avatar
    My BB Q10 won't complete the startup. It goes as far as the BB icon and completes the blue circle around the BB icon. The bottom of the screen says" Finalizing device setup" and that is as far as it goes. I have tried all the suggestions on the sites, remove battery (several times in fact). Leaving the battery out for a long time, hooked it to the computer and tried to get something moving. I took it to the dealer and they couldn't help. Phone is 16 months old (off warranty) and I am still in a contract for another 7 months. I also can't back up any data. I was also told that a factory restart (which all my data would be lost) might not work. Any suggestions?? Don't really want to spend the money on a new phone or spend the money buying out the contract.
    Last edited by djb53; 01-18-16 at 01:47 PM.
    01-18-16 10:30 AM
  8. rebroker2009's Avatar
    7 years later and still going lol

    Blackberry Passport Running 10.3.2.2813
    01-18-16 10:37 AM
  9. LSDBerry's Avatar
    Yeah my Lumia 950 wouldn't turn on, so I tried a battery pull and then re loading OS 10 with the autoloader, then I realised that it wasn't a Blackberry so I took it to the Apple store who told me that what I had there was actually a juicer. This also explained why my ear was bleeding last time I tried to make a phone call.

    Posted via CB10
    03-25-16 05:21 PM
  10. John Vieira's Avatar
    Yeah my Lumia 950 wouldn't turn on, so I tried a battery pull and then re loading OS 10 with the autoloader, then I realised that it wasn't a Blackberry so I took it to the Apple store who told me that what I had there was actually a juicer. This also explained why my ear was bleeding last time I tried to make a phone call.

    Posted via CB10
    Lsdberry indeed

    Posted via overheating lollipop Priv
    03-25-16 10:04 PM
LINK TO POST COPIED TO CLIPBOARD