1. hazmat1565's Avatar
    I am having a serious problem w/ charging my storm. It gets plugged in every night, it charges then when I awaken in morning it is completly dead and phone will not help. Any ideas?
    09-16-09 08:12 AM
  2. greydarrah's Avatar
    It's possible that the port on your phone had gotten damaged, but you can try this...

    battery wont get charged...

    I found this post from someone else...

    Take the battery out of the phone, plug the wall charger into the Storm then into the wall. After a minute or so, you should get a battery icon indicating the battery is missing. Once you see that icon, place the battery back in while the charger is still plugged into the phone and plugged into the wall. It should start charging, then put the back back on.
    09-16-09 08:15 AM
  3. hazmat1565's Avatar
    will do any other ideas. desperate.
    09-16-09 08:18 AM
  4. allenberry's Avatar
    are you using the official blackberry charger that came with the storm? most after market home chargers cause the storm to freeze and sometimes not charge
    09-16-09 06:01 PM
  5. BattyBugs's Avatar
    Don't feel bad. Mine won't charge any way but with the car charger any more. It isn't even acknowledged by the desktop any more. Talk about frustrated.
    09-16-09 08:51 PM
  6. Testingchip's Avatar
    When mine gets below 50% sometimes I plug it in and let it go.
    Come back in an hour and no change. It does get old but I have found if you turn the radio off for about 10 to 15 min. it will charge. I have no idea if it's the battery or what but it works for me. Just go to manage connections and stop all.
    It only seems an issue with me if the battery gets low so I try not to let it get to 50 or below.
    09-16-09 10:03 PM
  7. ekyle125's Avatar
    Every night that I turn it off first using the "turn off" option so my alarm will wake it up in the morning. I will plug it in overnight and its good to go in the morning. Have you tried a different outlet?
    09-17-09 05:30 AM
  8. jimstratus's Avatar
    Same problem sure its micro port. Bought external charger and spare battery from crackberry store. Now as long as sync part keeps working good to go. Cheaper than having port replaced

    Posted from my CrackBerry at wapforums.crackberry.com
    09-17-09 06:32 AM
  9. ekyle125's Avatar
    How long have you had it? If it is less than a year and the port is the problem then VZW should do a warranty replacement for you.
    09-17-09 08:08 AM
LINK TO POST COPIED TO CLIPBOARD