01-30-11 04:32 PM
475 ... 16171819
tools
  1. 64tracks's Avatar
    The source is here... http://alphapyro.com/bbtheme/x1b5.kb3.zip
    Let me know if you have any problems.
    12-23-09 12:21 PM
  2. rcklesslydriven's Avatar
    Does anyone use awardspace.com and know how I can make an ota link

    Posted from my CrackBerry at wapforums.crackberry.com
    12-23-09 02:08 PM
  3. rcklesslydriven's Avatar
    I am using trying to use the hidden dock theme from theme 2 by zachriel. I have changed the dock background a little by making it a little less transparent and adding a little color to the top button. I also removed the top two icons.

    Now however when I import it into theme builder i get an error.

    "SVG failed to import correctly.
    Certain portions of the SVG may not be rendered correctly.
    The SVG file: C:\Users\Jonathan\Desktop\Icon sets\Blackberry\Storm\COD MW 2\bottomDockred.svg may not be rendered correctly for the following reasons:

    "

    It doesn't show me the error however that is all that is posted. And it will not render in the simulator. Any help is appreciated!
    12-24-09 12:14 AM
  4. texassteve's Avatar
    Yep, I love the theme, but had the same issue.

    I am using trying to use the hidden dock theme from theme 2 by zachriel. I have changed the dock background a little by making it a little less transparent and adding a little color to the top button. I also removed the top two icons.

    Now however when I import it into theme builder i get an error.

    "SVG failed to import correctly.
    Certain portions of the SVG may not be rendered correctly.
    The SVG file: C:\Users\Jonathan\Desktop\Icon sets\Blackberry\Storm\COD MW 2\bottomDockred.svg may not be rendered correctly for the following reasons:

    "

    It doesn't show me the error however that is all that is posted. And it will not render in the simulator. Any help is appreciated!
    12-24-09 10:00 AM
  5. jaxjon's Avatar
    Jax

    I have opened an account on awardspace.com but can not seem to figure out what to do now to upload my files and create and OTA link for my themes
    You can use their file manager from the control panel on the site after you log in to upload or you can use ftp to upload. Your ftp address will be ftp://whatever.awardspace.com and you would use your login and password along with that in an ftp program or internet explorer should work also. For exact settings look for documentation on their site. I will look at my settings later and check to see if there is anything else I left out.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-24-09 10:38 AM
  6. SANDOFF#CB's Avatar
    could someone post the OTA for Theme 14 from GreekElite. just looking for it and im not good with plasmic
    12-29-09 10:48 PM
  7. Sciurus's Avatar
    First let me say that you guys rock. Thanks for letting ignorant newbies like me leech off your hard work. And a special thanks to jaxjon for post his explanation of sliding docks in post #303. I'm brand new to theme building (to graphic programming of any kind actually) and this thread has been just what I needed to get a jump start.

    Having said that, now I have a question. How do I get the icon text to show up on my Weatherbug icon on the home screen?
    01-06-10 08:47 PM
  8. jaxjon's Avatar
    First let me say that you guys rock. Thanks for letting ignorant newbies like me leech off your hard work. And a special thanks to jaxjon for post his explanation of sliding docks in post #303. I'm brand new to theme building (to graphic programming of any kind actually) and this thread has been just what I needed to get a jump start.

    Having said that, now I have a question. How do I get the icon text to show up on my Weatherbug icon on the home screen?
    The weatherbug text will only show when you make a Zen icon in Theme Builder and put it on the home screen. The icons made in Composer do not have text. If you have questions about how to do that I will answer them.
    01-06-10 09:02 PM
  9. MizMimi's Avatar
    Love them all! Going to see what I can create.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-06-10 10:58 PM
  10. Sciurus's Avatar
    Thanks, jax. I put a zen item up there, set it to "device application order" and loaded it into the simulator. Voila! I had app #1 up there WITH text label. But... the first icon in my sliding dock is also app #1. How do I fix that?

    Thanks in advance.
    01-07-10 10:04 AM
  11. robvb68's Avatar
    Thanks, jax. I put a zen item up there, set it to "device application order" and loaded it into the simulator. Voila! I had app #1 up there WITH text label. But... the first icon in my sliding dock is also app #1. How do I fix that?

    Thanks in advance.
    You have to manually edit your SVG file in Notepad. In the early portion of the file you should see a section similar to this:

    <g id="icon5"
    transform="translate(194.936 -52) scale(0.964262 1)">
    <!-- pz:tag type="button" -->
    <useApplicationIcons app-id="slot5"

    Where the slot number is, schange it to +1 (in the above example I would change it to 6).

    Later in the file you will see sections similar to this:

    <loadScene xlink:href="x-exec://slot9" begin="icon9.activate"/>
    <animate xlink:href="#img_1_1_204" id="_anim_357" attributeName="visibility" begin="icon9.focusin"
    values="hidden;hidden"
    keyTimes="0;1"
    dur="0.45s" fill="freeze"

    Again, change the slot number to +1 (10 in this example).

    Do this for however many icons you have in your SVG file, and do it for both sections for each.

    Hope this helps!
    Last edited by robvb68; 01-07-10 at 10:35 AM.
    01-07-10 10:26 AM
  12. Sciurus's Avatar
    You have to manually edit your SVG file in Notepad. In the early portion of the file you should see a section similar to this:

    <g id="icon5"
    transform="translate(194.936 -52) scale(0.964262 1)">
    <!-- pz:tag type="button" -->
    <useApplicationIcons app-id="slot5"

    Where the slot number is, schange it to +1 (in the above example I would change it to 6).

    Later in the file you will see sections similar to this:

    <loadScene xlink:href="x-exec://slot9" begin="icon9.activate"/>
    <animate xlink:href="#img_1_1_204" id="_anim_357" attributeName="visibility" begin="icon9.focusin"
    values="hidden;hidden"
    keyTimes="0;1"
    dur="0.45s" fill="freeze"

    Again, change the slot number to +1 (10 in this example).

    Do this for however many icons you have in your SVG file, and do it for both sections for each.

    Hope this helps!
    Thanks! I'll try it out and let you know.

    Maybe if I do enough manual coding like this I'll eventually start to understand what all that stuff actually means instead of just cutting and pasting.

    Or at least have a theme to post here.

    Someday. Soon, I hope.
    01-07-10 11:01 AM
  13. jaxjon's Avatar
    You need to go into your svg file and change the slot numbers all up by 1 search for slot and when you find one change its number slot0 becomes slot1 and on up till you have done them all.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-07-10 11:24 AM
  14. Sciurus's Avatar
    Okay, that worked. On the simulator, at least. Which brings me to a hopefully hypothetical question. Worst case scenario, how bad can I mess up my Storm with a poorly written theme? I mean, if I totally screw this theme up and then load it onto my Blackberry, it's not gonna like, burst into flames or anything, right?
    01-08-10 03:33 PM
  15. jaxjon's Avatar
    Run your theme on the Sim, if it is full of errors it will tell you. If it runs on the Sim then it will run on the Storm. If you don't like it you can just change to another theme or default and delete the old one. No worries. Just test on Sim first that all.
    01-08-10 05:31 PM
  16. SANDOFF#CB's Avatar
    could someone post the OTA for Theme 14 on the 1st page from GreekElite. Thanks
    01-13-10 08:26 AM
  17. jaxjon's Avatar
    I don't think there ever was one. You can download the desktop load files and load through desktop manager.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-13-10 05:38 PM
  18. teostar's Avatar
    Hey guys I used wat learned here an made a theme I called dimension for storm. ya'll can check it out. I started a thread in the 9520/9550 forum. "old skool theme for storm" check it out.
    I don't have an Ota only pics. Anybody wanna try PM me I'll email it.
    Thanx guys.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-14-10 09:32 PM
  19. gszeman's Avatar
    Hi all,

    Thank you all for putting this together...I am just beginning to give making my own themes a try. I really like Them 13...is there a working OTA download for that one?...I'd like to use that theme until I can work on my own...if anyone knows I'd appreciate it...thanks again!

    Six
    01-15-10 11:34 AM
  20. deejayburnout's Avatar
    Some nice themes here.

    Might have to much around and see what I can come up with myself

    Some of the ota links on the first page are down.

    Boo

    Posted from my CrackBerry at wapforums.crackberry.com
    01-16-10 08:13 AM
  21. jaxjon's Avatar
    If the links are down then you would need to contact the maker of the theme in question, which should be listed with the theme. PM or email them and ask for the files. It is possible some may not frequent the forums anymore.
    01-16-10 09:06 AM
  22. hyne's Avatar
    hi guys. I'm making my 1st theme playing with svg. First try it leaked so much, and i found what maybe causing it. I forgot to optimize the size of images to minimum.

    Then today i rechanged all the images, i manage to reduce the file size quite a lot. then i tested it, first reboot it minus 0,5 mb then for 10-15 minutes on standby, it drops suddenlly 1 mb. and for now it stayed -2mb since startup for 4 hours.

    Is it bad or normal ?

    sorry for my bad english
    01-16-10 09:08 AM
  23. deejayburnout's Avatar
    Thanks to jaxjon post #303 I was able to add a sliding dock into this theme. I think it's really slick now. DM download only but anyone can feel free to host the OTA. Maybe we can put this on the first page?




    I am trying to modify this theme to make it a more traditional today theme.

    Using the svg file, it seems to start showing icons for the appliciation for the item there in the device order. how do you change this to start at 1.

    Also how do you get the icons to have a focus on them.

    Sorry a bit of a noob when it comes to svg files.
    01-16-10 02:30 PM
  24. jaxjon's Avatar
    I am trying to modify this theme to make it a more traditional today theme.

    Using the svg file, it seems to start showing icons for the appliciation for the item there in the device order. how do you change this to start at 1.

    Also how do you get the icons to have a focus on them.

    Sorry a bit of a noob when it comes to svg files.
    when you are in the svg, slot0 = app#1 or the top left app in the main app list. If you want it to start with the second icon then use slot1. For each icon there are 2 places in the svg to change.

    This is an example of how an icon receives focus.

    Code:
     <animateTransform xlink:href="#Layer_2" id="_anim_l26" attributeName="transform" type="translate"
    		to="0,-266"
    		dur="0.4s"
    		fill="freeze"
    		begin="app1_Button.focusin"	/>
    01-16-10 03:33 PM
  25. deejayburnout's Avatar
    For some unknown reason the svg file now works as I need it to without me doing as you say.

    Wierd

    Done my first run of the theme and I hope to post pics tonight and the files.

    Still testing it for bugs

    Posted from my CrackBerry at wapforums.crackberry.com
    01-17-10 08:36 AM
475 ... 16171819
LINK TO POST COPIED TO CLIPBOARD