1. rfin16's Avatar
    My Q5 has suddenly started showing an error message suggesting that I "use the charger that came with this device" when plugged in on that charger. Sometime it then stops charging, other times charges to completion.

    Does anyone know why this could be a problem? I have used battery backup chargers a couple of times, but otherwise nothing has changed and battery health on the device, which is less than a month old, is showing Good in BB diagnostic app. Could the charging link have been damaged by using such batteries, or is it more likley a defective cable? (I have already tried two different charging cubes from Blackberry with the same results).

    Thanks for your help.
    05-17-15 11:21 PM
  2. BB-JAM215's Avatar
    If you've been using the same cable with different chargers and always getting the error message, then you should definitely try a new cable. Hopefully that will solve the problem.
    05-18-15 12:41 AM
  3. moegh's Avatar
    The old short usb cable is great for charging, it's small but good

    CB10 - Q10
    05-18-15 01:16 AM

Similar Threads

  1. Cool Features but Lame Devices
    By CrackedRosco in forum General BlackBerry Discussion
    Replies: 151
    Last Post: 05-23-15, 01:48 PM
  2. Anybody here have the gold passport?
    By bap3221 in forum General BlackBerry Discussion
    Replies: 8
    Last Post: 05-21-15, 09:45 AM
  3. Frozen home screen when using Android App
    By Sillydra in forum BlackBerry Passport
    Replies: 2
    Last Post: 05-18-15, 11:30 AM
  4. How to login to Sound Cloud with Blackberry Passport, google+?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 05-18-15, 05:28 AM
  5. got a BB 9930 on eBay from US. problem is that i can't use a few features
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 05-17-15, 05:33 PM
LINK TO POST COPIED TO CLIPBOARD