1. shravan kumar10's Avatar
    Hi, I dont know whats wrong with my lil q5, but since from morning, its signal reception is very weak, I mean its really terrible, I cant browse web anymore, im not even using 3G/4G, just edge, thats all, is there anyway I can fix this issue????? Tried reboot. Issue still persists
    Help me with signal reception-img_20150925_182830.png

    Sent from qualified q5
    09-25-15 03:03 PM
  2. paulwallace1234's Avatar
    You did contact your operator?

    Posted via CB10 v....not telling
    09-25-15 03:06 PM
  3. shravan kumar10's Avatar
    No, my dad's q5 is having full signal, same carrier...

    Sent from qualified q5
    09-26-15 01:31 AM
  4. rebroker2009's Avatar
    Check your network settings

    Blackberry Passport running 10.3.2.2639
    09-26-15 03:55 AM
  5. lift's Avatar
    Hi, I dont know whats wrong with my lil q5, but since from morning, its signal reception is very weak, I mean its really terrible, I cant browse web anymore, im not even using 3G/4G, just edge, thats all, is there anyway I can fix this issue????? Tried reboot. Issue still persists
    There is no BlackBerry symbol next to the "e" near the bars. Once in a while my phone will lose that symbol. What I do is turn on airplane mode for a minute and then switch off airplane mode and wait for the radios to fully turn back on.
    If that does not work, try shutting the phone off. Removing the SIM and cleaning it a little and putting the SIM back in. See if that helps.
    If none of that works, contact your carrier. Maybe they have to reprovision your SIM.
    shravan kumar10 likes this.
    09-26-15 11:52 PM
  6. shravan kumar10's Avatar
    It worked! Thanks z50!

    Sent from qualified q5
    lift likes this.
    09-28-15 10:49 AM
  7. lift's Avatar
    It worked! Thanks z50!

    Sent from qualified q5
    I'm assuming the airplane mode toggle did it?
    09-28-15 12:37 PM
  8. shravan kumar10's Avatar
    No, I removed sim card and rebooted! Now its all good, I think there was a problem with sim card.

    Sent from qualified q5
    lift likes this.
    09-28-15 02:03 PM
  9. lift's Avatar
    No, I removed sim card and rebooted! Now its all good, I think there was a problem with sim card.

    Sent from qualified q5
    Great. Glad I could help.
    shravan kumar10 likes this.
    09-28-15 03:44 PM

Similar Threads

  1. Fight for BBOS10
    By XCKocho in forum BlackBerry Priv
    Replies: 50
    Last Post: 10-04-15, 11:40 AM
  2. No, It Doesn't Come With BB10
    By tufcustomer in forum BlackBerry Priv
    Replies: 10
    Last Post: 09-25-15, 07:52 PM
  3. "Why we're teaming up with Google for an Android phone"
    By cyrilfournier in forum BlackBerry Priv
    Replies: 3
    Last Post: 09-25-15, 05:21 PM
  4. Replies: 27
    Last Post: 09-25-15, 03:53 PM
  5. Replies: 6
    Last Post: 09-25-15, 03:19 PM
LINK TO POST COPIED TO CLIPBOARD