03-14-14 12:15 PM
28 12
tools
  1. Mr Chris's Avatar
    I just got my Q10 and so far I've been pretty happy with it. There is one small issue though which I am not able to resolve...

    I used the Q10 on two different Wi-Fi networks (at work and in a hotel) and it worked just fine but when I want to use it on my Wi-Fi network at home it just doesn't work. It connects to the network without any problem but when I open the browser it just tells me "No Internet Connection"...
    So my guess would be that the Q10 is probably not happy with the settings of my router but when I connect any other device (Nokia phone, iPhone etc.) to the network it works perfectly...

    Thanks for your help...
    06-09-13 11:51 PM
  2. wxmancanada's Avatar
    Welcome to CrackBerry!

    Very weird situation. Whenever my Z10 or Q10 runs into a WiFi network it doesn't like, it normally avoids it by not connection to it at all. Seems like there's something else going on here though. With that in mind, do you have any special settings enabled on your home router? MAC filtering, IP leases, guest mode, etc?

    Are you able to verify the Q10 actually gets an IP when it connects to your home network?
    You can check by going into Settings, then About, then under Category select Network. There should be a "Mobile Network" section and a "Wi-Fi" section.
    Mr Chris likes this.
    06-09-13 11:59 PM
  3. Omnitech's Avatar
    There are also some built-in network troubleshooting tools you can use if you are connected to WiFi.

    Go to Settings/Network Connections/Wi-Fi, then press the "Advanced" button at the bottom.

    The default page will show your connection stats, which network you are connected-to.

    Heads-up #1: Make sure you ARE in fact connected to your own network. If your network has a common name, scrutinize this very carefully. Sometimes people will set up a "copycat" network to try to lure you to connect to some other system so they can snoop on your traffic. If you know your router's "MAC Address" you can verify that here.

    Then at the top of that page press the "Device Information" button and scroll to "Ping". Let's try to communicate with a commonly known IP address, Google's public DNS server. Leave all settings at default except at the bottom under "Ping To", type in the following string of numbers and periods exactly:

    8.8.8.8


    Then click "Send".

    Then under "Ping Results you should see a series of text reports

    64 bytes from 8.8.8.8: icmp_seq=3 ttl=45 time=...
    64 bytes from 8.8.8.8: icmp_seq=3 ttl=45 time=...
    64 bytes from 8.8.8.8: icmp_seq=3 ttl=45 time=...
    64 bytes from 8.8.8.8: icmp_seq=3 ttl=45 time=...
    Then after that is done, at the top it should print:

    4 packets transmitted, 4 packets received, 0% packet loss...


    If instead it prints something like "destination host unreachable", or "0 packets received", or "no reply", then you have a basic network connectivity problem.

    Post back and I will take you through the next step if that does not work.
    Mr Chris likes this.
    06-10-13 04:55 AM
  4. Mr Chris's Avatar
    As far as I know I don't have any special settings setup on my router (I double-checked the ones you've mentioned)... and I never came across this problem before with any other gadget I have here.
    When I check under Settings>About>Category>Network it gives me this information:
    Wi-Fi
    IPv6
    fe80::96eb:cdff:...
    IPv4
    169.254.144.94/16
    MACAdress
    94:EB:CD:43:B0...
    IMS Status
    No
    06-10-13 05:13 AM
  5. Mr Chris's Avatar
    ...Then at the top of that page press the "Device Information" button and scroll to "Ping". Let's try to communicate with a commonly known IP address, Google's public DNS server. Leave all settings at default except at the bottom under "Ping To", type in the following string of numbers and periods exactly:

    8.8.8.8


    Then click "Send".

    Then under "Ping Results you should see a series of text reports



    Then after that is done, at the top it should print:





    If instead it prints something like "destination host unreachable", or "0 packets received", or "no reply", then you have a basic network connectivity problem.
    I did this and the results it gave me are:

    4 packets transmitted, 0 packets received, 100% p (sorry, can't see the rest of it)
    ---8.8.8.8 PING Statistics---
    ping: sendto: No route to host
    ping: sendto: No route to host
    ping: sendto: No route to host
    ping: sendto: No route to host

    Thanks again...
    06-10-13 05:19 AM
  6. Omnitech's Avatar
    As far as I know I don't have any special settings setup on my router (I double-checked the ones you've mentioned)... and I never came across this problem before with any other gadget I have here.
    When I check under Settings>About>Category>Network it gives me this information:
    Wi-Fi
    IPv6
    fe80::96eb:cdff:...
    IPv4
    169.254.144.94/16
    MACAdress
    94:EB:CD:43:B0...
    IMS Status
    No

    The "169.x.x.x.x" is an "auto IP" address, basically what goes there if it cannot find a DHCP server to assign it an address.

    So you have a basic connectivity issue.

    What does the default under "Advanced" in the WiFi section say for "AP MAC Address"?

    That will help determine if you are connected to some network that is not your own.

    There should also be a channel listed there, and a signal level. Those would help as well.

    WiFi can be very dodgy because it uses an unlicensed spectrum and it is subject to interference from all sorts of external factors including other WiFi networks, Bluetooth devices, cordless phones, baby monitors, and microwave ovens.

    Most people have reported outstanding performance of WiFi on the BB10 devices but it's possible something is interfering there in your environment.
    Mr Chris likes this.
    06-10-13 06:15 AM
  7. Mr Chris's Avatar
    What does the default under "Advanced" in the WiFi section say for "AP MAC Address"?
    That will help determine if you are connected to some network that is not your own.
    There should also be a channel listed there, and a signal level. Those would help as well.
    It says:

    Status
    Connected
    Signal Level
    -77dBm
    Profile Name
    scppp
    SSID
    scppp
    Channel
    2
    AP MAC Address
    1c:7e:e5:49:b3:2f
    Security Type
    WPA Personal
    Connection Data Rate
    72Mbps
    06-10-13 06:32 AM
  8. Omnitech's Avatar
    It says:

    Status
    Connected
    Signal Level
    -77dBm
    Profile Name
    scppp
    SSID
    scppp
    Channel
    2
    AP MAC Address
    1c:7e:e5:49:b3:2f
    Security Type
    WPA Personal
    Connection Data Rate
    72Mbps


    OK. Is your WiFi router/access-point made by D-Link?

    If so, you're probably connected to the right signal. (IF you want to be extra careful, double-check the MAC address of your router on its web administration page)

    So the question is why are you not getting an IP address.

    Do you have your router set with filters to only allow certain devices to connect?

    If not, I would consider :

    1. Turn off WiFi on your Q10
    2. Power-cycle the router, let it boot and get ready for a few minutes
    3. Verify that you have internet connectivity on another WiFi device first - ie try to browse some recently-updated webpages (ie news site)
    4. Turn on WiFi on Q10, verify connection to scppp
    5. Run tests as previous
    06-10-13 06:49 AM
  9. Mr Chris's Avatar
    OK. Is your WiFi router/access-point made by D-Link?

    If so, you're probably connected to the right signal. (IF you want to be extra careful, double-check the MAC address of your router on its web administration page)

    So the question is why are you not getting an IP address.

    Do you have your router set with filters to only allow certain devices to connect?

    If not, I would consider :

    1. Turn off WiFi on your Q10
    2. Power-cycle the router, let it boot and get ready for a few minutes
    3. Verify that you have internet connectivity on another WiFi device first - ie try to browse some recently-updated webpages (ie news site)
    4. Turn on WiFi on Q10, verify connection to scppp
    5. Run tests as previous

    Yes, it is a D-Link router (DIR-655)...

    I double-checked the settings of my router but I can't see anything "unusual".. DHCP Server should be enabled (and it has a certain IP address range192.168.0.100 to 192.168.0.199), correct?

    I restarted the router but the problem is limited to the Q10, everything else works perfectly fine.
    (The readings under Advanced>Wi-Fi Information are also still the same... apart from that the channel has changed.)
    06-10-13 07:09 AM
  10. Omnitech's Avatar
    Yes, it is a D-Link router (DIR-655)...

    I double-checked the settings of my router but I can't see anything "unusual".. DHCP Server should be enabled (and it has a certain IP address range192.168.0.100 to 192.168.0.199), correct?

    I restarted the router but the problem is limited to the Q10, everything else works perfectly fine.
    (The readings under Advanced>Wi-Fi Information are also still the same... apart from that the channel has changed.)

    OK, well for some reason it's not talking to the DHCP server.

    Honestly that's the kind of thing that got me to stop using D-Link devices.

    Pity there doesn't appear to be a way to manually assign an IP address to the Blackberry, it would be handy for troubleshooting to assign a manual IP and see if it communicates.

    So if you select "Internet Connection" from the dropdown, does it display an IP address at the top? If so, what is it? How about DNS servers?
    06-10-13 08:39 AM
  11. kbz1960's Avatar
    Should be able to set a static IP for the BBRY.
    06-10-13 08:47 AM
  12. Mr Chris's Avatar
    OK, well for some reason it's not talking to the DHCP server.

    Honestly that's the kind of thing that got me to stop using D-Link devices.

    Pity there doesn't appear to be a way to manually assign an IP address to the Blackberry, it would be handy for troubleshooting to assign a manual IP and see if it communicates.

    So if you select "Internet Connection" from the dropdown, does it display an IP address at the top? If so, what is it? How about DNS servers?
    Yes, I know what you mean; I am about to look for another router now...

    If I select Advanced>Internet Connection there is an IP address at the top...

    169.254.144.94
    Subnet Mask
    255.255.0.0
    Default Gateway
    blank
    Primary DNS
    blank
    Secondary DNS
    blank
    Domain Suffix
    blank
    MTU
    1500
    Proxy Server
    blank
    Proxy Port
    blank
    06-10-13 08:49 AM
  13. Omnitech's Avatar
    Yes, I know what you mean; I am about to look for another router now...

    If I select Advanced>Internet Connection there is an IP address at the top...

    169.254.144.94
    Subnet Mask
    255.255.0.0
    Default Gateway
    blank
    Primary DNS
    blank
    Secondary DNS
    blank
    Domain Suffix
    blank
    MTU
    1500
    Proxy Server
    blank
    Proxy Port
    blank

    Before you do that, you might want to check the admin interface on the D-Link and verify that the Blackberry actually is associated with the wireless radio. To verify which device it is, use the device's MAC address, which you posted earlier. (94:EB:CD:43:B0...)

    D-Link | How do I log into my router?


    IF the Q10 is not even associated properly, it will never get an IP address.

    Another thing you can try is enter a static DHCP mapping for that MAC address. Here's the procedure for the DIR-655 - bear in mind this pertains to LAN hosts not wireless, which might be slightly different:

    D-Link | How do I configure DHCP reservation on my DIR series router?


    There also may be newer firmware that may help compatibility with some devices. You need to see which hardware revision of the device you have (usually listed on bottom side label), then check the support page for newer versions.

    D-Link | How do I upgrade my firmware on my DIR series router?
    Mr Chris likes this.
    06-10-13 06:17 PM
  14. Mr Chris's Avatar
    Before you do that, you might want to check the admin interface on the D-Link and verify that the Blackberry actually is associated with the wireless radio. To verify which device it is, use the device's MAC address, which you posted earlier. (94:EB:CD:43:B0...)

    D-Link | How do I log into my router?


    IF the Q10 is not even associated properly, it will never get an IP address.

    Another thing you can try is enter a static DHCP mapping for that MAC address. Here's the procedure for the DIR-655 - bear in mind this pertains to LAN hosts not wireless, which might be slightly different:

    D-Link | How do I configure DHCP reservation on my DIR series router?


    There also may be newer firmware that may help compatibility with some devices. You need to see which hardware revision of the device you have (usually listed on bottom side label), then check the support page for newer versions.

    D-Link | How do I upgrade my firmware on my DIR series router?
    Sorry, I was not at home all day...

    When I log-in to my router and I check Wireless>Connected Clients it gives me the Q10s MACa address (94:EB:CD:43:B0...) , mode (11n), Rate and Signal (100%), IP address 0.0.0.0.
    My D-Link runs the latest firmware update...

    I'll try that with the static DHCP (reservation) first thing tomorrow...
    06-11-13 04:35 PM
  15. Omnitech's Avatar
    Sorry, I was not at home all day...

    When I log-in to my router and I check Wireless>Connected Clients it gives me the Q10s MACa address (94:EB:CD:43:B0...) , mode (11n), Rate and Signal (100%), IP address 0.0.0.0.
    My D-Link runs the latest firmware update...

    I'll try that with the static DHCP (reservation) first thing tomorrow...

    OK, that's good info. So we have more or less narrowed it down to a DHCP issue.

    I assume the "rate and signal 100%" means that it has a good connection. That's important, because weak/congested/interference-laden wireless links are the source of a lot of connectivity problems.
    06-11-13 07:25 PM
  16. Mr Chris's Avatar
    OK, that's good info. So we have more or less narrowed it down to a DHCP issue.

    I assume the "rate and signal 100%" means that it has a good connection. That's important, because weak/congested/interference-laden wireless links are the source of a lot of connectivity problems.

    Again sorry for my late reply...
    What I tried recently was to assign a certain IP address to my Q10 via the DHCP reservation tool... no success!
    06-15-13 08:47 AM
  17. Omnitech's Avatar
    Again sorry for my late reply...
    What I tried recently was to assign a certain IP address to my Q10 via the DHCP reservation tool... no success!

    Next thing I would try is go to someplace with a public WiFi hotspot (or a friend's house with WiFi that you have access to) and see if you can connect.

    Because I have definitely seen cases where some routers had weird DHCP implementations that would not reliably assign IP addresses to hosts that request them.

    It's also theoretically possible that there is some bug with the Q10's IP stack, but since I've never seen any other complaint like this about either the Z10 or Q10, I'm more inclined at this point to blame the D-Link.

    You're absolutely sure you don't have a MAC address filter setup on the D-Link right? I used to use that in the old days when I wasn't as confident about the encryption or access-control protocols that some of the older devices were using. But then if you forget about it and try to connect something else, you can scratch your head for days wondering what's wrong until you remember that you have to add the new MAC address to the "allow" table.
    06-15-13 06:14 PM
  18. dbow27's Avatar
    I have this problem as well on my z10. I got so frustrated that I got a replacement device sent and still have the same issue so it definitely is something the way the phone reads the router. Every other device in the house works just fine on wifi.

    Posted via CB10
    06-15-13 09:17 PM
  19. Omnitech's Avatar
    I have this problem as well on my z10. I got so frustrated that I got a replacement device sent and still have the same issue so it definitely is something the way the phone reads the router. Every other device in the house works just fine on wifi.

    How did you determine it is the same problem?

    What brand/model of router are you using?
    06-15-13 09:21 PM
  20. dbow27's Avatar
    It is a netgear router with 2 wifi feeds from it.
    I just assumed it's the same problem as every post I read on this sounds like the same problem I am having. I am not in any way good with computers or routers so I don't know how to address the problem. Verizon had no clue so they swapped the phone out. Still having the same issue I believe it has to be the way the z10 reads the router

    Posted via CB10
    06-16-13 11:11 AM
  21. anon(870071)'s Avatar
    Welcome to CrackBerry!

    Very weird situation. Whenever my Z10 or Q10 runs into a WiFi network it doesn't like, it normally avoids it by not connection to it at all. Seems like there's something else going on here though. With that in mind, do you have any special settings enabled on your home router? MAC filtering, IP leases, guest mode, etc?

    Are you able to verify the Q10 actually gets an IP when it connects to your home network?
    You can check by going into Settings, then About, then under Category select Network. There should be a "Mobile Network" section and a "Wi-Fi" section.
    Above...this was my thought also.

    Posted via CB10
    06-16-13 11:35 AM
  22. tbro89's Avatar
    Hi there,

    I was wondering if anyone could help me. I'm also having trouble connecting to wifi networks on my Q10. The phone seems to refuse to connect. I always get the message "The maximum number of active profiles has been reached. You must disable or delete other saved active profiles. This profile has been saved and is disabled."

    I have tried rebooting the phone, turning the wifi on and off, deleting as many saved networks as I could (i have far fewer than 64), I've tried deleting and re-adding specific networks (this happens not on one specific router), and I've tried resetting the router.

    Has anyone had similar issues, or can offer some support tips? They would be greatly appreciated!

    "The network is disabled! Connecting to that network will reenable it. Do you still want to connect?"
    06-22-13 11:08 AM
  23. Omnitech's Avatar
    I was wondering if anyone could help me. I'm also having trouble connecting to wifi networks on my Q10. The phone seems to refuse to connect. I always get the message "The maximum number of active profiles has been reached. You must disable or delete other saved active profiles. This profile has been saved and is disabled."

    I have tried rebooting the phone, turning the wifi on and off, deleting as many saved networks as I could (i have far fewer than 64), I've tried deleting and re-adding specific networks (this happens not on one specific router), and I've tried resetting the router.

    How many saved profiles do you have?

    WiFi is a very imperfect system, in large measure because it's completely unlicensed and uncontrolled. So if you've got for example a profile saved with the SSID "linksys" (for example, your home network), you will inevitably run into all sorts of confusion because you will keep running into networks in the field called "linksys", but you cannot connect to them.

    And because WiFi is unlicensed and uncontrolled, there are oftentimes huge congestion problems which can be insurmountable. I live near a major university. You can pick up over 500 separate WiFi signals here depending on where in the house you are. Needless to say, that makes WiFi communication on common frequency bands almost impossible in many cases. (Used to have a portable cellular WiFi hotspot that would get so flustered by the RF situation here that after it was powered-on, would try to find an open channel to communicate on, and then after a couple of minutes just shut itself off because it could not find one.)
    06-23-13 12:41 AM
  24. Omnitech's Avatar
    I was wondering if anyone could help me. I'm also having trouble connecting to wifi networks on my Q10. The phone seems to refuse to connect. I always get the message "The maximum number of active profiles has been reached. You must disable or delete other saved active profiles. This profile has been saved and is disabled."

    I have tried rebooting the phone, turning the wifi on and off, deleting as many saved networks as I could (i have far fewer than 64), I've tried deleting and re-adding specific networks (this happens not on one specific router), and I've tried resetting the router.

    I found a posting elsewhere from someone with a Q10 who said that once he trimmed the saved-profile list down to about 30, it started working again:

    WiFi Problems with Q10 - Need to delete old WiFi Profiles to less than 64: [ BlackBerry Q10 ]


    And it may interest you to know that RIM/Blackberry received a patent for this WiFi profile selection mechanism about 2.5 years ago.

    https://www.google.com/patents/EP2242210A1?cl=en
    06-23-13 12:58 AM
  25. tbro89's Avatar
    Thank you for your help I also cut down my wifi profiles which helped... definitely less than 64 though!
    06-23-13 08:17 PM
28 12

Similar Threads

  1. Wi-Fi calling on the Q10
    By davidelsey0 in forum BlackBerry Q10
    Replies: 25
    Last Post: 11-28-13, 12:22 PM
  2. Wi-FI issue on Bold 9900 with Rogers
    By Rob_Berry2 in forum BlackBerry Bold 9930/9900
    Replies: 8
    Last Post: 04-27-13, 04:36 PM
  3. iPhone 3GS Wi-Fi Issue on iOS4
    By fabuloso in forum Apple iPhone/iPad
    Replies: 1
    Last Post: 07-10-10, 10:07 PM
  4. Wi-Fi Issues on 8900 Unlocked T-Mobile
    By tuffy1 in forum Other Carriers Worldwide
    Replies: 2
    Last Post: 09-10-09, 06:33 AM
  5. wi-fi issues on my blackberry curve 8900
    By fehrnazer in forum BlackBerry Curve 8900
    Replies: 2
    Last Post: 05-05-09, 12:53 PM
LINK TO POST COPIED TO CLIPBOARD